New External HD detected but not displayed

By JosephDezordi ยท 7 replies
Oct 14, 2006
  1. New 300 GB West.. Dig.. External drives detected ( PC makes the funny bell sound, ballon caption indicates found new hard ware), but not displayed in My Computer

    Have tried various USB ports, my other external drives ( maxtor ) are all working fine & reconised


    1. Turning Hard drive on & off
    2. Disconnectiong reconnecting
    3. Turning PC on & off

    I have purchased 4 of these drives & the problem is with all of them
    I saw the IDE cable being connected myself seemed to be done properly

    thanks for your help
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    If the HD's arent partitioned then they wont show in Explorer or my computer until you do.

    You need to go to disk manager and create partition's on it, to get there right click my computer and choose manage then disk management.

    If they dont show in there post back and let me know.

  3. JosephDezordi

    JosephDezordi TS Rookie Topic Starter

    Thanks I have gone into computer management
    it shows that
    My C: drive is partion/basic/NTFS/healthy(system) 11% free
    My I (F:)drive is partion/basic/Fat32/healthy(system) 0% free
    New Volume E:drive is partion/basic/NTFS/healthy 0% free
    The New drive appears to be detected as DISK1, Basic, 279 GB Online
    In the rectangular window with the cross hatching it says 279GB Unallocated

    I am afraid about wiping my other drives

  4. JosephDezordi

    JosephDezordi TS Rookie Topic Starter

    sorry I meant partition

    My C drive is partition/basic/NTFS/healthy(system) 11% free
  5. JosephDezordi

    JosephDezordi TS Rookie Topic Starter

    PS I also tired this new drive on another computer, a Note book with only one hard drive in it & the same problem occurs, ie the new drive is not detected in " My Computer"
    so the problem appears to be with the hard drive, but I am told they were formatted already

  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

  7. JosephDezordi

    JosephDezordi TS Rookie Topic Starter

    Thank you
    I didnt quite understand that last thread
    but I managed to solve the problem by using the disk management utility IDid myC600 told me about
    I discovered that the computer did find the disk, but I had to initial it & assign it a letter
    so thanks all for you help
  8. roxy

    roxy TS Rookie

    I have had an external usb removable storage unit for a long time (maxtor). I used it in both of my laptops and never had a problem with it. A few days ago, I plugged it in and it just didn't display on my computer or explorer. I tried all of the usb ports and nothing happened. (I did it in both laptops). It shows in the device manager under drives and on the safely remove hardware, but I cannot make it appear in my computer or explorer. Also, it doesn't appear on the Disk Management. I placed a standard usb device and it works perfectly, it even shows in the Disk Management under Disk 1, which it doesn't show when I plugged in the Maxtor unit. Can you help me with this issue??? I am new on this forum, so if you know of anybody that I can forward the message can you let me know? Thanks
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...