New Graphics Card Issues

By Cael
Mar 17, 2007
  1. Hi, all.

    I am new here, so please bear with me.

    I have been using a Radeon 9600 graphics card, but it died on me recently (I think the fan just went kaput). I replaced it with a GeForce 7300GT Sonic card, but right now, I am having problems with it working properly. Whenever I install the driver from the CD, it plays fine until the next time I boot up. It boots up fine, but when I get to my Windows desktop, everything stops working (i.e., I can't click on anything). The mouse cursor will still move around for a couple of minutes, and then even that hangs.

    I read the sticky, and so here are the information needed:
    1. Motherboard - Unknown
    2. Graphic interface - GE Force 7300GT Sonic
    3. Memory - 1Gb (2x 512Mb DDR Ram, I think)
    4. CPU - AMD Athalon XP 2800+
    5. CPU Speed - 2.8 GHz
    6. Power Supply Make/Model - ATX-450W/P4
    7. Watt output/Amperage - 450W total: 20A@12V, 40A@5Vdc, 28A@3.3Vdc

    I hope this is enough information. If not, please ask me, and direct me to where to get the information off the PC itself. I moved house recently, and the documentation is in the storeroom somewhere waiting to be found...
  2. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Hi and welcome to TS!! :)

    Try uninstalling the current drivers, and install the newest ones from Nvidia. Also make sure you have the latest DirectX, and chipset drivers :)
  3. Cael

    Cael TS Rookie Topic Starter

    Thanks for the reply.

    I have tried looking for the latest drivers in nVidia, but it seems that they no longer have them for the 7300. They only have them for the 7800/7900 and the 8800 in their archives. I have downloaded a generic one for XP from their site (the 91.31 driver), which I am hoping will work.

    I currently have DirectX 9.0c installed, which I think is the latest.

    I haven't done the chipset yet. I am presuming you mean the AMD Athalon drivers? If it is the motherboard drivers, then I am out of luck, since I don't know what MB it is...

    Update: I have tried the new generic driver, and it doesn't work. It keeps claiming that I don't have a compatible nVidia hardware installed. I have noticed that the card has a dual input cable connection (it is a split, so both actually goes to the same input slot on the card itself), but only 1 is plugged into the ATX power supply. Could this be an issue?
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...