New hdd's and massive install errors!

By foreverzero ยท 4 replies
Feb 4, 2007
  1. This is the third of fourth tech forum I am comming to for help and I am really running out of ideas and options.

    Heres what happned -

    I have an alienware m7700. After some heavy extensive use for over a year, the 2 hdd's started clicking and grinding, so under samsungs 3 year warranty, I had both of them replaced free of charge. The same exact model number drives, model # MP0603H 60 gig PATA, were sent back to me.

    Now on the old system, it was all configured to Raid0, and I wanted to do the same with these drives. So I installed the new hdd's into the caddy, set the jumpers into the correct stated posistion on and installed them using the same cables as the old drives.

    Upon booting the system, the bios came up with the "No array found" and I pressed ctrl-f to go set up my new array. I went into the auto setup by pressing 1 and set it so both drives were in the array, once I was finished I hit ctrl-y to save it. Thats when the error message came up saying "Error when modifying array, system will now reboot"

    Since then I have tried everything under the sun in order to get these drives to work. Ive moved the jumpers around to every different position. Switched the hdd's around in the caddy, tried my hdd's in another m7700 with the same cables. Also I tried loading it in ATA mode to just load the disk up as 2 60's but it went very slow and when it got to the partition menu, it came up with windows couldnt find the disk, and yes Ive tried loading with the f6 for both raid and non-raid.

    I also tried to put my gf's hdd into my system (she also has an m7700) and now her bios in her own computer will not detect her hdd, and im not really sure why. I tried to use her cables to connect my hdd to my mobo, but for some reason, they wouldnt fit in correctly.

    Basically Ive been fighting with this for 2 weeks trying to get it to work. This error message in the fastbuild bios no one else has seemed to have and im really out of ideas and options on what to do. And thanks to college, I dont have the money to bring it in to get repaired, so I'm trying to do everything on my own.

    If anyone has any ideas or suggestions, anything at all, I would be deeply greatfull.
  2. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Just a total shot in the dark, but have you tried doing a firmware update for your RAID controller? Since you've ruled out (somewhat) the drives by replacing them, then it makes sense to consider the controller might be doing something unexpected...

    Do the drives work on their own, singularly, in non-RAID mode? It might be worthwhile to check and make sure that each drive does indeed work. It certainly wouldn't be the first time someone has recieved a bum drive straight from the manufacturer's RMA dept.

    Try them seperarately on their own cable as single masters and run a drive diagnostc - verify that both drives are in good shape. There's a list of diagnostics on this forum. I know it sounds silly, but there is actually a disturbingly possibile chance you got another problematic drive from Samsung.
  3. raybay

    raybay TS Evangelist Posts: 7,241   +10

    Before you spend a lot of money, try formatting them, one at at time in another computer. Also check that the jumper pins are not bent. The drives that come back from Samsung are usually rebuilt or refurbs of defective drives... so there is the possibility of hidden errors... be sure they work or don't work in another machine, then call Samsung. Samsung has always been more fair with us than others when dealing with failed hard drives. If the drives are bad, Samsung will make good.
  4. tipstir

    tipstir TS Ambassador Posts: 2,475   +126

    PATA shouldn't be giving all these type of errors, but those you had prior were bad with the grinding an clicking noises they're gone. Did they send you brand new ones or Rebris..

    What happens when you just connect one and install the OS or can the system BIOS see these two drives?
  5. foreverzero

    foreverzero TS Rookie Topic Starter

    I did try setting up the raid array on another computer with the same error, but I didnt try to setup windows on them as the cd drive in the other computer wasnt working.

    The fastbuild bios does detect both hdd's, shows them both free and functional.

    One thing I have noticed is that in the fastbuild bios under drive assignment, sometimes the model number of the drives will change, the capacity will change from 42000 and 60000 and the udma mode will change from U2 to U5 randomly between bootups. I was thinking that might be showing some sort of connection error but Im not certain.

    Also how do I do a firmware upgrade? I have the most up to date bios I believe I can have that I got from the alienware forums, and I believe the fastbuild RAID bios is just part of that, but im not certain.

    Ok i tried setting up the disk 1 by 1 in ata mode.

    First one I put through went very slow getting to the windows setup screen. Once it did, it showed 6 partitions. The first 4 just disk not attached with setup cannot access this disk. Then the fifth showed "setup cannot access this disk" with
    "40893 mb disk 0 at Id5 on bus 0 on UlSata" under it. Whenever I hit anything, it dropped me into a bsod.

    When I tried the second disk, it basically had the same thing and dropped me into a bsod stating 0x00000050.

    It seems like the bios can find the disk, but when it comes to read/write its running into the issues of the drives dissapearing and such. And as for diagnostic utilities, when I tried to use the ones off samsungs site, it wouldnt even find the hdd's to look at.

    Also i tried disabling the card reader in my bios, it gave me the same error when trying to save the array plus during the windows setup it just said windows could not detect any hard drives connected, and didnt even make it to the partition menu. When I did it in ATA mode, it showed 2 partitions, the same "40893 mb disk 0 at Id5 on bus 0 on UlSata" and "setup cannot access this disk" over it. Its like it knows the drive is there, but something is keeping it from read/write.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...