New Here and need to know what IsWellKnownSid is

By Shknstrsgirl ยท 21 replies
Jun 14, 2006
  1. Hello name is Beth and I am new to the site. I also have a problem. I received a computer from my FIL and I have no idea what he did to it. It is running Windows 2000 Professional (and he is no professional....). I turned on the computer and I get the message: "The Procedure entry point IsWellKnownSid could not be located in the dynamic link library ADVAPI32.dll."

    I went to and of course no one knows who IsWellKnownSid is...I check out the registry like the site said and when I got to the last folder there is nothing but the default info...with no value set for the data column.

    Does anyone know what has happened...maybe something got deleted that wasnt supposed to?? This comes up when it goes to start up and goes to work on the network connections at start up.

    Any help would be great...thanks

  2. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    You can find info about that error by searching google for "IsWellKnownSid". This error usually appears with ADVAPI32.dll.

    There are two things you could try.

    1: Click start-run- and type regsvr32 advapi32.dll and hit ok. Then restart and see if it's gone. Or...
    2: Download or search your computer for a newer copy of advapi32.dll and replace the one in the system32 folder. Then run regsvr32 again.

    Somehow this may have to do with installing SP4. But maybe those two ideas will help.

    Good luck.
  3. Shknstrsgirl

    Shknstrsgirl TS Rookie Topic Starter


    I can't do a search for the cache...for some reason this computer wont do I did it folder by folder....I cannot find the dllcache folder in system32....and I've tried option 1 and it says it cannot find it...unfortunately I'm looking at probably having to download it onto a floppy and manually putting it back in...

    Is there another option for the dllcache search??? maybe there is another folder I can't get to??

  4. Peddant

    Peddant TS Rookie Posts: 1,446

    You can the download the .dll HERE.

    To find the dll cache you might have to -

    Open My Computer/Tools/Folder Options/View/

    Under the Hidden files and folders heading select Show hidden files and folders.
    Uncheckthe Hide protected operating system files (recommended) option. Click Yes,Click OK.
  5. Shknstrsgirl

    Shknstrsgirl TS Rookie Topic Starter


    Ok Vigilante and Peddant...I have FINALLY found the advapi32 cache....but I cant check the dates bc when I go to check the properties, I am given the "Windows Explorer is generating errors" stuff.

    Unfortunately after talking to the hubby I have found that I wont be able to get anything dl'ed for it since it doesnt have any internet connection and the one we have now isnt capable of dl'ing onto a CD rom...

    Is there any way to fix this without dl'ing something??

  6. Peddant

    Peddant TS Rookie Posts: 1,446

    I found the following from HERE
    Unless anyone else has other ideas,I think these are the only options.

    "1st thing you want to try is safemode(HERE ) and see if you can get in and check on the
    It will be in the C:\winnt\system32 and in the C:\winnt\system32\dllcache folder.(a hidden folder)
    If the file is the right size and the date is right in the dllcache folder copy it
    to the winnt\system folder and then try and reboot.

    If it's not you can download a copy of it from the net or pull a copy from the win2k
    cd disk.Use the Recovery Console to replace the file."

    File info - avapi32.dll is a part of an advanced API services library supporting numerous APIs
    including many security and registry calls.
  7. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    This may seem like a shot in the dark, but it's possible if you go in Safe Mode and RENAME the file, say, to "_advapi32.dll" and then restart again. The Windows File Protection will automatically replace the file for you from the dllcache or other backup location.

    Right-click My Computer and choose properties. And tell us what service pack you are running, it should say towards the top. Maybe somebody with the same version of 2000 can get you the file, it is small enough to fit on a floppy easy.
  8. Shknstrsgirl

    Shknstrsgirl TS Rookie Topic Starter

    Thanks for All the Help

    I think the only thing I have to do is dl something...but first I have to figure out who I am going to go to ... and whether I'll be able to use it once I get it.

    I got into safe mode...I found the advapi32....but I cant get into the properties....when I go to properties to check the date, I get the memo that windows is generating errors....and from what I get from Google, I dont have anyway to fix it without a dl...

    Of course the start up memo tells me that I'm in safe mode since its possible that my network or hardware settings are causing my probs.

    Does this ring a bell to anyone???

  9. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    You don't have to go into properties to see the date. Just click on the View menu and select "Details". Now you should have a column called "Date Modified". If you right-click that header/column area, you can also tell it to show "Date Created".

    There is no real point to knowing the dates unless you find another file that is newer on the PC.
    By the way, did you try running "regsvr32 advapi32.dll"?

    What service pack do you have again? Can you get into My Computer properties? If not, you can also try Start-Run-dxdiag. It may give some more details about Windows.
  10. Shknstrsgirl

    Shknstrsgirl TS Rookie Topic Starter

    Not Quite Sure

    I'm not quite sure what service pack Im using....Under operating system it says Microsoft Windows 2000 Professional 5.0, Build 2195

    On the regsvr issue, the first time I did it it didnt work...but then I tried again and it popped up saying advapi32.dll was loaded, but the DllRegisterServer Entry Point was not found. DllRS may not be exported, or a corrupt version of advapi32.dll may be in memory. Consider using PView to detect and remove it.

    But if there are two advapi32.dll with the same size and date, wouldnt that make both of them corrupt and if not, is PView accessible without the internet??? I have two of those files with 350KB and a date of 12/6/99
  11. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Maybe you are using NO service pack!

    When you right-click My Computer and choose properties, the box pops and looks something like this: Stuff/OperatingSystem.jpg

    The serivce pack should be clearly visible, and if not, then you don't have any, which is not to good, since MS has put out 4 or 5 of them now. I lost count! lol

    So that means we should find you a file perhaps from a nosp version of 2000...
  12. Shknstrsgirl

    Shknstrsgirl TS Rookie Topic Starter

    Very Interesting

    Well....surprise surprise I was able to check properties for My Computer....and no there is no service pack listed on the general tab.

    And does it mean that I have two damaged advapi32 files??? Both with the same date and in the system32 and one in the cachedll??

    Where do I go from here??

  13. Shknstrsgirl

    Shknstrsgirl TS Rookie Topic Starter

    Shot In the Dark

    Vigilante....I tried your "shot in the dark" and it wont let me change the says that windows is using the file....

  14. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    I figured. You must have the right file, the dllcache one is not "used" per se, it is just XP's "cached" copy in case the "real" one in system32 gets damaged. It's part of the Windows File Protection.

    OK, so you have no Service Packs, and you have NO Windows 2000 CD right?

    Well I guess the only thing I can do, assuming you have a corrupt file, is to find you another file. I could send my winXP one but it probably wouldn't work, so I'm going to try to find an updated one from a 2000 service pack.

    I hope we're chasing the right rabbit here, cause the problem could still be somewhere else. But we have to rule out that file specifically. Otherwise I'm thinking, a problem with scripting host or something else. But we'll cross that bridge when we get there.

    In the meatime, if anybody has a copy of 2000 they can attach their advapi32.dll file here and see if it works for her. Thanks.

    In the meantime, I'm trying to get the file for you. And if you like, continue browsing google on that error, somebody somplace may have a solution. Or at least you may read if replaceing that file even ever fixed the issue.
  15. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    OK, I downloaded Windows 2000 Service Pack1, extracted it on my machine and expanded the advapi32.dll file.

    But the problem is, you may have to rename both the system32 and dllcache version of yours, so windows doesn't replace this new one. And since the file is always in use, you may have to do it with Recovery Console. BUT since you don't have a CD, you probably can't go there. lol

    One other thing you could try is to go in to Safe Mode Command Prompt. This doesn't load the Explorer shell, and then maybe you will be able to replace the old copy with this one. That is if you know how to get around in command prompt.

    In any case, I'm posting the file here, see what you can do with it. Techspot has a measly limit of 100kb for zip files, so you can get it off my site:
  16. mailpup

    mailpup TS Special Forces Posts: 7,189   +471

    As an alternate route to take when looking for missing dlls or other files, you can sometimes find one by googling for it and find a free download. Take this for instance: However, I don't mean to take anything away from all the work that Vigilante did. That was very kind of him.
  17. Peddant

    Peddant TS Rookie Posts: 1,446

    Just read the thread a little closer mailpup :) DOH !
  18. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    Ya, I searched myself for the file but couldn't find it. At least, if DLL-files has it, I can't tell what version it came with. As it probably changes with each version and service pack.
    So I figured, what the hay, might as well make sure to get the one from SP1. Hopefully it works.
  19. mailpup

    mailpup TS Special Forces Posts: 7,189   +471

    Sorry. I duplicated your link which I overlooked. I thought I had gone through the thread looking for that kind of thing but obviously I missed it.
  20. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    just fyi on versioning ...

    "The Procedure entry point IsWellKnownSid could not be located in the dynamic link library ADVAPI32.dll."​
    The message says all. This is typically a versioning problem. The program that
    is looking for IsWellKnownSid was built (compiled+linked) with a different (ie: more current)
    version of the ADVAPI32.dll than you have installed. Seldomly will you see any
    registry entries for "Procedure entry points"; these are found by code after the
    DLL is loaded, and failure to find it results in what you are reporting.

    Soultions: Down-grade the program that is loading the DLL (not easy to determine) or up-grade the DLL.
  21. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Even better solution would be to install Service Pack 4 (or at least SP2, if 4 has problems).
  22. Vigilante

    Vigilante TechSpot Paladin Posts: 1,666

    The problem is (I think), that the system in question isn't online, and they don't have another system from which to burn a CD of SP4, or anything for that matter. Making installing anything to be a pain. But he can use a floppy, thus we're trying just to replace the one file.

    One way to get SP4 is maybe contact Microsoft, they often will send out free CDs of service packs. At least, they did with XP SP2. Maybe they will with 2000 SP4? Or at least it probably won't be expensive at all if they make you pay.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...