New OEM Liteon LH-20A1H-185 20X Internal Dual Layer DVDRW NOT recognizing Blank Cd

By JMHar ยท 12 replies
Oct 11, 2007
  1. I recently purchased (by mistake) an OEM Liteon LH-20A1H-185 20X Internal Dual Layer Lightscribe DVDRW and installed it in my pc. As soon as I powered on, Windows XP found it and it was recognized in "My Computer" as a DVD drive. Next I purchased some blank DVD+RW disks and put one in so that I could move clutter off of my HDD. Well, it doesn't see the DVD as a DVD, and instead sees a cd with the capacity of a cd. I checked the driver and it seems that I have the latest version. What can I do to get this thing working right?
  2. lludacrisboy

    lludacrisboy TS Rookie Posts: 24

    So it sees a dvd as a cd??? thats wierd. lol i sorry for the issue, my advice is send it back or check the driver again and make sure there isnt any updated firmware. ive had that happen to me in my computer shop and ive replaced the drive and solved the issue that way.
  3. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    buy better disc's ya know another brand
    still doing this do test burn make sure the program is set for dvd size
    some programs default to Cd
  4. JMHar

    JMHar TS Rookie Topic Starter

    I thought I had bought some quality disks (Sony). I'll try another brand to see if I still have the problem.
  5. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    Your problem is probably not the drive or the disks. It is probably the IDE driver you are using. Most optical drives work best with Microsoft's IDE driver, so if you are using Intel's, Nvidia's, ATI's, SIS's or VIA's IDE driver you need to switch it to Microsoft's version of the driver.

    Is the Liteon on its own ribbon cable? Do you have anyother optical drives or hard drives installed on the same cable? What software are you using to burn the DVD-RWs? Have you formatted the DVD-RWs?
  6. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Good Call! Cinders right on the money with that answer use the Microsoft IDE driver.. I had the same trouble with my DVDs showing up was CD or CDRW.
  7. JMHar

    JMHar TS Rookie Topic Starter

    How do I verify which driver I'm using, and where can I get the Microsoft version? Will switching drivers cause any problems with any other devices I use?

    No, it is the slave on the 2ndary IDE cable, with my cd burner being the master.

    When I tried I was using Nero (I can't remeber which one or version - It's at home while I'm at work).

    No, I haven't formatted any of the disks yet.
  8. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    This is probably too simple to be the problem but it couldn't hurt to check. I use Nero 6 at work and if I don't select DVD instead of CD in the upper right corner of the "Welcome to Nero" menu box, my blank DVD+RW will appear as a CD.
  9. JMHar

    JMHar TS Rookie Topic Starter

    I decided to start with the simplest fix and then go on to the next. I uninstalled/reinstalled Nero 6. When I ran it, it recognized the dvd in the drive, where before it wouldn't let me switch to dvd. But it seems to be ru8nning extremely slow. I'm copying about 4GB of files, and after 45 minutes its only 60% done. Is this normal?

    And before I forget, Thanks for all of the suggestions!
  10. mailpup

    mailpup TS Special Forces Posts: 7,186   +469

    Check to see if the channel on which the optical drives are connected is set to DMA transfer mode instead of the the slow PIO mode. Go to the Control Panel > System > Hardware > Device Manager > IDE ATA/ATAPI controllers. Right click on the channel in question and select Properties. If it is on PIO mode you can try to manually change it. You might have to restart for it to take effect. I'm not sure. Check again and make sure it stays in DMA mode. If for some reason it won't, you can uninstall the channel in the Device Manager, restart and let Windows reinstall it.
  11. JMHar

    JMHar TS Rookie Topic Starter

    I did as you suggested and it is set to DMA. I'm burning another disk (4.5GB) and after 60 mins it is 82% completed. Oh well, at least it works now.
  12. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    Click the Start button, right click My Computer and then choose Properties from the context menu. Click the Hardware tab and then the Device Manager button, or just type devmgmt.msc in the Run box. Click the + symbol to the left of IDE ATA/ATAPI controllers and then right click the top most device and choose Properties from the context menu. Click the Driver tab and then the Driver Details button. The provider should be Microsoft Corporation. Click the OK button and then the Update Driver button. The Hardware Update Wizard will come up, so click The "Yes, this time only" radio button and then the Next button twice. Let the wizard search for the driver. It should find the driver and and install it. You will have to reboot to finish the install. Your drive should burn much faster with this driver.

    Your drive was switched to PIO mode because of its incompatability with your current IDE driver. I'll bet the disk you burned is full of errors and is unreadable. I'll also bet that your drive will not successfully read an ordinary DVD movie with the video acceleration turned on in your video player software. I'd also bet that your CPU usage is between 40% and 100% when burning or watching a movie when it should be between 5% and 15%.

    Much to my suprise, when I went through the IDE update process, my IDE driver updated!
  13. JMHar

    JMHar TS Rookie Topic Starter

    After making the suggested changes and burning another disk (about 4.5 GB of stuff), after 45 minutes I'm 56% done, and cpu usage is about 18% - 35%.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...