New Wireless Card, Unable to view Wireless Networks

By icefreez
Feb 6, 2008
  1. I own a Gateway C-140 Tablet PC. It originally came with a Integrated Intel® 3945 802.11a/b/g wireless Mini PCI-E card. I did not have great luck dual booting into Linux with it so I purchased a replacement, the Gigabyte GN-WI01GT. The GN-WI01GT has a AR5005 GS Atheros 5th generation chipset.

    This new wireless card works great in Linux now however I can not get it to work in Vista Home Premium (i know i know, but its the best OS for a tablet). Seems like I swapped my problems :(

    I have talked with a Gigabyte tech and a Gateway tech.

    The gigabyte rep suspected that the device needed to be enabled via a button on the side of the computer. On my tablet the button is using the function key and F2. I tried this and my wireless card was still unable to detect any wireless networks. He checked the driver version ( which was the latest. The device is showing up in the device manager as enabled. Vista says the device is working properly. He also informed me I should not need any separate programs to connect to a wireless network like some manufactures do.

    The gateway tech was of no use and basically asked me to check the FN + F2 to enable the device told me it was a 3rd party product and gave me a gateway pay by minute tech line.

    Since the new card is functioning in Linux perfectly fine I find it hard to believe that it is something as simple as enabling the wireless using FN + F2 since you would think I would be require to do it in Linux as well before it worked.

    I am somewhat familiar with Vista but not enough to know if I have checked every setting that could affect this issue. Any advice is greatly appreciated. If you need more information I will be happy to provide it for you.

    Info Recap:
    OS: Vista Home Premium
    Old wireless card: Integrated Intel® 3945 802.11a/b/g wireless Mini PCI-E card
    New wireless Card: GIGABYTE GN-WI01GT has a AR5005 GS Atheros 5th generation chipset
    Windows Driver Version: Latest according to (sorry can't post links yet first post)
  2. icefreez

    icefreez TS Rookie Topic Starter

    I came up with a semi solution and a semi diagnosis for this problem. I put BOTH cards in at once putting an antenna on each. I noticed that when I booted into windows that the wireless light showed it was still disabled and in fact it was disabled. I used the FN+F2 key to enable wireless and *POOF* both cards work in vista now.

    So my guess is there was sort of hardware check that was disabling power to my wireless or something.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...