New Wireless Network Card receives but not sends packets. Tried almost everything!

By SweetPatato
Mar 30, 2006
  1. I have a you beaut MSI Diamond K8N Athlon Motherboard and yesterday I decided to get the matching MSI PC54G2 Wireless PCI adapter card after having an issue with a D-Link USB Adapter which worked well when plugged into my old notebook but never in my desktop.

    However, after setting up the new the new card I found I had the same issue I had with the USB adapter. Simply, I can't get onto the internet. I have checked the Wireless Key a thousand times and it is correct. I went to the Device manager and deleated and resintallled the MSI Wireless card.

    I have since found 2 odd issues:
    (1) When I go into the Wireless Network Connection Status on the system tray it has 2 Tabs (1) General and in this Tab I can see the received packets in high number and rising, but see Send as "O"; (2) Support Tab. When I click on the Support Tab it says Invalid IP Address. If I attempt a repair nothing happens - I have done this several times, it either hangs or it completes but doesn't fix the issue. Currently the Default Gateway is blank, but the Subnet Mask & IP Adress is which seems a bit odd!

    (2) When I go to Network Connections and open the Wireless Network Connection Properties there, I get 3 tabs - General, Wireless Network and Advanced Tab. Under Internet Protocol (TCP/IP) I am using Automaticaly Obtain both IP Address and DNS Server. Under the last tab Advanced it says: Windows cannot display the properties of this connection - then goes onto say use system restore as the WMI may be corrupted. Unfortunately I cannot do a system restore as I changed a few drives around and as a result it cannot do it.

    I don't wish to do another re-installation as I don't believe that will necessarily fix the problem and doing the last installation took 45 hours to complete 2nd time around and I don't have the time as holidays are over. So I need to find a way to resolve this issue and get on line with my desktop as I can't run cables anymore. Can anyone help?

  2. Peddant

    Peddant TS Rookie Posts: 1,446

    Edited highlights from -

    Turn DHCP on if you haven't already.
    Also for now turn WEP or WPA encription off.

    Now open the network connections and right click wireless connection and go to properties. click on TCP/IP and go to properties. Make sure everything is set on auto.

    If you now do view available wireless networks does your wireless pc see the router? If it does try connecting to it now. Also try turning off any firewalls running at the mo just untill you sort the problem out.

    To finally resolve the problem i had to manually enter TCP/IP settings on the PC connection. Basically the default gateway of was not working correctly and i changed it to (I.e. the other end of the range). Then i entered each PC's IP address as (where xxx is a number less than 254). Finally i entered the DNS server address and i was way.

    I believe the last bit could have been avoided if perhaps i hadn't messed around with the router trying to set it up in the first place.
  3. SweetPatato

    SweetPatato TS Rookie Topic Starter

    Hi Peddant, thanks for advise, but still stuck getting connected

    I found a really good simple article on repairing the WMI files. This solved my corrupt WMI file issue.

    I followed your instructions, but unfortunately, this did not solve my problem as I still cannot connect. I tried entering in an IP address and this made no difference. I am using the 'repair' utility again, to automatically renew the IP address, but after 5 minutes it again appears to be in a hung state.

    I am learning as I go, but am learning more mto deal with patience right now!

    Any further suggestions?

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...