No display, no beeps but all fans going

By Xanusus
May 16, 2006
  1. Hi first time on board looking for an answer. I'm fairly new to building computers. I've only did it twice now. sooo,

    I purchsed an ECS nforce4 - a939 board for the amd athlon 64 3000

    Ok so I followed the the mb manual and made sure by checking and rechecking all connections that everything was connected in the proper place.

    I've got the processor seated properly, ram, graphics card(radeon x850xt pci express), HD, Optical drive, PSU

    So I plug in the PSU 24 pin adapter to my mb click the switch on the back and hit the reset button on the computer. Well, all the case leds, psu fan, case fans, cpu fan, graphics card fan all start up. So I'm thinking great!.

    I then plug my monitor and and by the way it does work but get absolutely no display signal at all. My comp is not posting for some reason. There are absolutely no beeps whatsoever. So I left everything connected and went thru one by one changing first the cmos jumper. Nothing. Removed the ram (no beeps whatsoever on power up), removed the cpu (again no beeps upon power up).

    So I have no clue what the problem could be. I've checked to make sure the mb is not shorting out somewhere. all risers are in place.

    So does anyone know what my problem could be? I'm hoping it is this....

    You know the atx 4pin 12v connector on the board? well, my PSU is a chiefmax 650W BUT the connector for it is spliced off the 24 pin connector that comes from the psu and heres the kicker the atx12v connector is all the way on the opposite side of the mb from the 24 pin connector and the cable is not long enough to reach it because of it being spliced off the 24 connector of the psu. In other words I can't plug into the motherboards 4pin 12v connector on the other side because my psu 4pin 12v cable is not long enough. I still get power to the mb without it being plugged in though with all fans and leds on.

    So is this my problem? Or do I have a faulty mb, psu, cpu or something else?
  2. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    without plugging in the 12v atx cpu power you'll never know if the motherboard is any good. Powering it up without it connected can ruin the board.

    I suggest getting an extender for the power or another PSU.

    Extenders are cheap, but every extension has the chance for losing voltage or shorts.
  3. Jackpine

    Jackpine TS Rookie

    I had the same problem.

    In order to isolate the problem, I disconnected all hard drives, optical drives and floppy. I also had everything assembled outside the case.

    I took one memory stick (I have 2x1024MB sticks) and inserted it into one of my four DIMM slots, and tried booting. As it turned out, a heard a single beep and messages on the monitor (checking IDE drives; insert Boot Media and press a key, etc.) I then shutdown the pc and inserted that stick into the next slot and did the same startup test. Same result. I repeated this two more times with the other two DIMM slots, and had the same result.

    Then I took my second stick and inserted it into the first slot as before. This time when I started, there were no beeps and the monitor stayed black. I obtained the same result using the second stick in the other three slots.

    I then used both sticks at the same time in every possible combination with the slots. No beep, black monitor.

    The second stick was now suspect of being faulty.

    I took both to the store where I bought the memory and they checked them. Sure enough, the stick that I thought was faulty was confirmed by them to be faulty. They gave me a new set.

    Now when I insert both sticks, I get a beep and monitor messages.

    However, when I depress Del to go into the BIOS, it doesn't. I will have to post a thread to find out why.

    Good luck.
  4. chris33

    chris33 TS Member

    I've had a similar problem in the past with my PC. I took it to a friends house in perfectly working order. When I plugged it into the powerbar and hit power on the system, it lit up and spun fans but no boot. After about an hour of removing and replacing parts, I found out it was the fact that there was too much plugged into the powerbar and it couldn't supply enough power to the PC to fully boot. So, if you have it plugged into a powerbar, I would recommend just plugging it into the outlet directly and see what happens. Good luck.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...