no net access to USB connected HDD

By WindsurferLA ยท 4 replies
Sep 1, 2006

    The machine is a 1 Ghz Compaq Presario 700 lap top running WinXP-home with all recent updates, Windows firewall disabled and no Norton or McAfee firewall installed. Connected to the lap top via a USB 2.0 port in a USB2 card is a 200 GHz hard drive. The HDD has two partitions. One partition is set up to be shared on the network.

    Until recently, I could access the files on the USB connected HDD from my two other machines on the local hardwired Ethernet network. (Simple sharing at the drive level as well as lower levels is enabled.) I now get error message saying I may not have permission or not enough server storage is available to process this command. See subsequent post about irpStackSize being too small.

    I can read other files on the LapTop's C:\ drive over the network without problem. I can also read files on the other networked computers from the LapTop.

    Using Windows explorer on the LapTop, I can easily view and change the contents of the USB connected HDD by selecting the drive letter. However, using Windows Explorer on the LapTop to access "network connections" of the LapTop, I nearly always get the same error message as is that displayed on the other networked machines when seeking to access files on the USB connection HDD. The problem seems to be independent of whether the files are MP3 or plain data.

    Updates... When the external USB HDD is connected to another computer, files on the HDD can be viewed over network.

    INTERESTING .... When a short cut to the external USB HDD is placed in a directory on the C:\ drive of the lap top, the shortcut can be seen over the network, but it has a white question mark on a red circular background in the lower right corner of a HDD icon.

    Also... between when things worked, and when things stopped working, I installed the new Norton System Works 2006. However, the problem remains even when I turn off Norton protection. Norton GoBack was turned off by clicking on icon in lower right corner and selecting exit or other appropriate option. Norton system works was similarly subsequently turned off. See later posts for cure.
  2. fastco

    fastco TS Booster Posts: 1,123

    Do you also stop the Norton Process running in the background? Try that because just stopping the program won't completely shut down Norton.
  3. korrupt

    korrupt TS Rookie Posts: 716

    What excactly did you change just before it stopped working?


  4. jobeard

    jobeard TS Ambassador Posts: 11,177   +990

    yep, that's what I get too. As long as it works, the '?' doesn't bother me -- I read it to mean, "Unknown if mounted yet" (because mine is removed from time to time)
  5. WindsurferLA

    WindsurferLA TS Rookie Topic Starter


    Probing my LapTop machine, I found that it was logging error "2011 irpStackSize too small. " WinXP Home pointed me to Microsoft website that suggests the registry key
    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters\IrpStackSize be increased beyond 15. I could not find "IrpStackSize" in my LapTop's registry.

    Microsoft says the error happens when "The server is configured with too many file system filter drivers(for example anti-virus) and/or too many devices."

    I have since gone to Add/Remove programs to remove Norton System Works. Surprisingly, I found an option that lets me selectively remove Norton GoBack. After removing GoBack, I was again able to access the external USB HDD. I can't say GoBack caused the problem, but the problem vanished with its removal. :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...