No Network

By cogenmaster ยท 5 replies
Jul 19, 2004
  1. Downloaded and installed version 9.0 of Red Hat. Installed Linux on it's own seperate harddrive which is on the master IDE channel. I have a samsung 160 GB sata drive as the c:eek:n sata channel 1 with winxp on it formatted in a NTFS file system. Read through Phantasms linux installation post and tried to follow it but I could not seem to get the druid partitioner to work well for me...guess I am just not smart enough. I partitioned the 20gig maxtor ide drive in fat 32 and I made a fat32 partition on the samsung drive to put all my music and vid files on to mount to linux. During the redhat installation it sees the 20 gig maxtor drive and version 9.0 actually automatically partitions the drive with the main partition and swap file. Made the boot diskette and rebooted after installation and continued to get a failed to boot warning. All I can assume was that I had a bad floppy I could only find one in my hole house. If i go into bios and change the hard drive boot priorty and set the maxtor to drive 1 it will boot into linux with no issue. Want to set the system to dual boot but not sure I understand phantasm instrutions to dual boot plus Vesion 9.0 installed grub as the boot loaded not lilo. My biggest problem at the time is I cannot get the internet to work. I have a Nforce 3 board and found linux drivers at Nvidias site. Installed them and ran the internet config wizard and it showed a network adapter not sure of the name now. Went through the config and all went well but mozilla will not open any sites and under the config section it says my network card is inactive. Any suggestions would be appreciated.

    WinXP Home
    Linux Red Hat Version 9.0
    MSI NForce 3 Motherboard with on board Network
    AMD 64 3000
    Creative Audigy
    1 gig Kingston 3200 ddr
    Maxtor 20 gig ide
    Samsung 160 gig sata
  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    How are you connected to the Internet ?

    As for the network card, installing nVidia drivers should install a "nvnet" module. This is the module that you want to load in order to get your network card working.

    In your /etc/modules.conf file, you should have a line like this :
    alias eth0 nvnet
    Then you need to edit the file /etc/sysconfig/networking-scripts/ifcfg-eth0

    DEVICE=eth0    #the device to which the card is linked
    BOOTPROTO=dhcp #speaks for itself
    HWADDR=xx:xx:xx:xx:xx:xx #MAC adress of the card (optional)
    ONBOOT=yes     #activate the connection at startup
    If you don't feel like editing the 2nd file, you can always open a command prompt & type rehat-config-network.
  3. cogenmaster

    cogenmaster TS Enthusiast Topic Starter Posts: 117

    Verfied modules and sysconfig setting


    I verified both the etc/modules.conf and the etc/sysconfig/networking-scripts/ifctg-eth0 settings and they were already like you stated they should be.

    When I go into network configure option and try to activate I get a error message "device may not be present"

    The network card is not listed in the hardware browser as well.

    Any other suggestion?
  4. cogenmaster

    cogenmaster TS Enthusiast Topic Starter Posts: 117


    found this on google not sure what it means

    Silly me, 2.4 works differently. So here's the bug in a nutshell, since= =20
    > I got it working:
    > Debian installer does not update 'aliases' which is the input for=20
    > update-modules which updates /etc/modules.conf Once you do that (alias= =20
    > eth0 forcedeth), run update-modules and maybe depmod -a. Voila!
  5. MattG

    MattG TS Rookie Posts: 140

    Check your kernel compile. Your particular NIC might need to be compiled directly into the kernel instead of being run as a module.

    If its not, download the newest kernel and see if it has nforce3 support for it, as it is onboard. and pretty new.
  6. cogenmaster

    cogenmaster TS Enthusiast Topic Starter Posts: 117

    Got it working

    Never could get the Nvidia on board network card to work so installed my Dlinks network card. Worked like a charm. Got the internet working with mozilla and email evolution working. Dowloaded and installed gaim and talked to one of my buddies over the msn messeger port.

    I guess linux is ok at least I know that if I ever get really pissed at Microsoft I can get it installed and running. I never could figure out how to install a game and my sound was not working all though the system found Audigy and played the sound test fine. I ripped a CD and it put the file in my home folder but they would no sound.

    I guess Linux's big problem is that it is not very user friendly other then that it seems ok.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...