Nomad Jukebox Zen 60GB (Help!)

By Tundra ยท 8 replies
Sep 11, 2003
  1. Hi. I hope I'm in the right place, and I hope that someone can help me. :eek:

    I recently installed Creative's Nomad Jukebox Zen 60GB. It's an MP3 player that connects to the PC using USB (not firewire, like older Nomads). The Nomad works, but when I install the software (which is used to transfer music from PC to Nomad), it installs the software, but has a hiccup when trying to install the drivers. It copies the driver, but then - when it says "Setting up the driver", it pops up with "An error has occured" (that's all it says).

    When I explore the CD, there are three driver install files:

    I can install the last two manually, but they don't seem to do anything - individually or together. The Creative software doesn't recognise the Nomad - it says it's disconnected, although Windows knows that it is connected. When I try to install the first one, it comes up with that same "an error has occured".

    I downloaded the two most recent versions of the Nomad JukeBox Zen driver, but they both had the same problem.

    :confused: I don't know what to do. Perhaps there is a way to install the necessary drivers manually without using an EXE? I'm running short of ideas!

    Does anyone have any suggestions for what could be wrong, or what I should try?

    I have a P3 and am running WinXPpro

    Thanks very much in advance.
  2. Greeno

    Greeno TS Rookie Posts: 281

    i've got the 20GB Zen...

    When you say software (i dont know if its still the same, but...)

    that the file transfer wizard? coz i've always transferred my stuff thru creative's play center... it works v.well for me, just ensure the device is loaded correctly (in device manager) and try play center if you're not always.
  3. Tundra

    Tundra TS Rookie Topic Starter

    Well, if I had drivers installed properly, Playcenter would probably work well for me too ;)

    My problem is that the drivers simply won't install correctly. Hence, device manager tells me that they aren't installed at all, and Playcenter tells me that the Nomad is disconnected.
  4. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Have you tried installing the drivers BEFORE you connect the device? Often times, leaving the USB device connected while installing drivers can cause problems simliar to this.
  5. Greeno

    Greeno TS Rookie Posts: 281

    yeah... I installed my drivers, then connected the device :]
  6. Tundra

    Tundra TS Rookie Topic Starter

    Yeah, I hadn't connected it yet when I installed the drivers. Afterwards, I tried installing again with the Nomad still connected, then again with the Nomad disconnected. Then I figured that perhaps my existing USB devices could be causing the problem, which goes along the lines of what you said, Rick. But I've tried installing it with nothing plugged in to either of my USB ports, and still it didn't work. :(
  7. Greeno

    Greeno TS Rookie Posts: 281

    faulty Zen?
  8. Tundra

    Tundra TS Rookie Topic Starter

    no, the zen works fine. The software and drivers work fine too - on my friend's computer. He is running a Pentium 1 or something like that, with Windows 98. Everything works, just not on my computer - which is a rather large inconvenience. The general idea is to put gigs and gigs of music on this thing, and having to burn all my MP3s onto CDs and copy them over to his hard-drive (which only has 700MB free on it) is proving to be pretty annoying (and would eventually take up a whole lot of CDs! :D)

    The software and drivers are supposed to work on XP, and in most cases do (I would assume) just not on mine :eek: :(
  9. Klangboy

    Klangboy TS Rookie

    :( I had the same problem with the zen extra 60GB. I called the creative people and they say it should work and suggested I try another PC to see if it is OK.

    I finally solved the problem doing the following:

    1. Uninstall all the software.

    2. reboot

    3. Connect the Nomad to each USB port directly, the ones on the
    PC, on the motherboard is much better. Try every USB port on your computer.

    Windows XP detected the Nomad using the USB port that is built on the motherboard, i.e. without connectors. For some reason, it will not recognise the USB port that uses a connector!!!

    4. Install the software from the creative CD.

    It works after that. Hope you get it to work soon.

    God bless you,

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...