1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Norton partition magic says hard drive is "BAD" Why and how can I fix this?

By Nirkon · 20 replies
Nov 28, 2007
  1. I have a Maxtor Diamondmax 80 (its 60GB) (model no. 96147H6).

    In Norton Partition Magic I get 'BAD' written on the drive,
    but there is no problem with the drive, right now its empty, I took the stuff out, but it works perfectly, I just formatted it again in NTFS, there has been no data loss, the HDD isn't physically damaged, not making any sort of suspicious sounds. So why am I getting this reading, and is it possible to fix?

    I've looked at the sticky at this PowerMax utility but because Seagate bought Maxtor, they made some kind of new software or w/e, so I don't know which one to use.

    Thanks in advance.
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    Seagate owns Maxtor... Go to the Seagate/Maxtor website and download and run a utility called DiscWizard for Windows. It is possible that your Maxtor drive is failing one or more SMART parameters... DiscWizard will tell you. Ditch Partition Magic and try Acronis Home
  3. Nirkon

    Nirkon TS Enthusiast Topic Starter Posts: 202

    ok ill do that, I know for a fact though that SMART is disabled on the drive, so does that option still look viable?

    OMG the disc software is over 100MB!
    isnt there some small utility X0?
  4. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Ignore Tmagic.. Partition Magic does not know anything about SMART or hard drives - it is a utility for partitions and filesystems.

    Most likely your hard drive is just fine. Partition Magic is stupid/buggy/broken for sure and you are lucky that it didn't offer you a possibility to "fix" this hard drive.

    And now, please help the unfortunate silly people who are not telepathic and may not know all about you:
    What operating system are you using?
    Which version of Partition Magic are you using?
    What are you trying to do with Partition Magic?
    Have you done anything previously with that hard drive?
  5. Nirkon

    Nirkon TS Enthusiast Topic Starter Posts: 202

    damn, you're not telepathic? :p

    but anyway,
    1) WinXP Pro SP2
    2) PM 8.0
    3) Just to see the drives are ok and usuable to store data on, because I can't partition a 'BAD' drive.
    4) Yes, i took it out of another computer, it was in use for about a year with no problems.

    but now I see that Acronis doesn't recognize the HD! something about a read error.

    I reckon there's a small amount of space there (approx 64MB) which is corrupted (since its not showing up in windows explorer).

    Is there anyway to fix that sector?


    hmm PM seems to give out a BAD MBR error......
    but that really shouldn't matter should it 0_0?
    im not trying to boot from it, just use it as my 3rd HDD

    if there isnt thats still fine... its not like its creating multiple bad sectors, its just 1.. I can forgive that ;)
  6. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    MBR also holds the partition table among other things, so it is pretty important ;) The fact that the drive is still workable means that the partition table is just confusing PM.

    If you don't mind losing all data on that drive, try zeroing out the MBR and recreate the partitions with PM or some other partitioning program. You can use any disk wiping utility or disk editor or non-Windows OS to do the erase.
  7. rf6647

    rf6647 TS Maniac Posts: 829


    Consult above link, technical section, 3rd bullet. ‘Bad’ is one of the allowed descriptors for partition space. I see no explanation of this descriptor. It could indicate blocks lost by the FAT; it could indicate bad blocks not maintain by the defect tables. HDDs maintain defect tables for bad blocks.

    It is possible this is the only way PM can get you to run chkdsk with surface scan fix option. If this suggestion does not solve the issue, then do a low-level format of the HDD. Go to the manufacturer’s web site & download their SeaTools Diagnostic file and the Installation file. I did not find an explicit mention of the low-level format capability for either download.

    A far-out explanation - the defect table is so large that its significance is reported by PM because it has out grown its protected space. If this turns out to be true, I would not ever do FDISK or a low-level format for fear of losing this information.
  8. Nirkon

    Nirkon TS Enthusiast Topic Starter Posts: 202

    ^^ The Disc software from Seagate did not recognize any maxtor drive (its based off Acronis and acronis didn't recognize the drive either, so I think thats the problem).

    The other utility from them worked fine and the drive passed the tests there,
    I think I just need to re-write the MBR, its causing some trouble.

    Right now that drive is completely empty, so with which disk utility can I re-write the mbr with? (btw this wont effect my other drives right? its specific for this drive)?
  9. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Hum.. It depends on what you have. A disk editor is on the Windows CD in the Support Tools kit (dskprobe). You could download a disk wiping tool like DBAN and let it run to 1%. Or, you could download any Live CD unix OS and use the dd utility to overwrite the beginning of the drive.

    In any case, triple-check that you are acting on the correct drive! :p
  10. rtekz

    rtekz TS Rookie

    seagate and maxtor was same coy... Go to the Seagate/Maxtor website and download and run a utility called DiscWizard Starter. for Windows. or you can use zero fill process for that problem.. all bad sector of your hd was fully erased it will back into factory setting. like you have new hd. thanks... you can partition your hard drive in just a matter of seconds.

    thanks regards
  11. Nirkon

    Nirkon TS Enthusiast Topic Starter Posts: 202

    OK thanks guys ill try disk-wiping utilities,
    it'll probably be in like 2 weeks though, since my burner
    died on me and I still have warranty so ill have to bring it by to the store.

    thanks for the help!
    (cya in a couple of weeks lol)
  12. rf6647

    rf6647 TS Maniac Posts: 829

    ‘ptedit32.exe’ is a disk editor that works on the partition tables and boot record. It comes with Partition Magic. It is executed in the command prompt window.

    I was able to create the condition where PM ‘fixes’ errors in the partition table and the result is PM screwed up. The main screen (PM) designates the drive bad, and no operation can be performed on that drive.

    Ptedit32 repaired the partition table & boot record. The drive was then accessible to PM. Two attached files are screen shots showing the partition table and boot record for a 80G drive with a single partition, NTFS file system.

    Here is a procedure.

    Open the command prompt window.
    Change directories to the directory with the file ‘ptedit32.exe’ (e.g. cd \prog*\powerq*\part* )
    Enter command ‘ptedit32.exe’
    At the top of the window (PowerQuest Partition Table Editor) select the correct drive.
    Move cursor to line 1, under Type. Choose highlighted box ‘Set Type’.
    Manually edit values in line 1.
    Choose highlighted box ‘Boot Record’.
    Manually edit values.
    Save changes. Quit ‘Boot Record’.
    Choose highlighted box ‘Save Changes’.
    Quit ptedit32

    In my example, I worked on a small drive, FAT16B. I did not change fields 17 or 18 in the boot record.
    The attached jpg files will print on 2 pages unless you shrink the image.

    P.S. field 17 = 786432 field 18 = 9767516

    Attached Files:

  13. Nirkon

    Nirkon TS Enthusiast Topic Starter Posts: 202

    Hey, thanks, I don't want to mess anything up, could you tell me which values to change? cause i think something's messed up here:

  14. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    That partition table is FUBAR. Not much point in trying to put in anything. Just zero out everything and use a proper partitioning tool.
  15. rf6647

    rf6647 TS Maniac Posts: 829

    As Nodsu observes, your partition table is fubar. I find it curious that the screen shot is for drive 1. Ordinarily this is the boot drive. However, the ‘boot record’ button is not highlighted, which I interpret that it is missing.

    Anyway, here is a screen shot for a 60G HD. This drive has 7476 cylinders. Your drive has 7473 cylinders. This means that you need to reduce the number shown under ‘Sectors’ by ‘ 189 ‘ (3*63).

    Use all the other values for Partition 1 (line 1). This is the only part of the table with non-zero values. All other partitions should be set to zeroes.

    It is possible that saving these edits will get the editor to detect or offer a boot record. In the boot record for field 16, subtract 1 from the Sectors entered into the table. As a pure guess, that is about the only thing to change.

    The only other way to create a boot record is formatting the drive, but this will reset the MFT when it is re-created. Once you go down this path, all this work could have been avoided by doing the FDISK.

    In the future, I will try to master inserting a graphic in the actual post.

    Attached Files:

  16. Nirkon

    Nirkon TS Enthusiast Topic Starter Posts: 202

    Now that I can explain :)
    This is actually my 3rd hard drive, its set to Master on the IDE cable along with a second 80GB one set to slave, and I use these as data hard drives since I boot up from my 160GB SATA2 one :)

    Thanks for the help guys!
    I think i'll let this one rest, it is FUBAR, any changes to Line 1 come up with a read error.
    ill do FDISK /MBR on it and that'll be the end of it :)

    thanks again guys :)
  17. nimd4

    nimd4 TS Member

    Same problem as the original poster; So I have 2 partitions on that drive... One with the system and one which holds all programs/data. Lets see if I'm about to lose everything :/

    What happened is that I used the Vista DVD to format the HDD and then installed XP; Looks like it's Micro$oft's doing basically :( Gonna try the disk tools, but I doubt that there's anything wrong... Thanks for the links guys..:)

    ps. I tried posting the PartitionMagic & Computer Management screenshots, but
    pps. PartitionMagic doesn't see the partitions, while Disk Management does... I have a feeling all data's gonna get lost on this one ffs, dang it

    ^^ Even though I used CODE tags, the forum still thinks I'm trying to post images, while I am not (hence "hxxp").
  18. rf6647

    rf6647 TS Maniac Posts: 829

    Do not trust Partition Magic for this one.

    You booted using this drive. The drive is talking to Windows.

    Yes, use chkdsk /f to verify the directory/file structures on the disk.

    Screenshots of the ptedit32, which displays the partition table and boot sectors, may give some insight.

    Don't let PM make any corrections.
    nimd4 likes this.
  19. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,244   +234

    I agree rf6647,
    Partition Magic just doesn't work like it used to.. I like Acronis Home
    nimd4 likes this.
  20. Nirkon

    Nirkon TS Enthusiast Topic Starter Posts: 202

    ok, I want to rewrite the MBR, so if I create a bootable DOS floppy,
    then, disconnect all the other hard drives, and then rewrite the mbr on the only disk connected to the computer (the 'BAD' HDD), it should work right?
  21. rf6647

    rf6647 TS Maniac Posts: 829

    I will jump to the conclusions first.
    fdisk /mbr ........ re-writes the first 446 bytes of the master boot record.
    wrprog.exe ....... add this to the boot floppy. Obtain from PM DOS folder.

    FDISK with no other command line options will not alter the MBR if one is detected. See http://support.microsoft.com/kb/q69013/

    FDISK has a slight limitation with respect to NT. See http://support.microsoft.com/kb/q166454/

    FDISK /MBR - Partition Table structure is not altered.
    FT (fault tolerance) structures probably do not matter.
    Disk signature may matter. I did not research this further. I believe that this occurs as the last 2 bytes of the partition tables at the end of the MBR.

    I am a control freak, so I try to anticipate problems and create save points. So consider the following.

    The dos command "wrprog /bak track0.dat" saves track 0 from the hard drive with the jumper signifying master to a file a:\track0.dat

    The dos command "wrprog /rst track0.dat" write track 0 to the hard drive jumpered as master from the file a:\track0.dat.

    ptedit.exe is a dos command available from PM DOS folder, as well. If the disk structures are usable, it will read the MBR for the signature as part of the display for the boot record.

    If all else fails, a disk editor gets you down to the byte level. I did not see a likely match in PM DOS folders. Utimate Boot CD has partition tools and a disk editor. http://www.ultimatebootcd.com

    From your previous post, it was not clear if FDISK was used and no change was observed. My post here is pretty well the extent of my knowledge about FDISK. "Fdisk /mbr" restores the small piece of code to interpret the partition table. Since the last partition table shown for this HD is garbage, it should generate some type of error message, or a wild transfer to the wild blue yonder. A disk editor can give a glimpse of parts of these error messages (beginning of track 0).

    Some other links from my research:
    Ignore window from a.tribalfusion or ignore this link

    http://facstaff.uwa.edu/bmoore/340/theBasics/Operations of FDISK The Basics of FDISK.htm


    P.S. Dynamic Disk Overlay (DDO), often supplied by OnTrack or EZ-Drive: I had considered this as a suspect to explain the strange values occuring in the partition table. I would only be guessing at how to confirm this and how to recover.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...