NTLDR is missing

By zoephoenix
Oct 29, 2005
  1. I have 2 western digital hard drives, a 20GB hard drive with Windows 2000 installed and an 80GB hard drive with windows 2000 installed. When I try to boot the 80GB, it gives the message "ntldr is missing". I've had this problem before, but I don't really remember how I fixed it. Last time, I re-installed Windows 2000 on the 20GB and for some reason, when I tried to boot the 80GB, it worked. I can't figure out why.

    Sometimes the computer detects the 20GB as bootable and sometimes it detects the 80GB as bootable, depending on the jumper settings, but the 80GB ALWAYS gives the "ntldr is missing" error. I don't know what to do. Both hard drives are detected in BIOS, but they're never both detected as bootable devices when I go to the boot menu. Help..??
  2. ntldrismissing

    ntldrismissing TS Rookie

    You get the NTLDR is missing error likely because the 80GB drives C:\ partition isn't set to Active in the Master Boot Record.

    Set the jumpers back to the way it works, and boot back up on the 20 GB drive, then edit your boot.ini file on the 20 GB drive, adding a line to it that points to the Windows installation on the 80 GB drive.

    Shameless plug:
    For all other "NTLDR is Missing" errors, check out:


    If it helps, please make a donation.
  3. Sharam

    Sharam TS Rookie Posts: 509

    If you need help editing the boot.ini just ask, make sure you change the read only attribute first.

    This is simply because of the way or the order in which you installed your instances of the Win2K. Was one of the drives disconnected when you were installing win2k or you have removed what used to be C:\ at the time of setup?

    Do you require removing either of the drives from time to time? If so, as ntldrismissing has suggested, you need to have both boot partitions set to active with the required boot files including ntldr and boot.ini in the root directory if you want to boot from either of the drives with the other disconnected, let’s say you installed Win2k on the D: drive which is a SATA with an UATA drive as the primary master C: , after setup, if you disconnect the C: drive, you will get the exact same message even if you copied the required files from C:\ and edited the boot.ini. You will need to set the drive active as well.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...