1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

NTVDM CPU illegal instruction ???

By Gamork · 16 replies
Apr 16, 2003
  1. I’m new to this board and certainly unfamiliar with this problem. I am trying to install a new 4.71 ASPI drivers that I downloaded from the Adaptec web site. When I run the file (aspi_471a22.exe) that I assume will extract the files I receive the following popup error box.

    The NTVDM CPU has encountered and illegal instruction.
    CS:0543 IP:0106 OP:63 74 79 70 65 Choose ‘Close’ to terminate the application.

    I have Windows XP Pro SP1. I have tried downloading the files multiple times and even slightly different versions with the same results. I have found reference to a similar problem with NT listed on the Microsoft site that indicates that this problem occurs with an old version command.com dated 1997. I don’t think this is the problem since I’m using CMD.com and both it and command.com are dated 2001. Any suggestions would be greatly appreciated.
  2. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    In true Microsoft style, this is what MSDN had to say about your problem:

    Error Message:

    The NTVDM CPU has encountered an illegal instruction.
    User Action:

    Retry the operation. If you still get this message, try to continue. If you are able to continue, you might want to check the results of the running application. Otherwise, terminate the application, then restart it. If you still get this message, contact your technical support group or the supplier of the running application.


    this is what a NTVDM is....

  3. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    Anyway, I think you may have found a bug in something. Its perhaps possible that there isn't currently a fix for the problem you are having - its merely part of windows.

    There could potentially be a great number of things causing this problem. The problem may also not be unique to your machine, and is perhaps a problem that can be replicated on other machines with your same chipset, motherboard, CPU, graphics card, god knows.....

    If you are hell bent on finding out, think about installing a clean version of Windows XP on your machine, and see if the problem persists. Then gradually build up your base of installed programs, checking here and there if you can still install the software without generating the error.

    That's the best I can guess for you - you may find something on a news group article or the web sites of your various hardware manufacturers.

    oh, and i know that it says Windows NT in my NTVDM quote, but you can read that as Windows NT 4, Windows 2000, XP, Windows 2000 Server, etc...
  4. Gamork

    Gamork TS Rookie Topic Starter

    Hey thanks for you help. Here’s one to scratch you head on. Even though I have tried the ASPI version 4.71.1 from the Adaptec site and received the failure described above, when I down loaded it from your site I was able to load it just fine. We may never know the cause of the problem but at lease I have been able to update my drivers to 4.71.1.

    Thanks again.
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 4,909   +8

    ooohhh! oh, well. At least it works now...
  6. fropones

    fropones TS Rookie

    You are getting this error because the file you are trying to run is trying to access the computers memory. Because you are not running the file on a DOS or Win 3.X machine, NTVDM will not allow this. NTVDM allows a 16-bit DOS program to execute on Windows. It is basically a DOS emulator.
  7. Thunderj

    Thunderj TS Rookie

    I've been getting this same message for the last couple days myself on a win2k pro system (I wiped the drive and started over a few days ago). The difference is that I wasn't trying to run anything and the culprit program always starts from the docs and settings\"profilename"\local settings\temp" directory. So far I've had install.exe and optimize.exe pop up a few times and a few others that I can't recall (series of numbers and letters). All were exe's but are being spawned by some other process I haven't been able to locate. I keep emptying the folder to try to narrow it down with no success. Anyone have any ideas as to what could be happening? I'm kinda assuming some kind of trojan or something, but if it is I can't seem to locate it.
  8. adamabcd

    adamabcd TS Rookie

    Hi thunderj,
    I've got the same problem as you (in same directory).
    I had a norton message pop up previously about a 'bla trojan' but I doesn't seem to find anything on a system scan.
    Did you manage to find out any more?
  9. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,070

    It has been a while ,so Adaptec may have changed things.
    However I had the same issues updating my ASPI layer.I am a Nero man.
    What worked is download the ASPI file in .zip form not .exe ( Adaptec used to offer both)
    Extract to it' s own file .
    Run '...\aspi file\Install.bat /"correct O/S" ' making sure you have the ' aspi file path ' in the run box .
  10. Echelon

    Echelon TS Rookie

    Thunderj, and adamabcd.

    You BOTH have spyware.

    I suggest you get rid of it.
  11. darth_tulkas

    darth_tulkas TS Rookie

    NTVDM has encountered an illegal instruction

    Hi everyone,

    Ok, I have a similar problem, when I startup my pc, and the tray icons have finished to open, I receive the very same error message... a Blank DOS screen (16 bit MS DOS Subsystem), followed by an error message "NTVDM has encountered an illegal instruction, etc.....

    But I have noticed that it only happens if I’m connected to the internet (I have a cable connection), if I startup my pc unconnected I have no problems.

    Could somebody help me??? is it a virus???

    I received this message since I had to uninstall my AV, ´cause it was interfering with my Age of empires III installation, I have MS XP.

  12. Evilroy

    Evilroy TS Rookie

    I'm haveing close to the same problem, it doesn't happen when I try to run a program, rather, it occurs when i try to open command prompt. Heres the wierd bit, I am running a windows xp computer, and on that computer I have numerous accounts between four accounts 2 will show the above meantioned error message, and the other two will simply shut off DOS immediately after I open it. I am well aware that this is either Spyware or a virus, but I am unable to locate and destroy the attack with tthe means available to me. My question it this: How can I safely remove this threat from my computor, and what software will I need to be able to do so?
    I already have Kaspersky, NOD32 antivirus systems and Spybot search and destroy anti spyware programs, and they have failed to effectively remove, or even locate the threat.
  13. Evilroy

    Evilroy TS Rookie

  14. derekpenguin

    derekpenguin TS Rookie

    I had the same error running a PASCAL program that used BGI graphics. It works on two XP desktops but crashes on my laptop.

    Using DOSBox on the laptop enables me to run my program. I'd highly recommend trying DOSBox (it's free and open source ).
  15. ndmorgan

    ndmorgan TS Rookie

    I have the same problem and it is caused by spyware and a trojan.

    I bet if you guys go into your c:\windows\temp folders you'll see a few win???.tmp exe files and a load of *.tmp files.
    Thats the little blighter replicating itself.
    Oh By the way - These are nasty little trojans that will keylog and try to send info back to a few servers around the place so any banking/personal data may have been sent as well.
    As for removing them - I'm still working on that one.
  16. liviuandro

    liviuandro TS Rookie

    The NTVDM CPU has encountered an illegal instruction

    "16 bit MS-DOS Subsystem
    The NTVDM CPU has encountered an illegal instruction.
    CS:393a IP:393a OP:ff ff ff ff ff Choose 'Close' to terminate the application."

    This is a killer error because Microsoft has no solution for it, yet.

    From my expirience with this error, I tell you this:
    - it's an hardware related error - it appears on systems with the new Intel multicore CPU's - E7200, etc.
    - I have different systems - AMD Sempron, laptop with Centrino Core 2 Duo, quad core Q6600, Intel core 2 duo E7200, etc. I had problems only on E7200 when I tryed to run the DOS program based on FoxPro 2.6 in FULL SCREEN mode. The errors pop's out and I am stunned ... what the F... I said; my new system ... has a problem ?!!?

    I tryed to run the program in many ways and the only one that worked is this - MAKE A .BAT FILE AND RUN THE PROGRAM WITH A SHORTCUT TO THIS .BAT FILE.
    If you don't know what is this, ask someone older than you.
    Open Notepad.exe, put this lines in it:

    @echo off
    cd c:\dir\subdir\

    and save the file with ".bat" extention. The "dir", "subdir", "program.exe" is just for exemple.
    Put this file in the "C:\" and make a shortcut on the desktop. In Properties, set Full Screen. This will work and the error is history. BUT....
    The program I have is crashing often; maybe you will be more lucky ;)
    If anyone knows more about this, please tell me why programs "Fox Pro for DOS" based are crashing on multicore CPU's when reindexing the databases? The Task manager shows the NT Virtual DOS Machine (ntvdm.exe) running at 45%-50% of CPU time, and it stops only if I End the DOS program in task manager when it crashed.
    I this it's something related with the settings, buffers, files, etc. I use FILES=150.
  17. tj1972

    tj1972 TS Rookie

    Hello Liviuandro,

    Just today i faced with this problem on my friend's compuper. i had in the past problems what MS calls 16-bit DOS subsystem (easily solvable) but this one is something "interesting". As i understood you suspect that there might be a "misunderstanding" between XP and cpu?. This comp here has Celeron.

    Since you say that MS does not have solution for it yet it means that this is a sort of a new surprise from XPSP3? What MS gives is only solutions for Win2K.

    i'm gong to reinstall win and see what will happen. hopefully it'll help.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...