Nvidia Display Driver Installation problem

By Weizegger ยท 7 replies
Jan 1, 2005
  1. Ok the problem im having is this

    I was playing Battlefield 1942 on my newly reformatted computer with a new Hitachi 160 gig HardDrive. Immediately I noticed how god awful the game began to run(even though I set my settings to the highest the graphics were low quality, rugged edges everywhere, effects look like they were made in microsoft paint, and there was overall extreme slow down and choppiness) I was completely surprised as all my other 3d games run perfectly under high settings(Call of Duty, Return to Castle Wolfenstein etc) and I already had updated display drivers and the latest version of Direct X. I then uninstalled my nVidia display drivers and redownloaded a new file of the display drive. Now here in lies the problem... when It began to install all the sudden I get this message from the comp "The NVIDIA Setup Program has detected that one or more Microsoft Hardware installation wizards are active. Do You want to continue with Setup? Click Yes to minimize Setup until you complete or cancel the other installation wizards Click No to exit Setup" the problem is that I dont have ANY other installations going on at this time other then the display driver installation and when I do click yes the program minimizes and I restore it, however no progress is ever made because the program is waiting for me to cancel some other installation wizard that I dont have running. Can someone please tell me what im doing wrong here(or what I need to close in order for the installation to work?)

    My Comp specs:

    AMD Athlon 64 bit
    1.8 gigahertz processor
    160 gig Hitachi Hard Drive
    512 megs of RAM
    GeForce 4 ti 1200
    Verizon DSL

    Please guys any help would be appreciated.
  2. Yourm8e

    Yourm8e TS Rookie

    Try reinstalling the old drivers and instead of removing them before adding the upgrade, just leave them there and try installing over it. It will autoupdate only the files it needs to.
  3. 3dalltheway

    3dalltheway TS Rookie

    I had the exact same problem, but have not yet found a solution :<

    I had SLI'd dual Geforce 6600 GT's and it was going great for a few days.
    Then I tried running two instances of WoW on the same screen (in windowed mode) with all the settings boosted up. It ran pretty well, but it was pushing the resources to the limit. Eventually, I began to see some problems--parts of the game display not updating. I check the temperature, it was 65 degrees (just fine). I closed everything, and then I noticed a 40%-50% of the (AMD 4200+ dual core) processor being used. Thinking something was running that hadn't closed properly, I tried rebooting. Processor is still churning it up: the processes nmixer.exe and services.exe. Also, the Device manager keeps refreshing every 1-2 secs, and when I try reinstalling any of the Nvidia drivers (nForce, Display) its gives me that error: "The NVIDIA Setup Program has detected that one or more Microsoft Hardware installation wizards are active. Do You want to continue with Setup?" This makes it IMPOSSIBLE to reinstall the driver. I tried rolling back the system with "System Restore". I get my drivers back, but the problem persists. At this rate, I'll never be able to install another driver ever again. I'm worried I damaged something by pushing my cards too hard.
  4. 3dalltheway

    3dalltheway TS Rookie

    Okay, I've found the problem. It's really very simple. The Nvidia installation program gives you the error when Windows' hardware management is busy. Check your device manager to see if it was "hiccuping" like mine (appears to refresh over and over). This *can* be caused by any faulty or damaged hardware, but it is *most likely* (and was in my case) caused by one of the USB devices. Unplug your USB devices one by one and watch the device manager for a few seconds to see if it stops hiccuping. (For me it was an auxiliary USB data cable for my new monitor.) When you plug it back in, if there is nothing wrong with the hardware, Windows should recognize and install the USB device. (Lesson learned: don't power off the monitor while the computer is on.) You should also see your processor activity go back down and your Battlefield game should run like it's supposed to (great game!)What I still don't understand is why the problem doesn't get recognized/fixed upon reboot! I guess that's USB for you.
  5. gewehr43

    gewehr43 TS Rookie


    Thanks for the info on USB devices; I was having the "device manager refreshing" problem, which began after I updated a number of video and chipset drivers. Naturally I assumed it was a driver problem, but your post prompted me to check my USB devices. The first one I unplugged and re-installed fixed the problem!

    Thanks again.
  6. jwall76

    jwall76 TS Rookie


    I registered with this site just so I could thank you. I've been messing with my PC for a week now trying to figure out why one of the games I play (lotro) had suddenly started to stutter.

    I updated drivers, defraged out the wazzoo, removed software, etc. nothing worked.

    Then I noticed my device manager was also "sputtering". After readin your post,

    Eureka! a simple check on USB devices . . . . first one unplugged fixed device manager . . . and lotro.

    Problem solved.


  7. zoloft45

    zoloft45 TS Rookie

    I had same problem and it is fixed

    I have Windows Vista Ultimate and two 8800 GT's in SLI mode, and Quad 6600 processor. I updated Vista and the nVidia Control Panel and Device Manager began to refresh constantly. I rolled back to earlier Restore points, uninstalled and reinstalled several versions of nVidia drivers (after uninstall in safe mode with Drive Cleaner Pro). I called Microsoft Support and they worked on it with me for three evening (really, they were great). When I booted in Safe Mode, Device Manager stopped refreshing, but nVidia control Panel did not. We did all of the above and then they asked me to unplug USB keyboard and mouse. Still no fix. Then the tech asked me to unplug all USB devices, and It all stopped refreshing. Why? Because I had been using a Targus external 4 port hub. Once that was gone and I plugged in all USB devices, everything was back to normal. I hope that this helps and I think any bad USB device could cause this.
  8. kimsland

    kimsland Ex-TechSpotter Posts: 14,523

    That reminds me of a time when I serviced someone's computer fully
    Then handed it back perfectly working
    Then the owner called me back, and said it's really slow and things aren't working

    Well I tried all the normal stuff over the phone (except I missed one option!)
    I drove all the way out to house 20 miles away!
    And found his little 4 port USB hub to be faulty (which took about 5 mins, unplugging everything first)

    I now state clearly to unplug all devices and just plug in Power; Video; and keyboard\Mouse (even test without Kbd\Mouse) before saying anything else.

    Actually I have lots of these stories (unrelated to this thread though)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...