Nvidia nForce2 ethernet driver won't install

By chinq ยท 9 replies
Apr 18, 2004
  1. I broke my mobo disk for the Chaintech 7njs. I purchased it in February 2003.

    I changed HDDs and could not install the mobo drivers. Chaintech sent me a new disk, with updated drivers....however, no matter what I do, the ethernet drivers will not install, under any circumtances.

    What do I do?
  2. chinq

    chinq TS Rookie Topic Starter

    The original ethernet drivers were not called nVidia MCP. The chipset is an nVidia SPP + MCP. The new ethernet drivers are called nVidia MCP. I don't recall what the original drivers were named, except they were not MCP.
  3. OS samurai

    OS samurai TS Rookie Posts: 159

    just so I make sure I understand your ? you replaced your mombo & now your ethernet connection is not working? what OS are you running? what happend when you tried to install your ethernet drivers?
    what errors are you getting?

    Welcome to TS:D
  4. chinq

    chinq TS Rookie Topic Starter

    nVidia nForce2 Ethernet Driver

    Thanx Samurai. I'm using Windows ME on one platform, and Windows XP on another on the same disk.

    Before I changed hdds (hard disk drives), I had the same dual boot system on the same Chaintech 7NJS motherboard. I had no problem installing the drivers for the mobo, nor did I have a prob getting online.

    On the new hdds (60 Western Digital Caviar IDE), and the Seagate 120 SATA hdd, I have problems installing the ethernet software.

    When the install starts ( it doesn't matter which drive it is), the install stops at 50% and the message says "install complete'.

    When I try installing the drivers manually, I get a message saying the "driver could not be installed".

    I can see the IP addy when I do a winipcfg. It is the ip address as when I disconnect that computer from the DSL modem and hook up this present one.

    The IP address, and subnet mask match (I always disconnect one computer and test the other).

    Some one told me that a MS Loopback may have occurred.
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Where did you get the idea that the drivers aren't working? It can be just a simple Windows configuration issue. Especially since Windows actually manages to assign an IP to the NIC.

    What output do you get from "ipconfig"? Can you ping your own IP address? Does the ethernel link LEDs on the NIC and the DSL modem show a connection? How about pinging the DSL modem? Have you tried installing another NIC?
  6. chinq

    chinq TS Rookie Topic Starter

    I can ping the IP address. Wasn't really thinking. The leds are lit for the DSL modem.

    What would cause me not to be able to access the Internet?
  7. chinq

    chinq TS Rookie Topic Starter

    There is no lights on the NIC, it is an onboard interface.
  8. OS samurai

    OS samurai TS Rookie Posts: 159

    what is the output of ipconfig can you ping a website like techspot with ping www. techspot.com? do you get an IP addy besides the loop back address
  9. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    "ipconfig /all" output from both the working computer and the not working one would be most helpful.

    Can you ping the modem?

    Does your modem create the DSL connecton or you or do you have to "dial in" from your computer? Can you access some status screen for your modem to see whether it actually has a connecton?

    Is the modem working as a bridge so that you receive an internet IP from it or do you have a local network?

    Could it be that your ISP allows you to connect from only one registered NIC and blocks access for others?
  10. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    Even onboard NICs have leds.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...