Nvidia Quadro AGP cards recognized as PCI

By dwillard
Sep 8, 2005
  1. Hello, all,

    My system:

    Computer: IBM Intellistation M Pro, model 6849-52U
    Mobo: Intel D850GB
    CPU: Intel Pentium 4 with 256 Level 2 cache
    RAM: 1GB PC 800 Rambus RIMM
    Video: Nvidia Quadro 2 Pro/Nvidia Quadro FX 1100
    AGP 4X slot
    Power Supply: 340W
    OS: Win2K SP4 (Computer has Microsoft Win2K COA)

    This is a workstation that I bought used (eBay) to run high-end engineering graphics. It came with the NVidia Quadro 2 Pro board (64 MB) which was an OEM option. I recently bought the Quadro FX 1100 (128 MB) used (also eBay) for the additional 64 MB to bring video up to snuff for the graphics I want to run.

    The Quadro FX 1100 installed just fine, and I noticed improvement in video performance from the added RAM. When I got curious and started really digging thru the info in the NVidia View program that comes with the drivers, however, I noted that the board is running at PCI X 0 speed, rather than at AGP 4.

    I don't know what the Quadro 2 Pro was running at before the upgrade, as I hadn't paid a whole lot of attention to the graphics before I did the upgrade. I did reinstall the Quadro 2 Pro card and drivers, though, and the Quadro 2 Pro also runs as PCI X 0 now. It probably was running at the same speed before I installed the Quadro FX 1100.

    As the computer was designed to run the Quadro 2 Pro, something about the way I have the computer set up is most likely the problem.

    I have checked the obvious things (BIOS settings, power to board, cables, re-installed drivers). I have also run both the IBM diagnostics package and dxdirect on the Quadro FX 1100 and the card and the AGP slot check out fine. According to the Nvidia website, NVidia 8X cards are designed to run at 2X, 4X or 8X depending on the capability of the slot they are put in.

    Now that I have gotten past the most obvious possibilities, I would much appreciate any suggestions on the finer details of what I should do to get the card(s) running at AGP 4X speed.

    Any thoughts on what my next steps should be?


  2. PanicX

    PanicX TechSpot Ambassador Posts: 669

    This sounds to me like a reporting error. If everything's running fine and faster than before, I'd tend to believe that you're running at the 4x speed and the nView program isn't reading this correctly.
  3. dwillard

    dwillard TS Rookie Topic Starter Posts: 28


    Thanks much for replying. I was starting to think that my post didn't make sense to anyone.

    As it happens, somewhere along the way I read thru about 15 pages of TechSpot posts that concerned AGP problems, as well as the FAQ responses on the PNY and NVidia websites.

    Eventually it sank in that perhaps when I installed a new hard drive I had left out something called the "System Management Controller" which manages the AGP as well as a few other I/O devices. Oops! :blush:

    For the sake of info to anyone who reads this, I tried to download and install the Intel INF utility that should apply to my chipset. It downloaded OK, but I couldn't get it to install. I also tried Microsoft Update, thinking that a critical update like this should be there, but for whatever reason I couldn't get MS Update to work for me, either. Bad hair day at the website or something, I suppose. :rolleyes:

    With panic setting in, I fell back on my tried and true problem-solving solution: Turn off the computer, get a sixpack of beer to clear my head, and think about things some more.

    And I found my solution with this time-tested procedure. I downloaded the software I needed from the IBM website under listings for my computer type (6849-52U), installed it, checked the registry to be sure it was there, then uninstalled the NVidia Quadro FX 1100 and driver and rebooted. :approve:

    I reinstalled the Quadro FX 1100 and driver after the reboot, and NVidia View now shows my system running at AGP 4x. And my video is faster, but I'll have to use the computer more to be able to judge whether or not it really is really 4X as fast as it was before this exercise. (Can anyone recommend a good test program to check this?)

    But for a fact, the unidentified PCI device that had been showing up in Device Manager has now disappeared. Good omen. I love IBM support! (This is an non-sponsored endorsement, unfortunately!) :)

    So I was mentally occupied for a day or two solving a problem, and now my video seems several times faster now that I have solved the problem. Doesn't get much better than this except when I get paid for solving other people's problems. :giddy:

    Thanks again for your input.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...