Odd problem with SATA and WinXP

By Messenjah ยท 13 replies
Dec 6, 2004
  1. I have just bought a WD SATA 200GB hdd and an ASUS K8N-E DELUXE mobo to go with it. This was part of an entirely new setup, and I excitedly put everything together and attempted to install WinXP. WinXP did the first part where it set up the drive you want to install the OS to and copied the install files to the HDD perfectly without a hitch. Then it restarted, and when it got to the WinXP boot screen, it just shuts off. I was like WTF!?!?! and i turned it back on and watched it do exactly the same thing again. I've tried installing RAID drivers for it, reformatted tons of times, and it still does the same thing. It gets to the first WinXP boot screen and just turns off.

    Can anyone help me with this problem? I'm at a loss on what to do now...


  2. Messenjah

    Messenjah TS Rookie Topic Starter

    There doesn't seem to be an edit button, so i'll just post here. I just tested my new computer with the hdd that's in this machine, a standard IDE hdd, and it's doing the same thing. Still turning off when it gets to the windows XP boot screen... I've tried with windows 2003 server eval edition, and it does the same thing. Anybody that can help?
  3. Crazy

    Crazy TS Rookie Posts: 139

    Sounds to me(i'm a noob in this area thou) that you have some settings wrong like ram timings or cpu speed ect.
    I had the same thing when i set my cpu voltage to low(2ghz o.c. to 2,5)

    Again, i'm not very good in this area :)
  4. Messenjah

    Messenjah TS Rookie Topic Starter

    Brand new machine. Stock Bios settings. I haven't had a chance to OC anything yet.
  5. Crazy

    Crazy TS Rookie Posts: 139

    It could still be a wrong setting like a voltage or something, it's probebly the stock bios settings that is bugging you.
    It would be very strainge if your new hardware was defective, so my first gues would be settings in the bios that are not working with your other hardware.
  6. Messenjah

    Messenjah TS Rookie Topic Starter

    I looked, and everything is turned down as low as it can go... Any more ideas?
  7. strat1

    strat1 TS Rookie

    Same thing with My K8N-E Deluxe.

    Did not want to Hyjack your Post, so I posted a simlar question! I am not able to post the link to it - but will post any answers I get on here.

    Good luck!
  8. Shiney

    Shiney TS Booster Posts: 160

    Unhook all other drives ie cds etc. then try again.
    Did you use the F6 function during xp install to load your sata drivers?
    Check the h/s and fan on cpu is working ok.

    Good Luck
  9. Moglie

    Moglie TS Rookie

    Make sure your PSU is providing the required power stated in your new mobo manual.
  10. The Best Alias

    The Best Alias TS Rookie Posts: 113

    I'm betting your motherboard isn't getting along with either the memory(most likely) or the video card (less likely). Asus mobo are kinda picky about memory. Several people here have reported conflicts between Kingston Value Ram and the A7n8x-e.
  11. Jimpsta

    Jimpsta TS Rookie

    Same problems

    Different units but same stuff happening to me - see thread on RAM/XP/SATA conflicts posted after yours.

    Have talked to someone who said they had similar till they stuck an IDE drive instead of the SATA. So I'm going to try that... lord knows if it'll work - will keep you informed...
  12. ithomson

    ithomson TS Rookie

    Bro - this exact thing happened to me and in the same process of trying everything under the sun in terms of different settings in the BIOS and in Windows (F6), I have come to the conclusion that there is some buggy driver code for SATA drives under Windows. I mean....

    1. I tried loading the 32 Bit drivers in XP PRO and it installed perfectly.
    Machine was flying, then I connected an IDE drive (as slave) and powered up, nothing...

    I ran Seagate diagnostics, and it said that the partition was stuffed. I then ran Windows recovery and it didn't see the entire partition - only 139Gb of the 300Gb drive. This was proof that the driver either messed up the partition table or something...

    So I reformatted the SATA drive, and left the IDE off.

    2. Machine was flying until I installed Windows XP 64 onto a spare partition on the SATA drive, and when it came to the reboot after installation, it bombed out exactly as you say.

    It seems that the driver or something is written to the boot sector that bombed out the boot process. Nothing works, the boot doesn't even get as far as offering the options to get into SAFE mode.

    3. As a desperate measure I disabled SATA, put the IDE drive back into the PC and installed Windows XP 32 onto it, got it up and running 1st time (Good 'ol IDE), and from there re-inabled the SATA drive in the BIOS (but not as the boot drive), the IDE drive booted up fine and picked up the SATA drive and believe it or not everything was still on the drive - no loss of data and no corrupt partition as Seagate had mentioned. I can access all my data off the SATA drive now, just cannot for the life of me boot up on it... It still crashes the PC if I choose it as my primary boot drive...

    I have been down the hardware road or checking PSU, RAM motherboard... I don't buy that, I think the SATA drivers or whatever is written to the boot sector is causing the mix up...

    Any ideas will help - there seems to be many others with a similar problem if you check the net, but no one is giving any decent answers... everyone is waffling on about choosing the correct F6 drivers and power supply issues, this is not the case. The ONLY think I haven't tried, it enabling the RAID option (although I only have 1 SATA drive), and allowing it to timeout and continue the installation of Windows XP. I always disable the RAID option.

    Although if I enable it now, it still dies on me at boot up (on the SATA drive).

  13. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Did you try to install XP without a service pack? It doesn't support drives larger than 137 GB.
  14. ithomson

    ithomson TS Rookie

    Yes, come to think of it, my Windows XP was the original one - no service packs. However after installing XP on both the IDE and SATA drives, I did install the SP2.

    Do you think this might be an issue?

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...