1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

One of the files containing the system registry data had to be...

By jjjapan · 16 replies
Sep 8, 2006
  1. Hello. I have recently bought a new computer. It is about 1 week old. I have installed XP Home Edition onto it, and for the first couple of days it worked fine. Then all of a sudden an error message popped up EVERYTIME I logged into Windows. The Error message is...
    "One of the files containing the system registry data had to be recovered by use of a log or alternative copy. The .... was successful"
    It is really beginning to grate on me. I have tried all of the things below:

    Booting to last known good configuration
    Virus Scan
    Registry Mechanic
    System Restore
    Creating a seperate user profile to the Administrator one
    I have also TRIED to use the XP Home Edition disc to use the recovery tool, however my computer will not boot using the CD. I have tried, booting for the CD by pressing F11 in which you can choose what you boot from and pressing F8 to use Safe Mode with Prompt and tried to do it manually and it STILL didn't work.

    I have looked up this problem on the Microsoft website and suprise suprise it is a load of unhelpful crap. I have Service Pack 2. I have all the updates. This is really annoying. I would LOVE to fix this before I go away to uni in two weeks. I have no idea what else I can do. I have searched the whole of the net for this problem and no forum thread or website has been helpful.


  2. fastco

    fastco TS Booster Posts: 1,075

    Booting off of the XP cd won't help you with the registry if it is corrupt. If system restore doesn't work then I would say the only way to repair it would be to Backup files, Format and reinstall Windows and all your software. Even if you did do a repair of the current Windows installation, it won't repair the faulty registry. If anyone has any more ideas I'm sure they will chime in.
  3. jjjapan

    jjjapan TS Rookie Topic Starter

    Ok. Well I would re install windows however if you reinstall it before 120 days the CD Key wont work. And I will have to phone Microsoft for another and explain my situation which will cost money. This is highly annoying. why can't computers just WORK.
  4. iamwk

    iamwk TS Rookie

    due to faulty bios or hardware?

    hi all,

    i've just had this error message pop up on me recently. it comes and goes.

    these are the things that i've tried.

    1. run CClean, it cleaned up my registry, made shutting down and turning on faster, but the error is still there
    2. run chkdsk /f /r
    3. formated the harddisk and tried to reinstall, but had problems formating the drive initially, dont' know why
    4. finally manage to reinstall windows xp home sp1 but still have the problem cropping up

    any idea what else can be tried?

    am running a centrino 1.4mhz, 512mb ram, notebook.
    did a hardware test but couldn't find anything wrong

  5. jjjapan

    jjjapan TS Rookie Topic Starter


    hey as you can see I also had this really annoying problem. I am afraid I tried everything you have and more and the only way I fixed it was to call the company I got my computer from. Then they proceeded to change the RAM and motherboard. They said if the computer's mem. isn't fast enough, or is faulty, for the spec of the computer this error comes up a lot. In the end I found out I had faulty RAM and they upgraded it, and with doing this they needed to upgrade the motherboard.

    I have alot of high spec things on my system which was giving the mem. trouble such as an XFI soundblaster soundcard, 7900GT Niv. graphics card and 400 GB's of RAM.

    This problem was highly annoying and i searched everywhere for help. You should get it fixed though because it starts to effect other things. for example windows said I didn't have a genuine copy and i did, then loads of things wouldn't work.

    I hope this helped.
  6. iamwk

    iamwk TS Rookie


    yeah, have finally given up and sent the notebook to the service centre...

    mine's a notebook...will probably cost me quite abit if it's the motherboard...

    oh well, will wait and see what they say

    keeping my fingers crossed!

  7. shinomen

    shinomen TS Rookie

    If you have already restored the registry and you continue to recieve this problem, then give the following a try

    The problem:

    I think this problem has something to do with file permissions for the ntuser.dat file or the directory it is located under. (typically located at c:\Documents and Settings\(username)\ntuser.dat) Ntuser.dat is the user specific registry file for HKEY Current User under regedit.

    My fix for this:

    **Note: You must enable hidden files and folders under tools folder options**

    1. Create a new user account with administrative rights on the affected machine. Navigate to the affected user's profile directory and copy ntuser.dat to a folder named backup on your C: drive.

    (example for a user named dave: copy c:\Documents and Settings\dave\ntuser.dat to c:\backup)

    2. Once you have backed up the ntuser.dat file, overwrite it with the one located in c:\windows\repair\

    (example for a user named dave: copy c:\windows\repair\ntuser.dat to c:\Documents and Settings\dave\ )

    3. Log off the temporary account you have created and login to the affected user account and let windows fully load up. This will create a new ntuser.dat file under the user's profile.

    4. Once windows has fully loaded up, log back out of the affected user's account and log back into the temporary account you made earlier.

    5. Copy the ntuser.dat file you backed up earlier to the user's profile directory overwriting the new file that was created.

    (example for a user named dave: copy c:\backup\ntuser.dat to c:\Documents and Settings\dave\ )

    6. Log out of the temporary account and log back into the computer under the affected account and see if the problem is fixed.

    Hope this work for you like it did me.
  8. ScoobyDaNoobie

    ScoobyDaNoobie TS Rookie

    Thanks Shinomen it worked like a charm on my laptop others users beware though while this method did work for me it might not work for you due to the following reasons, faulty RAM (by faulty i mean even if you have a 512mb which is standard for most laptops these days your motherboard ,gfx card soundcard might be too high spec for the RAM to handle after a long period of usage(even though we would expect the high paid technichians at Sony,Compaq,Toshiba etc to have figured this out b4 actually putting their LEMON products on our consumer shelves, once again capitalism reigns supreme over quality and durabilty for us little guys) or youve tried everything to fix this nice little glitch from microsoft (thank U! Billy G you hack!) and instead ended up screwing your registry and system files then in this case i suggest a fresh install and when the problem happens again afterwards please try Shinomens method first and foremost.Oh for the record i've done about 8 fresh installs since this problem first arose 2 months back and its been happening on and off again until i tried Shinomens method and now 2 weeks later still no annoying startup message
  9. confused asever

    confused asever TS Rookie

    My solution

    Unfortunately, none of the solutions worked for me, however thanks to "shinomen" he set me in the right direction. When I tried his solution I noticed I did not get the error messages when logging on with a new user account. Simple really, I just created two new user accounts, restarted and logges in using one as a temporary administrator facility to manually transfer all my personal stuff (emails email accounts and My documents plus anything else that would otherwise be lost) to a new main user account then restarted, logged back on with my new user profile and deleted the other two accounts. Not only has it fixed the original registry error but the whole machine seems more responsive and no problems to date. All programmes seem to work OK. The only problem was loosing a few preference settings which was just an inconvenience really.

    Best of luck to all.
  10. saiprem

    saiprem TS Rookie

    The question in my mind is: Who gives a **** if the system's registry data had to be recovered by use of a log or alternate copy? 99.99% of computer users only want their computers to turn on! They (we) don't care a rats *** about that message, so why would Microsoft even make that message come up, and then make it so hard to go away? Microsoft sucks. Windows sucks. Now we have Vista which sucks worse than then anything else!
  11. group6

    group6 TS Rookie

    No **** M$ sucks. I sure as heck wouldnt get on a plane that was run on Windows-"Ladies and gentlemen, this is the captain. We've had a glitch in the radar unit so we are going to shut down the engines and restart them. This should fix the problem. Dont be alarmed, actually the glide ratio on a Boeing 747 isnt as bad as you might think..."

    F*** M$ and may Redmond be the recipient of a large asteroid.

    There, that oughta do it.
  12. nickc

    nickc TechSpot Paladin Posts: 921   +11

    ^ lol.......
  13. durnell777

    durnell777 TS Rookie

    One of the files containing the system registry data had to be


    Before doing anything drastic like a format and reinstallation - shut the pc off and try different memory. Or if you have more than one stick of memory remove one stick and try again, if this works great, if not replace and remove another stick, if this works great, if not try different (preferably NEW) memory.

    Worked for me


  14. AdvancedGlobal

    AdvancedGlobal TS Rookie

    Quite significant detail - Hats Off

    My hats off to you for going through the trouble to not only mention the details of your determination, but elaborating on those details in a readable form that is legible and detail-oriented.

    I ran into this same problem this evening, and came across this link, and I just wanted to say thanks.

    This reminds me of the error in the event log about the user profile and the registry settings not being saved, and the patch that has to be downloaded to fix such a thing. However, my situation relates to a VM of XP I am running on my Macbook. Not that this would differ significantly in the sense that it's still a C: drive according to the VM, but it just made me wonder if it might have something to do with the VM or the VMWare software I am using, or possibly the fact that I am updating my VS2008 to SP1 and playing with an application I am building in ASP.

    More importantly, I wanted to make sure it wasn't a virus or trojan, as I had just installed Zone Alarm (possibly another avenue of suspicion) and that can cause problems, especially when running in a VM if one is not careful and keeping his/her eyes open.


  15. rmowbray

    rmowbray TS Rookie

    Replacing the memory worked for me

    Yes. Replaced the bad memory-
  16. ndsc_uk

    ndsc_uk TS Rookie

    system32 error on boot after the errormessage

    I am running Windows XP SP3 on two similar machines one which is online the other is not. The online one is protected by XPs firewall and Pcdoctor software, however despite PCDoc not detecting any infections I am getting the

    “one of the files containing the system registry data ….”

    error message on booting up on the online machine but not on the offline machine. This occurs about once every three weeks and it displays after the desktop and icons have launched. Clicking the ok on the message telling me the problem is fixed allows me to continue working without apparent problems. However, after normally closing down the next time I bootup I get the dreaded :

    “Windows could not start up because the following file is missing or corrupt

    I then Bootup from the Windows XP Cd and choose the repair option on the blue Windows start up screen and then choose the installation I want to repair (1. C:\Windows) and enter for password, then at the C:\windows> prompt

    C:Windows>CHKDSK /R

    The machine then takes about an hour to check all the disks and automatiocally repair. When the screen indicates 100% I bootup after removing the CD.
    Everything is then fine for the next week or two with no lost data or apparent problems…

    Although this always solves the problem I have no idea what might be causing it. And its frequent occurrence is annoying. Any ideas of what the underlaying problem might be?
  17. hopelessliar

    hopelessliar TS Rookie

    simple fix (?)

    Just in case somebody else stumbles across this post like I did when seeing this error message, here's the solution that worked for me.

    I simply change the amount of shared memory for the integrated graphics in the BIOS. It had been changed to 32M but when I changed it back to 64M, the error went away.

    Why this should be set up this way I have no idea (nice one Packard Bell!) but that's what the problem was in my situation. So although it does have to do with memory, it wasn't 'faulty' memory causing the problem.
Topic Status:
Not open for further replies.

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...