1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

oops! My hard drive has gone!

By Spike ยท 13 replies
Aug 17, 2004
  1. Last night, I accidentally deleted one of my linux partitions in the MMC, and so I decided that I may as well delete the other two. So i did. Over night, there was a powercut, and when I woke, my pc was off.

    On reboot, I was greeted with

    Searching for boot record on IDE0 (as it does)

    Li 0 1 0 1 0 1 0 1 0 1 0 1............................................. and so filled half of a screen and hung.

    Naturally, my boot drive (installation) being IDE0, and my data drive being IDE1, I booted the recovery console from the CD and fixed my MBR (fixmbr)

    The computer booted as expected, and windows started. no obvious problems.

    Now, I have a 700MB video file on my C: drive, and windows tells me I'm running out of space. I went to move it to the other disk, but on opening my computer, lo and behold, the only partition is c:

    The disk management snap-in in the MMC is only showing IDE0. Where's my other disk? lol

    Bios seems to pick up the disk, but windows doesn't. Rebooting hasn't solved it. I'll get bios to auto detect my disks again, but in the mean time, does anybody know why this happens and what to do about it?
  2. MYOB

    MYOB TS Rookie Posts: 492

    Unplug and replug the disks. Sounds too stupid to work, but has fixed a number of problems for me in the past (dodgy IDE controller).

    Windows should detect any disks detected by the BIOS though, if the IDE controller is working right
  3. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Yea. That sounds like a good Idea.

    I rebooted and entered bios just now. Apparently, my warm little IDE1, on the same controller as my warm little IDE0 isn't detected even by the bios now.

    I guess that makes this a storage and networking thread, if anyone cares to move it.
  4. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    OK. I've disconnected all ide cables, and reconnected them. I'm still not detecting my IDE1 on Primary Slave in BIOS.

    There was nothing at all wrong before the powercut last night, and the drive was working efficiently. It's a 40 GB (maxtor I think), and has had far less use than my 10GB on IDE0 (primary master).

    My next thought is to boot the computer with only th undetedted drive attached. I still can't see why only that drive would be knocked out though (or that ide position on the board?)

    Any better ideas would be welcome if anybody has one?
  5. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    I've just connected the drive in question on it's own, and it is just spinning constantly at top speed from the moment the computer is switched on. I'm assuming that this would mean that my drive is completely fried?

    What's bugging me is that the drive is only about 6-8 months old! There ws no warning before this happened either.

    Is it possible that a powercut could do this to my primary slave only without affecting anything else? Any idea's on what's wrong with the drive, and why it happened would be much appreciated.
  6. Goalie

    Goalie TS Booster Posts: 616

    Have you tried moving it to secondary master??

    A power cut is never good for devices, and if you run the risk enough eventually yes, you'll get bitten, but I really don't know the odds on that.

    If your drive is only 6-8 months, it should be under warranty....

    (Also, have you seen the thread about HD health/repair utilities?)

    Edit: I should mention that the "li ...." line indicates to me that there was corruption on the drive after the powercut. I've deleted my linux partitions before, and Lilo will prompt you saying it can't find its conf file (note that operating Lilo manually is a pita.)
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try Partition Magic or FDISK, to see if they detect it.
  8. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Thanks for that guys. Tried both now. Nothing detected at all. The thing just spins away at 7,200 rpm and nothing else. I would love to know why though.
  9. Shiney

    Shiney TS Booster Posts: 160

    I would say the drive is fried, the power cut may have sent out a power spike which fried it, i suppose some drive circuitry is better able to withstand the power spike than others-hence only one drive fried.
    Just a thought :)
  10. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    well, I just RMA'd the drive. If it was a power spike greater than the drive should have been able to cope with, I dare say I'll know when thy don't replace it for me. lol
  11. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    & that is why you should purchases a power-surge protection outlet or better yet an UPS.

    Just like a monitor, it's probably the only part of your system that won't be completely obsolete a year after the purchase.;)
  12. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    yes. So true. I guess i've just been lazy! lol. I've never really bothered to look at the subject. Well, I know about UPS, and the different kinds (can't really afford it), but not about surge protectors. I know what they do, but I wouldn't know a good one if it hit me in the face! lol

    Any chance of a link to something that would be appropriate in the UK?
  13. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  14. Spike

    Spike TS Evangelist Topic Starter Posts: 2,168

    Thanks guys. I've now got hold of a surge protector.

    Anyways, I got a new drive after RMAing the faulty one. I guess this means that the drive was at fault in some way. Still, it could easily have been the powercut instead. Better stil, they didn't hav any 40 gig ones left in stock, and instead of a maxtor powermax 8 40GB 7200, they gave me a powermax 9 60GB 7200. I guess it pays to be a regular customer! lol
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...