1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Open GL errors

By Burr ยท 4 replies
Mar 11, 2005
  1. make it work again please....
    SOF2 1.00 win-x86 May 3 2002
    Initialising zone memory .....
    ------- Filesystem Initialization --------
    Current search path:
    c:/progra~1/soldie~1/base/update103.pk3 (55 files)
    c:/progra~1/soldie~1/base/update102.pk3 (213 files)
    c:/progra~1/soldie~1/base/update101.pk3 (298 files)
    c:/progra~1/soldie~1/base/therest.pk3 (7125 files)
    c:/progra~1/soldie~1/base/textures1234.pk3 (10843 files)
    c:/progra~1/soldie~1/base/textures0.pk3 (2816 files)
    c:/progra~1/soldie~1/base/skins.pk3 (4117 files)
    c:/progra~1/soldie~1/base/musicandsound.pk3 (3055 files)
    c:/progra~1/soldie~1/base/mp.pk3 (338 files)
    c:/progra~1/soldie~1/base/models.pk3 (3643 files)
    c:/progra~1/soldie~1/base/maps.pk3 (466 files)

    32969 files in pk3 files
    Precaching string packages ...
    ... 3180 strings precached
    ---------- Getting System Info -----------
    OS: Microsoft WinXP Service Pack 2 (NT)
    Celeron running at 986 MHz
    253MB physical memory available
    --------- Client Initialization ----------
    Loading renderer.....
    --------- Initializing Renderer ----------
    Initializing OpenGL subsystem
    ...initializing QGL
    ...calling LoadLibrary( 'C:\WINDOWS\system32\opengl32.dll' ): succeeded
    Checking for ARB multisample ... GL_ARB_multisample not found
    ...setting mode 3: 640 480 FS
    ...using colorsbits of 16
    ...calling CDS: ok
    ...registered window class
    ...created window@0,0 (640x480)
    Initializing OpenGL driver
    ...getting DC: succeeded
    ...GLW_ChoosePFD( 16, 16, 0 )
    ...35 PFDs found
    ...GLW_ChoosePFD failed
    ...failed to find an appropriate PIXELFORMAT
    ...restoring display settings
    ...WARNING: could not set the given mode (3)
    ...shutting down QGL
    ...unloading OpenGL DLL
    Error during initialization SYSTEM ERROR
    GLW_LoadOpenGL() - could not load OpenGL subsystem

    ------------- Input Shutdown -------------
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Try reinstalling the video driver or game. If that doesnt work its usually easier to do a clean install of Windows. Its really hard fixing driver problems without mucking up Windows.
  3. LNCPapa

    LNCPapa TS Special Forces Posts: 4,247   +448

    BTW - dxdiag really shouldn't have anything to do with it seeing as it's an Opengl game. You can have d3d pretty much disabled and an Opengl game should still run if the drivers/card support it properly. As Vegas said I'd try reinstalling my video drivers first. It would also be nice to have your system specs in your profile so I wouldn't have to read your dxdiag results to see you're running onboard video.
  4. Burr

    Burr TS Rookie Topic Starter

    Ive downloaded intel 82810E graphics drivers probably 10 times. The game does not list intel as a supported product, but them game used to work. Would reinstalling windows be worth the effort? When it didnt work before, I spoke with someone and, if I rember correctly, he had me change the "3" here to "0" or something like that."WARNING: could not set the given mode (3)"-and it worked... now, I dont know what happened and it doesnt work anymore. Im getting blood thirsty and need to shoot somebody. Please help
  5. shadow_29

    shadow_29 TS Rookie Posts: 211

    sof2 (double-helix)......its a great game and a demanding one but since its based ona variation of the quake engine it should work on most systems.you didnt list any of your specs on the post...that might help you know.well this is an error a friend of mine used to get on his machine,he just removed and reinstalled his video card drivers but since you said you have downloaded and tried that but why are you downloading the driver dont you have the cd that came with your system?you might be installing the wrong chipset drivers.also have you installed any new utility/driver or program or game lately that might be the cause of this.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...