Spread the love! TechSpot Tech Gift Shortlist 2017

Partition Magic v.6.0 Problems

By drgrafix ยท 15 replies
Oct 31, 2005
  1. I wanted to be a nice guy and fix my wife's PC. Because when we first got it we installed PC-Cillin AV software, and then switched over to AVG... but even when I tried to remove the PC-Cillin it continued to try and re-install on every single boot. You could cancel through it, but you also got a fatal error message, and the machine would lock up every once in a while.

    Just for some background, it's a 850 AMD, 40 Gig HDD ultra HDD, has a CD Burner, floppy, and generally speaking it runs pretty good for my wife and daughter. The OS is W2K Pro.

    So... since the girls have tons of music (my daughter buys iTunes) stored on the machine along with loads of MP3s (actually about 6 gigs worth). I figured I'd use Partition Magic which I bought a few years ago, v.6.0 which is W2K compatible. Was going to create a new partition, move all the music and a few other picture files to the area. Did all that, everything went along real nice... I made a 20 Gig NTFS partition, so the C: [root] would be around 18 gigs NTFS. Everything went along just swell until I tried to use the W2K CD to re-format C:\. Now I can't boot the machine except with the PM Emergency Disks (1 & 2), and while the partitions show up there... in my PC's BIOS, I'm being told there is no HDD Master (or slave), just a slave CD-ROM drive. PM uses Dr. DOS (I think), so when I put in an old W98 boot disk to try and get things going, I get a message stating that I have the wrong OS.

    My problems seem to be:

    1. I can't get my PC to acknowledge that the drive is there.
    2. If I get the drive recognized, I don't want to lose all the music.
    3. I'm not sure whether there's another way to install W2K and make sure it goes on the newly resized primary partition (C:\).
    4. Would it help to get a boot disk file from someblace like bootdisk.com?

    Any/all help... greatly appreciated. My alternative is to go out and buy a new HDD, start from scratch, and slave the old drive. But I gotta believe that somebody can decipher this mess. The wife and daughter are not happy :(.

  2. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    I'm confused?
    you already had W$K on machine used a partition manager to make partitions?
    why reload W$K?
    you formated partitions?
    if you formated all of them you lost your data(kinda)
    you can retrieve ,but not easy.
    at this point you may need to find someone that will store data till you get OS back up..does hdd show up in bios?
    ther's a free boot cd out ther called the ultimate boot cd
    I have not used it,but heard it works great
    I use my own home made complie(rarely)
    and now
    don't forget to take the girls out to dinner

    and knitting and knitting
  3. drgrafix

    drgrafix TS Rookie Topic Starter

    Simple... I attempted for several months to get rid of the PC-Cillin fatal error on boot, and even when I called Trend Micro, they couldn't help me but suggested I install a newer version (buy it) of PC-Cillin and maybe the fatal errors would go away. In the meantime... the machine would sometimes freeze on boot, and other times make strange sounds, like it was searching for a file but we weren't doing anything.

    My logic was that if I used Partition Magic to make what used to be "C:\" into "C:\ [ROOT] & D:\[DATA]" then I could at least transfer all their music to "D:\" and once accomplished (I did get that far), I could reformat the "C:\" partition and reinstall W2K as the OS. So now I have two active partitions, one has the data that I moved, the other has nothing, and I can't boot/install from my W2K CD.

    Right now, I can use the Partition Magic Emergency Disks to reboot to the PM command screen only, where I can see both partitions, and note that the music appears to be on "D:\" (5 gigs worth). However, I cannot boot the machine otherwise. I used Partition Magic's Format Command to re-format the "C:\" partition and I think they use DR.DOS/Caldera. For some strange reason, I cannot get the BIOS in the PC to recognize the HDD at all. Its a 40 Gig modern 7200 rpm drive, and should get a reading in AUTO mode but it keeps saying that there is no HDD. To make matters more confusing, in the boot sequence, I briefly "see" the drive size 37820 MB. Short of buying a new HDD today and making this drive a slave... I'm baffled.

  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    To do properly what you (planned) you should have:
    1) resize C from 38 to 18GB and hit Apply
    2) create an extended partition, then in there the logical partition D (20GB) and apply
    3) format D in NTFS and hit apply
    4) reboot
    5) copy/delete or move the music from C to D
    and that would have been it! No need to reinstall W2K!

    To fix your quandary, try booting from the PM floppies and change the D-drive from a Primary partition into a Logical partition. That way there is only 1 active partition (C) and your BIOS should recognize the HD again.
    If needed you should now be able to reinstall W2K on C.
  5. drgrafix

    drgrafix TS Rookie Topic Starter

    Maybe the following will help you guys give me the advice I need to regroup/repair:



    (treat the dashes as empty spaces)

    Now I can't seem to convert too much in this group with regard to logical or primary choices, but that's probably some PM voodoo stuff. I do get the the following info (one way or another) when I try to boot:

    1. There are no drive letters assigned when booting in PM except for the unallocated line which is C:\.

    2. Primary Master Drive Fails (this is in the DOS BOOT)

    3. Boot says Drive 1: NONE (this is in the DOS BOOT)

    I'm beginning to think that part of the problem is the motherboard bios maybe... because I connected a 20 Gig 7200rpm drive to the exact same cable last night and the PC still cannot boot without saying that there is no HDD and that my Master drive is actually my CD-writer. Just for the record this is a ASUS A7V133 otherboard with built-in support for ATA100 as well as ATA66 HDDs. What is bumming me out is that prior to trying the drive swap last night, the case had not been opened so nothing was changed and I had all the problems this week.

    Again... thanks so much for the help.

  6. IronDuke

    IronDuke TS Rookie Posts: 856

    Delete the unallocated partition and it should boot OK. The hidden partition needs unhiding and it should show up as D:
  7. drgrafix

    drgrafix TS Rookie Topic Starter


    I'm at work so I can't try anything until later, but OK, I can delete the "Unallocated" partition or whatever it is, then un-hide the hidden NTFS partition and you're saying that'll it'll boot. What about the ROOT partition... there are no options available IIRC.

  8. IronDuke

    IronDuke TS Rookie Posts: 856

    At the moment the unallocated partition is your root.
  9. drgrafix

    drgrafix TS Rookie Topic Starter

    I'll surely give it a spin... maybe I can salvage it before major surgery :).

    OTH, if all else fails (and I'm asking because I really don't know/understand PM that well) maybe I could slave this drive onto another machine, extract all the songs, reformat the nasty drive back into a single 38 Gig deal, and then reinstall W2K, get it all smooth, and then transfer the music back to their machine?

    Although the A7V seems to have some weird quirks with regard to recognizing HDDs that are connected to the ATA100 blocks as opposed to the regular IDE blocks.

    Haven't been to the UK in a couple of years... last time was we attended a friend's wedding out in the midlands... Asby De La Zouch. Spent about 5 days in London, 3 before wedding, 2-3 after. Never rained which was bizzare.

  10. IronDuke

    IronDuke TS Rookie Posts: 856

    The slave route should be fine if needed, but probably not necessary.
  11. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    now as I see you can have you tried going into windows disc
    and your pc says there is no drive at all! it's not a sata but standard ide drive!
    I would try putting drive on 2nd ide cable as master
    put your cd-rom on first as master
    reset your cmos or bios to default
    on boot go into bios check to see if the disc is there
    if you get to this point you can again try the os install see if it shows both partitions.
    past that your MB went byby or the maxtor did
    I had a maxtor running for 6 months and shut it off ,it never came back on.then theres the old hard rap on drive trick ohya
  12. drgrafix

    drgrafix TS Rookie Topic Starter

    Interestingly enough, when I set the drive jumper as a slave on this PC, it was not recognized. I physically removed the cables from the current slave drive, plugged in and it said there was no drive. Scary.

    OK, so I removed it, reconnected it to the old chassis, set it as master on the jumper, then connected the cables and booted with the PM Emergency Disks. This is what I now have:


    *: ROOT------Unallocated---18,167.2------0.0---------0.08--------None---------PRIMARY

    (again, treat the dashes as empty spaces)

    Right now my need is to get the 5,301.4 MB's of data (mainly iTune$) off this drive and onto something more stable. So my questions are:

    1. Would be should I just try to make the "DATA" partition larger? Or should I try to "merge" these two partitions?
    2. If I merge the two partitions or expand the DATA partition, will I lose all the music files she has stored on the drive?
    3. Should I be able to set this drive to "slave" on my other machine as-is and "see" the DATA partition... and therefore be able to "move" it to a remote drive?
    4. Once the data has been removed/transferred, what would be the best way to reformat this Maxtor drive in a single NTFS partition so I can put it back inside the girl's pc either as the Master or Slave?

    I realize PM is doing loads of impossible things, but I wish they made it more intuitive to learn for the non-geek. Thanks again for the help.

  13. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Do option 3) first.

    If that fails (but it shouldn't):
    Resize the Data partition to include the 18GB at front. Click Apply.
    You should not lose your data.
  14. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    please let us know how far you got with this

    the stoned one
  15. drgrafix

    drgrafix TS Rookie Topic Starter

    Was able to extract music files off HDD after I slaved it. Funny, it didn't work the first couple of times on my primary cable so I disconnected my CD Burner and cabled it to that connection and it worked. Go figure.

    So now if I want to reformat this drive as one large NTFS partition, do I have to do anything special or do I just hook it up and run old-fashioned FDISK?

  16. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    The quickest would be to use PM again.
    Delete Data partition, hit apply. You should now have one big unallocated area.
    If not, delete anything else and hit Apply.
    Then Create partition (use ALL space), hit Apply
    Format in NTFS, hit apply.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...