partition woes

By yeah ยท 21 replies
Jan 4, 2004
  1. I recently had the "pleasure" of re-installing XP on my C drive due to my motherboard mysteriously dying. The problem lays in the size of partition that I could make. I am running a 120 GB drive, but I could only make a partition up to 31.4 GB. I asked a few people that I know, and one of them thought she had heard of a flaw being in the recovery program that would only let the user make a partition about that size. So I got Partition Magic 8 to try and increase the size of it, but that says that the maximum size is the 31.4 gigs. Anyone know how to get my space back?

    during bootup, the IDE detect shows that there is a 120 GB drive there, it's just that windows doesn't recogonizo it being that large.

    I am a newbie to this forum and a basic search didn't reveal anything useful, so if this had been covered, just link.

  2. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    How are you creating the partition exactly?

    ~30GB is the size limitation for FAT32 file system so if you are making a new partition as FAT32 it won't let you go above that.
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Windows XP and Windows Me create FAT32 partitions larger than 64GB. Are they stretching that file system thin or what?! :)

    If you are using FAT32.. Please don't! NTFS or die.

    32GB limit is a common barrier for older systems. But Partition Magic and Windows XP should not have a problem recognizing the full capacity of your drive. By older I mean first generation Pentium IIIs and first generation Athlons and older.

    Many drives have a "32GB clip", and if this is a new drive, you probably have this enabled. YOu can change this by moving the jumpers on the back of the drive... It works simliarly to master / slave only it is a secondary jumper that you can remove.

    If this is not the problem, you said you changed your motherboard. It may not support drives larger than 32GB. This usually can be solved by updating the BIOS. Visit your manufacturer's website for any updates you can apply.

    Alternatively, if there is no good solution, you can purchase an ATA PCI controller (about $30 USD) and this should solve your problem. PCI disk controllers have their own BIOS, bypassing the limitations of your existing system board.
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Nodsu is right for Windows XP, there the max. partition size with FAT32 is 32GB. (Windows 2000 does not have that limitation).

    You can either leave your partition as is, or convert it to NTFS.
    You can format the rest of your HD as one big partition under NTFS, or make 3 more partitions of max. 32GB under FAT32.

    PS: Rick's answer came in while I was formulating my answer, hence a bit of cross-wiring.
    But the 32GB limit under WinXP is confirmed by MS:
  5. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I must be mistaken then.

    However, Partiton Magic 8 does create very large FAT32 partitions. I just recently made a 80GB partition with FAT32 under PM8.

    I have also used a Windows Me startup disk to format drives larger than 32GB and I can swear I've used XP to do this too. That article is pretty solid proof. I will need to investigate this further. I know XP does support using larger FAt32 drives, but perhaps it will not format them?

    Either way, yeah should be using NTFS. :)
  6. yeah

    yeah TS Rookie Topic Starter

    ok, I didn't know that about FAT32 partitions, which is what i am using because this is the first time that I had done something like this. So I am going to convert it over to NTFS.

    I am using a ASUS A7N8X motherboard and a hard drive that is a little over a year old. So I do not think that those would be the problem.
  7. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    There shouldn't be a problem with your hardware then, save the 32GB clip jumper on your drive being in place.

    Try formatting NTFS and see if that fixes your problem.
  8. yeah

    yeah TS Rookie Topic Starter

    When I do this format, should I do a re-install of the entire OS? Or should i re-do it with Partition Magic?
  9. yeah

    yeah TS Rookie Topic Starter

    I Re-did the partition into NTFS, but i am still having the limitation. I re-did it through partition magic and it worked fine, I just need to get my space back.
  10. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    How about resizing the partition with PM?
  11. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    It is just as easy (using PM) to delete all current partition(s) and format the whole HD in one partition under NTFS. Then reinstall XP and whatever.

    On the other hand, having a smaller partition (say 10GB) with just your OS on it, and the rest (say 110GB) for programs and data, will make it easier for taking images of your OS.
  12. Shiney

    Shiney TS Booster Posts: 160

    As a matter of interest when you set up xp you mentioned a recovery program, what was this?

    Did you not set up from the windows xp cd and choose to create the partitions for the installation.
  13. alphnumeric

    alphnumeric TS Rookie Posts: 173

    XP can't create a fat 32 partition larger than 32 meg. It can use partitions larger than 32 meg, such as those created with a win 98 bootdisk etc. Also beware of Converting Partitions to NTFS Under Windows NT: Converting a partition from FAT to NTFS under Windows NT results in the NTFS partition being assigned the smallest possible cluster size, 512 bytes. This may cause a degradation in performance.
  14. yeah

    yeah TS Rookie Topic Starter

    When I try to resize the partition within PM, it wont let me make it any higher then 32,239.8 MB.

    The recovery program that I mentioned is the one that I got with my computer. It is a I Series Recovery CD-ROM for Windows XP home edition. I configured my computer through and that is the disk that came with the computer.

    When I was first going through to set up XP, it would only let me make a partition up to the 32 GB, and not any higher, so I dont know if it is a problem with the recovery program, or what the problem is.
  15. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    So now you have an NTFS partition of 32GB with WinXP on it.
    Partition Magic should be able to format the rest of your HD into one big NTFS partition (maybe delete whatever is after the first partition before you format). When finished, either leave the 2 partitions or use PM again to "merge" the 2 partitions together.
  16. yeah

    yeah TS Rookie Topic Starter

    I was working on this today and have found out that the problem lies within the BIOS as Rick said in his first post. So that got me working on finding flash upgrades off of ASUS's website. I am pretty sure that I got this board which then translates into this board on ASUS's site . I was looking at the 2 newest BIOS "patches" to see if those are the ones that I needed, so I downloaded them, and flashed the BIOS with them.

    I got the c18b1006 and 7 patches to flash, but that didn't do it. When I tried to get the AN8B1006 and 7 patches to work, I encountered an error. It said "The Program files BIOS-lock string does not match up with your system!" and there was a string of characters for LAN and 1394.

    I think that I need to install that patch that isn't working right now, and I don't know what to do because it keeps giving me that error.
  17. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Me thinks you sent your mobo to the eternal hunting fields!
    Asus specifically mentions different flash-files for different PCB-revisions, using the colour RED. You tried both, which is a NO-NO!!!
  18. Rick

    Rick TechSpot Staff Posts: 4,572   +65

  19. yeah

    yeah TS Rookie Topic Starter

    I tried to update the BIOS with both of the files with the AN8B1006/7 one first and it gave me that error so I tried it with the other one and although it flashed successfully, it still doesn't recognize my actual size. I get the feeling that you think my mobo does not work anymore but it does, just not as well as I'd hoped.

  20. Smactek

    Smactek TS Rookie

    Sounds like the 32gb limit jumper is still installed on the drive. If your not sure, please post the brand and model of the drive. I will post a picture of what the jumpers should look like. In most cases, the jumper should be removed for the 2 pins to ALLOW large disk access. Also you want to use 16 cyclinders NOT 15 if possible with the drive.
  21. yeah

    yeah TS Rookie Topic Starter

    Awsome. It was the 32 GB jumper that was messing the size thing up.

    I am going to post my specs. anyways so if anyone wants to check it out. The drive is a IBM Deskstar model IC35LI20AV VA07-0. The cap. is 123.5 GB, 7200 RPM and 16383 sectors.

    The pins when I started looked like "I _ " and now they look like "I I".
  22. Smactek

    Smactek TS Rookie

    Glad you saw the light. hehe. Just for reference. Here is a link to the hard drive jumper settings for your IBM/Hitachi Dekstar.

    IBM Dekstar ATA 100 Jumpers

    :D Glad I could help. SMac

    edited for link
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...