1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

PC won't boot up, mobo or video card problem need help

By dudezer88 ยท 5 replies
Jun 26, 2007
  1. Hi everybody, I recently put together a new PC about 2-3 months ago. It never really worked from the start though. When I hit the power button the system would turn on but it would just sit there, the IDE indicator light would be lit solid and I noticed a red LED lit on my video card, a Sapphire X1950XT 256mb, right next to the power input. Hitting the reset button would get it to boot up but now the reset button doesn't work either. I can replace the motherboard and video card, but I'd like to know if anyone has a solution before I get into that mess. System specs are below. Thanks.

    Sapphire X1950XT
    BIOSTAR NF4UAM2G Socket AM2 NVIDIA nForce4 Ultra ATX AMD Motherboard
    AMD Athlon X2 4000 brisbane
    Patriot 1gb ddr2 800
    Enermax liberty 500w PSU
  2. jdurbin6

    jdurbin6 TS Rookie

    couple questions, did you try another graphics card? the graphics card might have been a defect, or the graphics expansion slot on the mobo is dead (that's what happened to my last mobo), but yeah try a new graphics card first, then maybe the mobo needs to be replaced because of the slot (the slot being dead should be covered in the warranty)

  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

  4. dudezer88

    dudezer88 TS Rookie Topic Starter

    So, I returned my motherboard, got my replacement (same model) plugged everything in, started up, and the exact same thing happened. I tried the stuff from the no post tutorial and pulled everything one component at a time and no one thing seemed to be causing the problem. I even pulled an old pci video card out and plugged that in but there was no change. I was starting to think that there was something wrong with my power supply but I'm using it on my old computer now and everything is working fine. One thing I did notice is that the two red LEDs that lit up on my X1950 are labeled T_Fault and Ext_PWR. I'm not really sure what that means I'm going to do some searching but maybe someone here knows what that's about.

    I'm really stumped here. Any help you guys can give me is very much appreciated.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

  6. almcneil

    almcneil TS Guru Posts: 1,277

    Do you have the manual for the MoBo? Can you verify that you have everything wired correctly? Sometimes just one connector in the wrong place and nothing works!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...