Php pages won't work on my web site

By buffy450 ยท 4 replies
Dec 14, 2004
  1. I'll warn you in advance, I am a VERY green linux newbie so please word you responses in terms a third grader would understand. ;)

    I have some php scripts that I want to use on my web server. When I attempt to run them they all give the same basic error message that is similar to this one:

    Warning: main(functions/ical_parser.php): failed to open stream: No such file or directory in .. directory... on line 12

    Fatal error: main(): Failed opening required functions/ical_parser.php ( in ... directory... on line 12

    (I omitted the directories because this posting program keeps telling me I have to remove my URLs before I can post. This was the only way I could get it to accept it. Sorry...)

    I assumed that this meant that PEAR was not installed. Every script I have tried to run has ended with an error that talks about PEAR. IF I AM WRONG PLEASE LET ME KNOW! Not knowing anything about PEAR I did two things. First I tried running the pear web installer called go-pear.php. This worked well, for a minute or so. The output of the install job is printed below:

    Then it just sits there and goes no farther and I am baffled as to what to do next. Is there a way to install pear manually? Please remember that I am stupid, so don't assume that I know what you are talking about. :)

    I actually did try to download the pear base system, but I was expecting to see a source file. Instead all it is is a bunch of php files. What do I do with them?

    Many thanks and I look forward to hearing from you.

  2. The Best Alias

    The Best Alias TS Rookie Posts: 113

    It sounds like PHP isn't installed. Using Notepad, copy and paste this:

    <title>PHP Info</title>
    <?php phpinfo(); ?>

    Save as "Php-info-test.php"

    Include the quotation marks in the name so that notepad will save it as a .php file and not a .txt file. You can use whatever WYSIWYG (Dreamweaver, Front Plague) if you like. Upload it to your site, then hit it with your browser. If php is installed on your site, your browser will return a plethora of information. If not, then you've got some back pedaling to do because you want php installed.
  3. buffy450

    buffy450 TS Rookie Topic Starter

    php IS installed

    When I run the phpinfo script it gives back many pages of information so I assume that php appears to be installed properly.

    Does this imply that it is specifically a PEAR problem? If so, how do I install it manually? Do I just untar the files and move them to a specific directory? If so, what packages do I need to ensure that I have all that I need?

    Thank you for your help!
  4. MYOB

    MYOB TS Rookie Posts: 492

    You could have a permissions issue. Try running Apache, etc as root and see does the error pass. If so, its a permissions issue.
  5. buffy450

    buffy450 TS Rookie Topic Starter

    I'm stupid...

    I am so stupid.... It works now.... It had nothing to do with pear or php or anything else.... I untarred the file incorrectly. Not all of the files were in the appropriate directory and some were missing completely. It only took me a week of fiddling to figure it out too. :(

    Thanks everyone for the help. But hey, at least I'm learning.

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...