Pioneer DVR-111D Stuck in PIO Mode

By TheDrizzle
Feb 2, 2007
  1. Hey Folks,

    I am hoping someone can help me fix my problem with my Pioneer 111D DVD-RW drive. There is a bit of history here, so bear with me. I built a brand new machine with an ECS KA3 MVP Motherboard, and an AMD Athlon X2 4200+ CPU. I swapped hard drive from an old machine, and did a repair install of XP pro and everything went fine. I have a 120 gig HD and a 300 gig HD as master/slave on the primary IDE bus, and Pioneer DVR-111D as master on the secondary IDE bus. However, after about a week my DVD drive started fail when I tried burn any discs.

    I did some Google searching and discovered people had similar problems with this JMicron JMB363 chipset that is used as the secondary IDE bus on my motherboard. I did install JMicron drivers from the CD that came with my motherboard when I first set it up. In an attempt fix the problem, I downloaded a new version of the drivers from the JMB website for the chipset. When I ran the installer, it gave me two choices, to either install in RAID mode or install in IDE mode. Neither one worked. If I installed in RAID mode, my DVD drive was recognized as an SCSI drive and it would fail with IO errors every time I tried burning discs. If I installed in IDE mode, it worked but was stuck in PIO mode, which meant horribly slow and error prone burning plus it pegs the CPU. I could not, no matter what I tried, get the drive to be in DMA mode.

    So I tried hooking both of my hard disk drives up to the JMB seconday IDE bus and the DVD drive to the primary. Big mistake. When I booted back to Windows it gave me an error saying my Windows profile was corrupt. It tried to install some driver then rebooted. When it did, Windows would not boot. It kept cycling back to the bios. Somehow the JMB chipset erased my windows partition. I lost everything on my main drive. I had to reformat and re-install Windows. However, once I got everything back up, I DID NOT install a driver for the JMicron chipset. Windows installed its own PCI-IDE driver. It worked great for a week or so, my drive was in DMA mode and it was working.

    However, last night I was burning a disc and all the PIO symptoms came back. I checked the device manager, and low and behold the secondary IDE bus was in PIO mode only. Grrrr its so frustrating.

    I have tried everything to fix this. In the device manager, there is an option to set it do 'DMA if available' but it doesn't get it out of PIO mode. I have tried various different apps/scripts that 'hack' the registry to get it go into DMA mode, none have worked. I have tried uninstalling the entire IDE channel in the Device Manager and letting Windows re-install the drivers. Still it is in PIO mode.

    I am completely at a loss now. I don't want to install any JMicron drivers, I am NOT going to try and hook up my Hard driver to the secondary IDE bus again. Does anyone have any suggestions on how to get the DVD drive back into DMA mode?

    Thanks in advance...
  2. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Take it back to where you got it or just replace it with newer technology. No sence setting there and worrying about a optical device, they do go bad nothing is perfect these days..
  3. TheDrizzle

    TheDrizzle TS Rookie Topic Starter

    Got it working, finally. Turned out I was using a 40pin IDE cable, and that chipset requires one of the newer 80pin cables to achieve DMA speeds. Sheesh. Once I changed to an 80-pin cable, the DVD drive was functioning correctly.
  4. tipstir

    tipstir TS Ambassador Posts: 2,473   +126

    Sounds good!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...