Please help - BSOD and other errors. Comprehensive post inside.

By radiohead ยท 5 replies
Nov 22, 2006
  1. Hi

    I've seen a lot of people getting help at this forum so I figured I'd register, see if I can learn anything from you guys and maybe fix this PC in the process.

    Its literally about five days old - we bought it from a local company that builds 400 of these things a month and sells them all on eBay. They get good feedback, but thankfully they don't have mine yet. They claim to have tested this machine with Windows XP, but I'm not so sure they have.

    On first starting with the machine I had immediate trouble. I had a reset in the midst of a Windows XP Pro installation as it was trying to detect devices. One was a device driver related BSOD and the other was a BAD POOL CALLER, which I understand to be a RAM error? I think I fixed the latter. I come to that in a moment.

    Eventually I got the XP on there cleanly!
    However. Once it was installed I was still getting errors.

    Internet Explorer keeps ****ing up

    Internet Explorer was crashing, noting failing modules: mshtml.dll, flash9b.ocx and occasionally others.

    Because what stability I have is going to have to do until I figure out whats wrong, I've stopped using IE altogether, banned it from the Defaults and Permissions, and installed both Opera and Firefox to use instead.

    Only guess what? Opera and Firefox crash just like IE did. With Opera its failing module is opera.dll, with Firefox its firefox.exe... I have no idea whats going on here.

    Windows occasionally resets

    The resets kept happening at a regular frequency at first and I feared either bad RAM or that something had gone wrong in the installation. To rule out the latter I've done more than three clean installs on this thing! I've made sure I did every Windows Update, and on this current install used AutoPatcher XP and kept copies of the update files on another partition (just to expediate things when I do a clean install)...

    For the RAM I opened it up to have a look and noticed a loose power wire was touching the stick. I wouldn't have thought that would effect it too badly, but I carefully pulled the wire away, and neatened up the other loose power cables with a cable tie. On trying the machine again I believe I noticed a definite change in behaviour - and I haven't had that BAD POOL CALLER error since. Additionally - before doing this, I tried to install Nero 7 and got CRC errors as it extracted the installation CAB files. Afterwards, I never. There have been two clean installs since making this change, with no BSOD resets during installation.

    To double check nothing was wrong with the memory I moved it to the other DDR400 bay, and ran Microsofts memory diagnostic ISO. I left it running tests for ages. Not a single complaint. Thats where I'm at with the RAM at this very moment.

    I checked the temperatures in the PC with SpeedFan

    Temperatures look super cool if anything. I've noticed one temperature moving about as I do varyingly intensive things, and the fan accomodates. I assume thats the CPU?

    SpeedFan has a SMART tab where you can check out SMART devices that report their status. It notified me to "watch" the seek error level on my HDD. Its not at the warning level / threshold where the program tells you to worry but I thought I'd mention that anyway as it might be a clue.

    Windows said my video drivers were to blame for resets

    There are two Power Users on the Machine and myself (as Admin). After every reset, I get an error report message whenever I log on. I send the error reports to Microsoft every time.

    The first responses that popped up in IE were saying the video device driver caused it (a message about the driver being STUCK_IN_THREAD). I downloaded the latest device drivers for this chipset from, but I kept getting that error message. In the end I reduced Hardware Acceleration on it a couple of levels, and the error ceased.

    I can't say I'm entirely happy with that solution but its onboard graphics, and its probably pretty crappy. I didn't buy this thing first and foremost for games - so I can wait. With regards to the video, and memory sharing etc there are BIOS settings pertaining to it I think. I'm not sure if I have those set up correctly -- my BIOS settings are at the bottom of this post.

    Windows also says an unknown device driver is causing problems

    To get more information about the latter I've stopped the computer resetting automatically on a BSOD. The last couple of resets I've gotten an IRQL_NOT_LESS_OR_EQUAL error. The minidumps are attached.

    I've had one or two freezes

    I was just typing up this post before and the machine gradually froze up on me (I could move the mouse but nothing was responding). I haven't had this happen before but my brother says it happened to him while he was using Windows Media Player, and Internet Explorer.

    Peripherals and other things to be aware of

    The only additional peripheral I'm using is a USB Wacom Graphire (ET) graphics tablet -- I've only really been using the mouse, not the pen. In terms of software I've got AVG Free antivirus, Spybot, Bitcomet, and a few other things on here.

    My hardware setup is in my TechSpot profile, click here for my msinfo32 system summary, and I've attached some minidumps. I've written down all of my BIOS settings too.


    American Megatrends AMIBIOS 080012 7/20/2006


    Primary Master IDE = CD/DVD
    Primary Slave IDE = CD/DVD
    Secondary Master/Slave = N/A
    SATA1 = HDD (Maxtor 6v200e0)
    SATA2 = none


    Quick boot = Enabled
    1st boot device = HDD
    2nd boot device = Floppy
    3rd boot device = CD/DVD
    Try other boot devices = Yes
    Aperture size select = 64MB
    DRAM Timing = Auto
    Auto detect DIMM/PCI clk = enabled
    Spread Spectrum = Disabled
    Max CPU ID value limit = Disabled
    Execute disable bit = Disabled
    CPU TM function = Disabled
    C1E Support = Disabled
    Intel SpeedStep Tech = Disabled
    DRAM Driving = normal


    Onboard floppy controller = enabled
    Serial port 1 address = 3f8/irq4
    Onboard IR port = Disabled
    Parellel port address = 378
    - Port mode = ECP
    - ECP Mode channel = DMA3
    - Port IRQ = IRQ7
    Onboard PCI IDE Controller = both
    Onboard SATA IDE = IDE (as opposed to RAID)
    Audio device = enabled
    Modem device = auto
    Ethernet device = enabled
    - onboard LAN boot ROM = disabled
    Onboard USB function = enabled
    USB function for DOS = disabled


    ACPI aware O/S - Yes
    Power management - enabled
    ACPI enhanced efficiency - disabled
    Suspend time out - disabled
    resume on RTC alarm - disabled
    LAN/ring power on - disabled
    keyboard power on - disabled


    Primary graphics adapter = PCI (other option is AGP)
    Share memory size = 64MB
    Allocate IRQ to PCI VGA = Yes
    PCI IDE BusMaster = enabled


    CPU over clocking function = disabled
    DRAM Frequency = auto

    I really hope someone can help me. We'd like to avoid sending this thing back, and besides which I don't think the guys in the shop will know any more than you guys to be honest. If it has to go back I'd push for money back or different hardware!



    Attached Files:

  2. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    Probably the culprit is faulty ram.

    1. Run memtest to stress test the ram
    2. Re-install AVG as one minidump is crashed at AVG. The timestamp of your AVG modules are at year 2006 and 2005. It seems the AVG are installed improperly.

    Mini112206-01.dmp BugCheck 1000000A, {38509, 2, 1, 806e4a2a}
    Probably caused by : avg7rsxp.sys ( avg7rsxp+18b9 )

    Mini112206-02.dmp BugCheck 1000000A, {0, ff, 0, 80544f2d}
    Probably caused by : ACPI.sys ( ACPI!StrCat+2c )

    Mini112206-03.dmp BugCheck 1000008E, {c0000005, 8054afd2, f0dc570c, 0}
    Probably caused by : win32k.sys ( win32k!HeavyAllocPool+74 )
  3. radiohead

    radiohead TS Rookie Topic Starter

    I'm going to follow that advice now. There have been four crashes since my last post, so I have more minidumps in the meantime.

    Thanks a lot for the help so far, I'll report back once I've done more RAM testing and reinstalled / uninstalled AVG
  4. radiohead

    radiohead TS Rookie Topic Starter

    Interesting behaviour from Memtest-86.

    In PCI Plug and Play settings I have these options:

    When share memory size is set to 32MB, Memtest shows and tests only 992MB of my 1GB RAM by default (1024 - 32MB). When its set to 64MB, Memtest shows and tests 960MB.

    Using both values, I did hours and hours worth of passes in default BIOS e820 mode, no errors.
    I then did the BIOS - ALL option, and I got errors, too many to count or write down.
    When I used the PROBE method, it was again doing passes just fine. No errors.

    Like I said earlier, Microsofts memory testing utility yielded clean results. Memtest seems to yield clean results when I'm not testing the memory thats been allocated to share with the online video. So it seems to me like this is something to do with the onboard video and the way it shares / leeches off memory from the rest of the system?

    I can't set that share size below 16MB by the way. There's just no option.
  5. radiohead

    radiohead TS Rookie Topic Starter

    Hi... another update.

    I sent back the RAM and the company sent out a new stick for me to install. I installed it yesterday and I was still getting the same problems.

    Changing the DRAM frequency from Auto (Where the bios detects it as 400mhz) to 200mhz seems to have stabilised my system. Its a single stick of 1GB DDR400 / PC3200 RAM... I've just been reading on Wikipedia that DDR400 RAM is designed to run at 200mhz??!

    So has my BIOS' auto detection been the cause of all the trouble or am I currently underclocking my RAM frequency?

    If somethings still not right (ie. if my system should be stable at 400mhz) I'll take it up with the company again and make sure it gets sorted, but if its simply because of how the BIOS had things set up, and this sounds okay now, I'm quite happy.
  6. sghiznaneck

    sghiznaneck TS Maniac Posts: 403

    Auto detect is in fact the culprit. DDR stands for double data rate, meaning instead of one bus pass per clock cycle, it in fact doubles that to two bus passes per clock cycle (200mhz X 2=400mhz). It is strange to have the auto detect do that since the bios should automatically detect that the DIMM slots for your memory is DDR and should have adjusted to 200mhz instead of a full spread of 400mhz.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...