Plug and Play software device Enumerator and Service Pack 2! No sound

By jasper1106 ¬∑ 6 replies
Jul 15, 2007
  1. [SOLVED]

    Hi guys,

    After a reformat yesterday due to a new hard drive everything was fine, I then couldn't understand why the sound suddenly disappeared. Reading a post on the net after trawling for hours it has become clear that when Service Pack 2 went on all the sound disappeared.

    I looked through the device manager today to find that "Plug and Play software device Enumerator" has a yellow exclamation mark by it. With the properties:
    "This device is not working properly because Windows cannot load the drivers required for this device (code31)

    I located the swenum.inf file on the Internet which is the drivers for this device so I have tried to reinstall but each time it turns up with this yellow exclamation mark.

    I've reinstalled the drivers for soundmax from the Toshiba CD as well as downloading the fresh .zip for the sound card from their website.

    System Info: Windows XP Home
    Celeron CPU 2.60GHZ
    496 RAM
    Toshiba Satellite A40

    So after a lot of searching and no answers, I decided to restore back to Service Pack 1. Sure enough on boot the sound was all working and the Enumerator under System was working no probs. So I then run Windows Update yet again, after another 3 hours of downloading and installing, service pack 2 was for the 2nd time applied to my system. On reboot, yes all the sound has disappeared and I am back to square one with the Enumerator having problems.

    Any help would be greatly received, thank you in advance!
  2. CCT

    CCT TS Evangelist Posts: 2,653   +6

  3. jasper1106

    jasper1106 TS Rookie Topic Starter Posts: 16

    Hi CCT,

    Thank you for your quick reply. I followed all directions and it installed the Enumerator once more - however after the reboot it still remains in my device manager with the yellow exclamation mark.

    I then tried disabling the device, which worked but on enabling it again, back to the yellow mark. (thought it was worth a try).

    Any more ideas :S
  4. CCT

    CCT TS Evangelist Posts: 2,653   +6

    Interestingly enough, I don't have that inf file on my comp but do have the swenum.sys driver in C:\Windows\system32\drivers .

    Date is 04/08/2004

    Do a 'search' and find yours - I believe the cab files can be extracted to the win32\drivers folder - pick the driver from the older cab since that is probably the SP1 version that 'works'
  5. jasper1106

    jasper1106 TS Rookie Topic Starter Posts: 16

    Hi CCT,

    Thanks again for your reply. After 2 days of searching I have finally found a solution on another forum, this fix supposedly came from another forum before that, so whoever wrote up this fix, thank you very much as it fixed the problem. For anyone else having this nightmare:

  6. CCT

    CCT TS Evangelist Posts: 2,653   +6

    '8.) Now reinstall your "PnP software enumerator" following the steps mentioned in the posts above. (In the hardware manager click "have disk" and choose your temp folder and the inf file in there, choose "PnP software enumerator" under standard devices or something like that).'

    People will need that URL or the instructions for re-install he mentions.

    Otherwise, great material.

  7. jasper1106

    jasper1106 TS Rookie Topic Starter Posts: 16

    Hi CCT, the fix for the reinstall was actually the link your originally posted me:

    The sound drivers needed a little fiddling with afterwards but the fix got rid of the corrupted enumerator.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...