1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

'Plug-N-Play BIOS Extension' shows "!" under 'System Devices'...how to fix??

By PRELUDiCON ยท 5 replies
Jan 20, 2005
  1. My MOBO is ASUS P4P800 Deluxe.
    I just recently flashed my BIOS to the latest BETA version from the German ASUS FTP site in order to correct my compatibility issues detecting my 300GB Maxtor SATA drive.

    All was perfect until I tried to connect my mobile phone via USB and something went wrong and it wouldn't detect properly. The phone does, however, show up under USB devices as MOTOROLA USB MODEM, like it did in the past.

    So I don't know what's the problem... and don't know how related this issue is, but then I saw that under 'System Devices' there is 'Plug-N-Play BIOS Extension' listed twice.

    First one is fine, second one shows an exclamation mark and under properties it says that there is some corruption in the registry or something.

    I don't like exclamation marks anywhere under Device Manager. I hope someone can tell me how to fix this...

    Do I look for a driver? And if so, which one and where? Is this 'device' suppose to be listed twice? Maybe I should just try 'removing' it?
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,372

    Click on update driver

    PRELUDiCON TS Rookie Topic Starter

    n den?

    that was the first thing I tried actually... it does not find the driver automatically and I don't know where to look for such a driver because all I know is that it is a "Plug-N-Play Bios Extension" device...

    How can I find out what driver I need for it and where to get it ?

    PRELUDiCON TS Rookie Topic Starter

    I uninstalled it ...

    Then tried to scan for new hardware in an attempt to reinstall it and nothing was found.

    Like I said, there is still another entry called "Plug-N-Play Bios Extension" working fine...

    Anyone know what this actually is or what it does and maybe even how many of these entries is normal ?
  5. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,372

    Go into the BIOS and make sure Plug And Play OS is enabled or says yes.
  6. crackkillz

    crackkillz TS Rookie

    same issue, different cause

    i am having the same problem on my machine. there is a exclamation point after the second of the two plug and play bios extension's in my device manager. heres my specs:
    video:Saphire Radeon 9000
    sound is onboard, anything else is moot atm.
    i found that after i uninstalled divx, this occured. im sure about this because after i noticed the problem i restored to the earliest point when i did not have this problem. I uninstalled divx and sure enough it happened again. i have tried uninstalling, updating, and even disabled it. i have not noticed any actual effects of this issue. but i feel the same way PRELUDiCON does. i dont like having the ! in my device manager. any info is greatly appreciated. i apologise if this topic has been resolved in another thread.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...