Poor graphics performance/artifacting with an 8600gt

By mattf_89 ยท 5 replies
Sep 8, 2007
  1. I just bought a new Asus 8600gt graphics card. Playing games with the card results in extremely poor performance compared to benchmarks I've seen in reviews, and in some games (stalker and bioshock with high level shaders enabled) artifacting also occurs (flickering black polygons etc.). I've checked the load temperature of the card and it doesn't go above 55 degrees C, so it seems overheating is not an issue. The card is also running at the stock clock settings. The latest Nvidia beta drivers (163.44) are installed (and I've also tried the non betas, 162.18, made no difference), I ran driver cleaner in safe mode and I've tried reseating the card.

    One possible cause I can think of is my PSU. The card is in a dell dimension 4700 desktop computer, and the psu is 305W
    (specifications here: http://support.dell.com/support/edocs/systems/dim4700/sm/techov.htm#wp1053452).
    However, I don't seen any of the usual PSU issues (random resets etc.), just this graphics issue. I've also seen on several forums that people have been running the same card with the same dell psu without any issues. Is it possible that the psu isn't supplying enough power to the card, causing the poor performance?

    If it helps, my previous graphics card was an x300SE, and I had no such problems with it.

    Thanks .
  2. kpo6969

    kpo6969 TS Maniac Posts: 710

    No it's not possible. I have a Dimension E521 and run a 8600GT. Your psu has 22amps which is more than enough. How much ram do you have and what's your cpu? I believe the issue is one or the other.
  3. mattf_89

    mattf_89 TS Rookie Topic Starter

    I have a Pentium 4 3.4ghz processor and 1gb ram (2 sticks of 512mb).

    I had a look at device manager and there are a few things in an error state which weren't there before I installed the new card (not the video card itself, but they appear to be related to it). I've attached a screenshot of it.

    Attached Files:

  4. kpo6969

    kpo6969 TS Maniac Posts: 710

    1.Did you dis-able your on-board video in your bios? It looks like your video drivers are corrupt. Try this:
    1.Download new drivers again, save to your desktop.
    2.Delete the 8600GT from device manager-right-click, delete.
    3.Delete drivers from control panel
    4.re-boot system, when Windows screen comes up about display drivers-cancel out of that screen
    5.Disable anti-virus
    6.Install new drivers
    7.Reboot system
  5. mattf_89

    mattf_89 TS Rookie Topic Starter

    Hmm, well it _appears_ to be fixed. I tried reinstalling the drivers again, and when that didn't resolve the problem I flashed the latest Bios update for my motherboard, which seemed to fix it (although I have absolutely no idea why). Bioshock is running well on high now.
  6. kpo6969

    kpo6969 TS Maniac Posts: 710

    Good to hear.:approve:
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...