Power Problem

By Damian ยท 10 replies
Sep 18, 2003
  1. my backup computer has an odd power problem that I suspect has something to do with a damaged reset button... its an AT style case with both a power button and reset button, when it boots everything gets power, the fans, cd rom etc... but thats where the process stops and the post beep goes on forever as though there's a power problem..... also pressing the power button no longer turns the system off, but when held down for a long time it does (normally just one press is fine).... the reset button has had problems in the past with getting stuck and causing a similar problem and its visibly messed up due to severe beatings... also I ripped part of the casing's front off since this particular part of the computer can't be seen by merely removing the main casing.... pressing the reset button produces random results as far as the mechanism is concerned because its badly damaged, so I wonder if its somehow in a state of constantly being held down even though it looks like it's semi-depresses sometimes...

    also the system is amd 450mhz, 64ram, ati rage fury blah blah but I know the individual components work fine....

  2. StormBringer

    StormBringer TS Maniac Posts: 2,244

    Looks like you have answered your own question. It is very likely that faulty switches are to blame. And since you say it is damaged anyway, replace it and see if it corrects the problem.

    1. the part is inexpensive
    2. sounds like it needs it anyway
    3. its an easy repair to make

    If it doesn't turn out to be the problem, reply and let us know and we'll go from there.
  3. Nic

    Nic TechSpot Paladin Posts: 1,549

    You can always disconnect the reset switch from your mainboard. You don't need the reset if it is causing you problems, as you can always switch off by disconnecting the input power. You can use this method to narrow down the problem and replace your reset switch later if you wish to do so.
  4. Damian

    Damian TS Rookie Topic Starter

    ok I disconnected the reset switch from the motherboard (which was easy to find since it was marked "reset sw")... the problem persits, same never ending beeps, still not responive to the power switch once turned on, full power and no video....

    also my case has always had a strange setup that requires the power switch to be pressed exactly 3 times to turn it on otherwise it turns off after like 5 seconds....

    so if the problem isn't related to the switch I'm stumped please help....
  5. Nic

    Nic TechSpot Paladin Posts: 1,549

    Are you running an AT power supply, or have you fitted an ATX power supply? Is your system an ATX based system? When did this problem start?
  6. Damian

    Damian TS Rookie Topic Starter

    the original case was used for a pentium pro system around 1995, then around 1998 it was gutted and an atx style powersupply/motherboard were installed.... since the case was AT I didn't notice that ATX parts were used in it....
  7. Nic

    Nic TechSpot Paladin Posts: 1,549

    The power switch in an AT style case is an off/on type switch, whereas an ATX style case power switch is a momentary contact type. The two are not compatible. This appears to be why your system is continually rebooting until the switch is released. Get a proper ATX case, or a new power switch of the correct type.
  8. Damian

    Damian TS Rookie Topic Starter

    now I'm really confused, the AT case worked fine for years by pressing the power switch 3 times (the switch goes from the on, to off and back to the on position) to boot...

    also after unplugging/replugging the "power sw" jumper the computer no longer beeps but still has the problem of no video signal and not turning off properly.... also it now turns on for 5 secs and shuts off when I insert the power cord into the case even though it should be shutdown (this 5 sec effect is what would normally happen if the switch were pressed less than 3 times)...

    what kind of mad technician would rig an AT case to work with ATX gear back in 98.... I didn't know much about hardware back then so this went unnoticed for years....
  9. alphnumeric

    alphnumeric TS Rookie Posts: 173

    Might try to clear the cmos (reset the BIOS). Should be a jumper on the mother board to do it. Make sure the power is OFF and you put the jumper back before you power up again. removing the battery for 5 does the same thing. It resets it back to fail safe defaults. The 5 sec delay is normal on shutdown is normal. There is a setting in the BIOS for it, instant or delayed shutdown on button press. On an ATX mother board the reset and power switch (front case mounted) are momentary. On an at power supply the power switch actually switches off the main line, it's not momentary and it usually is wired to the power supply. Sounds like your at switch was connected to the motherbord. You end up pressing it twice to start the PC, off, on ,off.
  10. Damian

    Damian TS Rookie Topic Starter

    thanks resetting cmos fixed everything...
  11. alphnumeric

    alphnumeric TS Rookie Posts: 173

    Your welcome, glad you got it sorted out. And thanks for posting back with your results. :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...