Power Supply Problem?

By powermanaf ยท 7 replies
Apr 11, 2007
  1. I have an eMachines T2642 system and a week ago when I went to go upstairs to use it, it was off, so I pressed the power button to turn it back on, and nothing happened. Then I noticed a kind of high pitched noise coming from the power supply, so I figured we had some sort of power surge and it blew the power supply. So I bought a new one, put it in, and still, nothing happened, but there wasn't any kind of noise coming from this power supply. So I searched on this forum and tried taking the battery out of the motherboard and resetting some stuff, but still nothing. So I figured the motherboard went with the power supply. So I purchased a new one, just installed it, hooked up the power, and it still will not turn on. Oh, and the green light on the ethernet port comes on, so does that mean some power is getting to it?

    Any ideas on what this could be? I am going crazy with this thing.

  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    When you bought the new board did you use the same components, like the CPU and memory ?, its possible that they have gone bad or they arent compatible with the board, also try booting the PC up with nothing connected to it apart from a VGA card (unless its onboard) and 1 stick of memory,

    It may be a case of take it to a repair shop who will be able to swap parts about until they find the faulty part.

    Post back with

    make and model of board
    make and model of memory, how many sticks and size
    Make and model of CPU.

    If its an incompatibility issue someone will spot it for you.

    Lastly are there any jumpers on the board, some boards come with the CMOS reset jumper set, end result when you turn on the power it doesnt boot, changing the jumper to what it should be will result in the board powering on, its location will be in the motherboard manual.

  3. powermanaf

    powermanaf TS Rookie Topic Starter

    Motherboard: Biostar P4M80-M4

    Memory: NANYA 256MB DDR-333MHz PC2700 (1)

    CPU: Intel Celeron 2.60GHz Processor

    I checked the CMOS jumper and it was set to the normal state, not reset.
  4. powermanaf

    powermanaf TS Rookie Topic Starter

    Actually, the problem wasn't solved. Is it possible that the power button simply isn't working? I have tried two different motherboards and power supplies, and still, nothing happens. The only hint of power I see is that the ethernet port lights are illuminated when the power cord is plugged in.
  5. Tedster

    Tedster Techspot old timer..... Posts: 6,002   +15

    go to the cpu forum and read the FAQs on e-machines
  6. powermanaf

    powermanaf TS Rookie Topic Starter

    Are you referring to the sticky on that forum? If so, I have already replaced the power supply, but if you are referring to something else, then I can't seem to find an eMachines FAQ on that forum.
  7. powermanaf

    powermanaf TS Rookie Topic Starter

    Could a burned out CPU be causing the system to just not power on at all? Maybe the PSU took out the motherboard and the CPU?

    I am trying to eliminate all possibilities.
  8. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415

    Thats why I suggested taking it to a PC shop they can test the various parts for a small fee,

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...