By turbo1 ยท 8 replies
Apr 9, 2007
  1. Hi everyone,please bear with me if this topic is already posted.I have this ATI Radeon 9600 Pro/256MB that was a gift from a friend that he bought when he was in U.A.E.the problem is,it was'nt with the box,no driver (CD),no owner's guide or manual,just the card wrapped with bubble pack (brand new though).He intentionally left the box without taking off the driver,packed his things & went back home.(how st_ _ _ d).

    i have tried almost every version of the catalyst drivers or any ATI installers as well as Omega radeon drivers but no luck,all of them give's me same error.... "set up was unable to find components that can be installed on your current hardware or software configuration.please make sure you have the required hardware or software"...... just to find out from ATI.amd.com's technical support that the ones that has the logo or marked with "POWERED BY" ATI needs a different driver & that should come from the manufacturer.And the ones with "BUILT BY" ATI i supposed does not have problems with the compatibility on other regular ATI drivers.

    Any one who can direct me to a site where i can download the driver?or anyone kind enough to share the driver?please help....
  2. HPCE_Larry

    HPCE_Larry TS Rookie Posts: 132

    Do you know who the manufacter was? It should say somewhere on the card.
  3. turbo1

    turbo1 TS Maniac Topic Starter Posts: 353

    its not printed on the PCB...on the heat sink part was just "POWERED BY" ATI,there is the product number & written right after it was ATI TECHNOLOGIES INC.....other than that is ATI RADEON GRAPHICS & other series of numbers & conformity of the product i guess,thats all.
  4. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    Most of the ATI cards I've owned were not made by ATI itself (only one was) and I've never had any problem using the ATI Catalyst drivers from ATI/AMD's site. However, using the latest Catalyst Control Center driver bundle requires Microsoft's .NET to be installed. Have you done that yet?
  5. turbo1

    turbo1 TS Maniac Topic Starter Posts: 353

    i have the .NET Framework 1.1,or do i have to download the 2.0?
  6. mailpup

    mailpup TS Special Forces Posts: 7,182   +469

    It wouldn't hurt to install 2.0 but I think 1.1 is sufficient.
  7. turbo1

    turbo1 TS Maniac Topic Starter Posts: 353

    still the same,no change with 2.0 .NET Framework...anymore suggestions? please help..thanks.
  8. Sharkfood

    Sharkfood TS Guru Posts: 1,019

    This is the same with NVIDIA- where the chipset manufacturer designs the chips and models a "reference" standard board design, then this reference design is handed to independent board makers who may choose to follow or modify from that supported reference design as they so choose. Most simply change brands but keep the important things pretty consistent- i.e. different brand/speed memories, different coolers, add-on capture/tv chips, etc.etc.

    Interesting note aside- ATI doesn't even make boards themselves. They outsource their own ATI-branded cards to other makers (in the past, companies such as Powercolor or Sapphire made the Built-By for ATI... not sure who it is currently).

    As far as your current issue- I doubt this is a Powered or Built-By issue but instead a Windows issue. It sounds a lot like you may have a non-genuine/pirated version of windows that is device-manager locked to the SP1 or SP1a level.

    The issue you are encountering is common of older imaged/pre-SP1 or SP1a ****** versions of windows. It's because the VGASAVE drivers are hacked and have no way to get the more current device manager bindry drivers. If this is a non-genuine version of Windows, this would explain it. If it's a genuine version, upgrading to real Microsoft SP1A or SP2 for XP, along with using Driver Cleaner Pro in Safe Mode/Administrator should cure it.

    More rarely, it could also be an IRQ issue. You need to hunt around in the BIOS and ensure it has:
    a) Any possible integrated videocard disabled.
    b) Any settings for "ASSIGN IRQ TO VGA" set to true.
    c) If the above don't help, try flipping the "Plug n Play OS" setting to opposite of what it is now.

    Good luck!
  9. turbo1

    turbo1 TS Maniac Topic Starter Posts: 353

    i got your point & very well said,thanks.....the issue not on the IRQ or BIOS or in PNP OS neither.But you gave me an idea about the virtual resource manager device driver.It could be a windows issue,but im aware that i have a geniune version like my other friends where all of us bought our computer systems in one computer store & they dont have problems with windows so far.we all have same specs but we varry on add on cards.I'll try to have the whole thing manually updated...thanks again.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...