Preboot BSOD 0x0000007e Only boots in VGA mode

By jeffkrol ยท 19 replies
Nov 27, 2005
  1. SOLVED:preboot BSOD 0x0000007e Only boots in VGA mode

    Something died in my computer so I replaced MD/CPU/ and power supply. Had to do a re-install of Win XP. Did and XP (original, old CD) worked and booted fine.
    Added XPSP-2 and then it wouldn't boot except in "boot in VGA mode". At this time I had limited hardware installed. Anyways, tried removing video drivers, tried 3 video cards ect. Still BSOD's me on normal boot. Used to do this in safe mode as well but now for some reason safe mode works. Anyways haven't found any fix as of yet. Last thing I did was to try to swap mem slots (1,3 vs 1,2)
    AMD64 2800+
    2- Corsair Valu RAM sticks at 512 each
    Error 0X00000007e (0xc0000005, 0x00000000,0xf7a2f0c0,0xf7a2edbc)
    minidump (though nothing looks new here)
    Looks to be blue screening before minidump. Also not thinking it can be any hardware "fault" (except some bizarre incompatability) because XP runs fine in VGA mode. Discs,RAM, Programs (except for the usual glitches w/ a reinstall)
    Network ect. 3 days and have yet to BSOD or lock for any reason after vga reboot.
    Field Value
    BIOS Properties
    BIOS Type Award
    Award BIOS Type Phoenix - AwardBIOS v6.00PG
    Award BIOS Message VNF3-250 09/16/2005
    System BIOS Date 09/16/05
    Video BIOS Date 03/20/02

    BIOS Manufacturer
    Company Name Phoenix Technologies Ltd.
    Tried an update to the BIOS but it failed..... :( Had to jumper back to orig CMOS.... Will check on why..(Had the current BIOS apparently according to Chaintech, which is why it failed????)
    Addendum: Checked properties in Control panel: System:Control Panel:Advanced: settings....Was set for full dump. Switched to minidump and then tried a full boot. BSOD'ed. Rebooted in VGA mode and looked at the minidump folder. No new entries. did a full search for files .dmp in case they were somewhere else for some unknown reason. Foud a few but w/ creation dates way in the past.
    ADDENDUM2: Reset pagefile to see if that was causing minidump to not be written. Well that didn't do it either. Same BSOD, same lack of a dump :(
  2. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65


    Alright. Seems to be a memory issue. Can't boot to XP w/ 1 stick RAM (either one). Even VGA mode fails. Corsair lists RAM as compatable. Did a RAM test and it found nothing. Why would it boot (VGA boot) w/ 2 sticks and not one? Wrote to Chaintech to see if they have any solutions. Other than that I'm open to suggestions :)
  3. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    Your latest minidump is at April 2005. I don't think you want to fix the problem that occurred 7 months ago. Attach the minidumps which are taken within this month.
  4. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    no dumps

    There are none, sorry. They won't generate..... :( Checked that out and tried redoing pagefile per MS but that didn't do it either. Actually I think I hit on something in the registry. hkey_local_machine..Harware .. Device map ... video
    points to a key that describes a S3 video card. Can't find a NVidia in the whole bunch of keys associated w/ hkey_Local Machine.. System.. Current control set... except for an old Elsa Gladiac :(. Looks to be a buggy key that Xp won't release to re-configure. Need registry help at this point I think.
    WRONG; Key points to nv4 drivers.. Must have mis-read it.
    BTW: Thats the full collection of dumps on my system (3 yrs worth)
  5. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65


    wow !!! Must be a good one :)
  6. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    Last resort

    Ran mem test overnight. No problems in 20x through. Ordered a new vid card. We'll see. Not really counting on it but who knows. Did try re-installing vid drivers AGAIN yesturday. Same error. still bugs me that everthing still works normally. BTW: Don't see a video BIOS screen on boot or reboot.
  7. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    The crash may be caused by faulty ram or device driver error. The system event log and the minidump has the most useful diagnostic information.
    When Windows crashes with blue screen, it writes a system event 1001 or 1003 and a minidump to the folder \windows\minidump
    Check system event 1001 and 1003 and it has the content of the blue screen.

    Event ID: 1001
    Source: Save Dump
    The computer has rebooted from a bugcheck.The bugcheck was : 0xc000000a (0xe1270188, 0x00000002, 0x00000000, 0x804032100).
    Microsoft Windows..... A dump was saved in: .......

    Event Source: System Error
    Event Category: (102)
    Event ID: 1003
    Error code 1000007f, parameter1 0000000d, parameter2 00000000, parameter3 00000000, parameter4 00000000

    Control Panel -> Adminstrative Tools -> Event Viewer -> System -> Event 1001/1003. Copy the content and paste it back here
  8. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    No new minidumps and event viewer...

    shows very little except for when I boot into safe mode. Crash appears to be occurring even prior to Windows loading/writing/scanning anything AFAICT.
    A few incidental SCM red errors and the fact that I shut the parrallel and com ports off in BIOS for a try. Anything in particular to look for???? Rest ar all info
  9. cpc2004

    cpc2004 TS Evangelist Posts: 1,994

  10. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    Short explaination

    Uncheck "automatically restart". So when I reboot normally (Normal start up Load all device drivers and services) computer goes through BIOS boot ect. Then hits Windows boot and BSOD w/ that error. No "description" after it but I can think of 1 or 2 like YOU'VE_JUST_BEEN__@#$@%$#_ROYALLY :)
    Computer boots just fine in regular mode as long as /BASEVIDEO is checked in boot.ini in msconfig. Only 8 bit color at some low resolution though. I just go in a boost both and refresh rate to 85hz. Thing works fine and looks good though I'm sure the "good" video features are off. Think I'll try a DVD and see what happens.
    Been meaning of tweaking that setting on /basevideo a bit. Think I found it in the "hive" (registry) or whatever. Safe mode boots in a much higher resolution then the /BASEVIDEO normal boot mode but of course you lose almost everything else. Still think it's a graphics card incompatability. My reseach has led me to believe that Chaintech is not the greatest BIOS writers out there. IF this is the case it would be quite strange that a Quadro4 would not work with it BUT on digging into the cards "history" it looks to be an IBM pull (bought it used on ebay last year). And IBM may have a "tweak" in the video BIOS that is causing this. I'm just shooting in the dark here.
    Card does work fine on other MB's. Big catch to this is I did try a PCI s3 card (same failure) and I had an older QuadroII that did the same thing BUT I really was not that careful w/ the driver uninstalls. Still.... could just be a bad mother board. When I get the new video card that wil be a sign. Hate wasting all this time though.
    But for now I just have to set it at
    1280X1024 32bit @ 85hz
    after rebooting.
    Sorry not as short of an answer as planned.
  11. blaacksheep

    blaacksheep TS Rookie Posts: 70

    ok, I have to ask.... Did you go to the vid card's website and get/install the latest driver?

  12. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65


    Yes. BTW this is the response from MS so far
    I apologize for the inconvenience you have experienced. I understand that Service Pack 2 is installed on a computer with an AMD 64 bit CPU. As far as I know, this version of Service Pack 2 is only designed for a 32 bit Operating System with a 32 bit CPU. There are untested areas and potential issues if this Service Pack 2 is installed on a 64 bit CPU. Currently, our development team is dedicated to designing a new Service Pack 2 version for a 64 bit CPU. While we cannot guarantee within what time frame this version will come out, we would like to ensure you that we will make every effort to see that it is finished as quickly as possible.

    In order to ensure the best performance for your computer, I believe it is best to temporarily remove Service Pack 2. If there is any update on this issue, I will let you know...................... unquote.
  13. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    boot.ini w/ /sos switch only mod

    With nothing to lose I tried a few of the other boot.ini switches. Guess what? By using only the SOS switch (no /basevideo) I get a "normal boot". albeit a bit slow sice XP has to go through whatever it does w/ that switch. Maybe a video timing issue at boot ? At least now I get full vid driver loading. And I don't have to readjust my refresh rate/ resolution.
    Did I mention I was confused :)
  14. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    New video card isn't the answer.

    but /sos switch still works fine. For now I'm just stuck w/ using it. Will try to dig up the splash screen and "countdown" (white bars on bottom) program/file
    to see if they are corrupt or "lost". Anyone know where they are?
  15. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    Anyone good w/ ntoskrnl.exe?

    My only logical (of course this rarely applies to computers :)) conclusion is a splash screen/ntoskrnl.exe incompatability w/ my motherboard. Another longshot. Looks like a reformat/reinstall is looming. This is really annoying since it's like throwing an elephant at a gnat.
    Added: Forgot to mention I switched video cards yesterday w/ a new 8x AGP card but of course all the problems remain the same :(
  16. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    Day 15 (+/-) and no answers

    Tried a bunch of "things" and actually thought it might be my mouse (in my attempt to make things simple for the repair install I moved the mouse from USB to PS2.Anyways thanks all. This is beyond me (except for reformat/reinstall) Even tried SFC /scannow but it gave me the "need CD 23 times. Tried the "workaround" (copy entire i386 file to root, change path in registry) but no go.
  17. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    Fixed Problem:

    Well it took long enough but I fixed the boot problem today. SOOOOOOO simple.
    I extracted NTLDR from my old XP CD (prior to SP1 even) and substituted it for the current NTLDR that the SP2 CD installed. Worked like a charm..... Have rebooted twice completely without the BSOD. Odd huh............
    Oh MS (Magoo) you've done it again.................
  18. cpc2004

    cpc2004 TS Evangelist Posts: 1,994


    Great! Your problem is resolved.
  19. jeffkrol

    jeffkrol TS Rookie Topic Starter Posts: 65

    Hope it helps others

    though the error seems uncommon. May save people from a format/reinstall which in this case may not have even helped.
  20. Solmills

    Solmills TS Rookie

    Similar problem, upgraded from Pentium 4, to AMD x64 4200 with BSOD

    I upgraded my computer from Intel Pentium 4 to an AMD x64 4200 and could not get it to use my existing hard drive. I could re-install a new hard drive and it worked fine, but I wanted to aviod reloading all the software and settings.. I tried repairing windows, and still got the BSOD Stop: 0x0000007E (0xC0000005, 0xF7482750, 0xF789E450, 0xF789E150)

    After reading all of these hits, I found a tip on a microsoft site to delete all drivers in C:\windows\system32\drivers after 2002.. I found through the process of elimination that only the driver : intelppm.sys to be the cause of my BSOD, not the older NTLDR file.

    Hope this helps someone else.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...