Printer/scanner combo device prints but doesn't scan!

By CamaroZ28c ยท 10 replies
Mar 11, 2005
  1. Hi all, I have a Dell A920 All-in-one printer/scanner device. It is installed correctly and I also reinstalled the drivers from both the disc I have and the downloaded drivers from Dell. It prints perfectly fine but it does not scan, whether I press the scan button on it, or use software to tell it to scan. The printer shows up in the system tray but it has a red X over it. There are no X's or ?'s in the device driver screen under imaging devices though. Any ideas? I tried getting help through Dell's India Support, but they just told me to read the user's manual to "learn how to scan" after an hour of answering their stupid questions. They had no clue what they were doing :mad:

    thanks for any help!
  2. dopefisher

    dopefisher TS Rookie Posts: 444

    you might get help with this link also;

    it is dell's forums, although you said you werent too happy with their service. however, there are regular users in there just like u and me,. so maybe itll help.
  3. maddog8153

    maddog8153 TS Rookie

    similar problem

    may or may not help I recently purchased HP1315 all in one installed (took forever) called HP no help took and exchanged uninstalled and reinstalled same thing not until ran windows cleanup utility and removed all traces of printer could I do any good. now all is work currently so cannot recall where link is to download go to microsoft download center and search
  4. CamaroZ28c

    CamaroZ28c TS Rookie Topic Starter

    Thanks for the advice. Ive posted on Dell's site and haven't gotten a single response. It seems like a lot of people have had the same problem though, so I am going to see if any of them ever got it resolved.
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Join the club of proud Dell-rebadged Lexmark Expensive-Ink-Guzzling Super-Doorstoppers.

    FYI: The Chevrolet brand is now available in Ireland, BUT: they are all (former) Daewoo!
  6. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    Z28 when you go to the control panel and double click "Sanners and Cameras" does the scanner show up there? If it doesn't click on add imaging device and see if you can install it from there. It probably can't find the drivers.
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  8. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    Real. Are those Lexmarks that bad?. I just got a Epson Photo925. Goes through 1/2 a color cartridge cleaning the nozzels. I'm tempted to spend $100 to have my old $50 hp fixed. It was sure better than this $200+ POS. LOL
  9. CamaroZ28c

    CamaroZ28c TS Rookie Topic Starter

    It shows up in there and when I "test" it in the properties, it says that it all went fine

    hmm where do I get these STI drivers or check for them? I ran a search on the computer for them and came up empty. Oh and I never upgraded from a lower Windows OS, its been XP all along, only thing I can think of is the SP2 upgrade way back...

    Thanks again for your help guys!
  10. luvhuffer

    luvhuffer TechSpot Paladin Posts: 443

    go to administrative tools in Control panel, and open Services. Double Click on Windows Image Acquisition (WIA) and make sure it is enabled and running (automatic startup type is normal in XP SP1 or manual in XP SP2). stimon can be found in your system32 folder. I'm not sure about the other.
  11. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    one of my clients use one of those Dell A940 doorstoppers. As I said they are rebadged Lexmark crap. Dell has even gone so far as to modify the caps on top of the black cartridges, so that normal (read cheaper) Lexmark cartridges will not fit in them.
    But you can screw Dell, and break/cut off the small plastic pin that comes out from the black cartridge lever. After you have done that, the Lexmark (or other cheapo remanufactured/refilled) cartridges work.

    check in the c:\winnt\inf directory for sti.inf and with that you can install your Still Image stuff (at least in W2K).
    The A940-stuff above also applies to your A920.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...