Spread the love! TechSpot Tech Gift Shortlist 2017

Problem connecting via wireless link to router

By Nikki Jones ยท 14 replies
Aug 8, 2007
  1. Hi there

    I have a small wireless broadband network at home. Up until a few weeks ago it was all good. I started experiencing problems with the line being dropped for hours at a time. Couldn't connect to internet at all but all pcs in house still seeing wireless router. Broadband service provider came to check and when he left, the router had lost all it's settings. I resetup the router with the same network name and WPA key etc. Now I cannot establish a wireless link from my laptop to the router. I can plug in the usb cable directly and connect to the internet. All other pcs in the house are fine.

    What I see is that momentarily the wireless link is established with excellent connectivity but then it drops saying it's trying to acquire a network address and provides me with a list of wireless networks that I could connect to, mine being in the list. On my laptop, I have re-entered the wireless network name and retyped the WPA key to authenticate but am still not able to connect.

    Any suggestions would be very welcome.

    Thanks ahead,
  2. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    This sounds as if your laptop is not getting an IP address from the router. This is probably due to security settings on the router, so 1st I would disable all wireless security while this is fixed.
    Access the router with a patch cable to get at the settings.
    If you can then sign on - run cmd and then ipconfig to make sure you have been given an IP address by the router for both the wireless and cable connection.
    Once you have a connection, reset the security - one thing to check might be access permissions by MAC number.
    Hope this helps
  3. Grummangy

    Grummangy TS Rookie


    Have a quick check to see if your N/W DHCP is set to get its addy from the router, the tech may have altered the settings in the router and that PC is the only one with manual settings. U'll find it under the advanced settings for IP in control panel/network connections. Ensure that all settings are automatically assigned.
  4. Nikki Jones

    Nikki Jones TS Rookie Topic Starter

    Thanks AlbertLionheart & Grummangy

    Router is assigning IP addresses - one has been assigned for the USB connection to the router and one for the wireless adapter and they are within the allocated range. Permissions are per WPA key with privacy on, only one SSID allowed and not per MAC address.

    Reset security on router but no luck. Also checked nic in laptop - IP settings are all automatic.

    Any other suggestions? Thanks so far, much appreciated.

  5. Grummangy

    Grummangy TS Rookie

    Another suggestion

    There is another suggestion Nikki. What AV/Firewall proggy are you running, and are the permissions set in the firewall allowing the appropriate connections. Seen a lot of this in the past week or three. Have you tried to ping each machine from the other ? Simply open up a command prompt and type IPCONFIG on one machine, write down the IP address from that machine, go to the other and open up a command prompt and PING the other computer. Do that for both, it will give u an indication as to what is going on. Let me know the results.
  6. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    How are ypu getting at the router settings - with a patch cable?
  7. Grummangy

    Grummangy TS Rookie

    Yes ALH Nikki is as stated in an earlier post. Nikki, go into the advanced settings for your wireless adaptor (DRIVERS) and ensure that the protocols assigned match those the router is broadcasting. This is a little different than IP, you need to find what transmission signals (A G N or a combination are used, then match that to the router) Email me at graeme@northernstarcom.com if you need step by step as this is a little off the beaten track, but something I have seen before.
  8. Nikki Jones

    Nikki Jones TS Rookie Topic Starter

    Hi - in South Africa, am going to pick up again with your suggestions Grummangy in the morning. Thanks so much for the assistance so far. Will get back to you with the info.
  9. Nikki Jones

    Nikki Jones TS Rookie Topic Starter

    Ok, am using Bitdefender as AV and NAT firewall - none of the settings have changed. Can ping all machines on network and when wireless comes up on laptop for brief moment, can ping too.

    Checked protocol on nic and these match those on the router - are the same as the other pcs, all have mixed mode selected.

    Yes, am getting to the router with a USB patch cable.

    Would welcome any suggestions further. When I initially set up this network, I remember having a similar problem with one of the other machines, not the laptop. Until I matched the WPA key (uppercase and lowercase) correctly, we could not get a permanent connection.

    Thanks so far ...
  10. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Beginning to wonder if perhaps the laptop wireless NIC is the problem.
    If you turn off all the firewalls (NAT & Windows?)?
    As Graeme suggested, the protocols could be a problem but then it worked before the broadband engineer "fixed" it. Default settings all round?
    Ping commands can get through firewalls so this is not always a reliable check.
    If the wireless NIC is a PCMCIA card or USB, could you try it on another laptop?
  11. Nikki Jones

    Nikki Jones TS Rookie Topic Starter

    Wireless nic is onboard, so unable to try it elsewhere. All settings are default. No difference if Windows and NAT firewall switched off, pings still ok but same intermittent conncectivity.

    What do you think about taking one of the USB wireless dongles from one of the other pcs, disabling the onboard wireless nic on the laptop and going from there?
  12. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,026

    Good idea - this will at least sort out if it is the wireless nic or a software issue. Do let us know!
  13. Nikki Jones

    Nikki Jones TS Rookie Topic Starter

    Well, this is all too wierd. Switched off laptop to move it and plug in dongle etc. Switched it back on again and was just busy disabling on board nic when I noticed that the wireless was connected and staying connected with no error message. It has now been up for the past 30 minutes! And it's definitely going through the onboard nic, not the dongle - that is now unplugged. I cannot begin to think what went on there, no changes made, excepting that I unplugged the patch cable - just a move from right next to the router to another room???!!

    So, all looks good for now. I'm none the wiser excepting for some of the tips you guys gave me, which I'll remember for next time. Thank you AlbertLionheart and Grummangy for jumping in so quickly. This site is amazing and I'm always so stunned at the help given.

    Thanks & cheers,
  14. Janet D

    Janet D TS Rookie

    Nikki, are you still up & running? I switched from DSL to Verizon's FIOS this weekend and my personal Laptop keeps losing the internet connection. I've called their techsupport twice and they've tweaked here and there while I was connected via ethernet cable. Once we unplugged it looked like I still had my internet but when I walk away from the router it drops. It shows the wireless connection but it wont let me in!

    Funny thing is that my work laptop connects with no problem!

    If anyone has any suggestions (in end user terms!!) I'd welcome them!!
  15. Nikki Jones

    Nikki Jones TS Rookie Topic Starter

    Hi Janet and others

    An update. My laptop was up and running for a full hour and then dropped it's connection and went back to it's old tricks. Due to work and study issues, had no time over last few days to mess around anymore, so just worked through patch cable, irritating ...! Then, two days ago, the other pcs in the house started losing their connections as the laptop had done.

    Unplugged the router yesterday(5 months old), packed it into original box, took it and cash slip to supplier and requested a swop which they gladly did for me. Plugged in new router (Mega 200 VWR, which is a Billions clone for the SA telecoms market I believe) and ran a quick setup and the wireless network is now up and running, all pcs connected, no problems at all.

    So, yes, my problem is solved, the router had gone faulty. We have been up via wireless for more than 24 hours, not one link being dropped.

    Janet, I dunno if this is helpful, but I guess I needed to close the story.

    Good luck
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...