Problem enabling SLI in Windows

By ChrisN ยท 20 replies
Jun 20, 2005
  1. Hi everyone,

    I've been working on this for a few days. Here are the basic symptoms:
    When I install the nVidia gforce drivers and reboot the system the driver prompts me saying that the system is SLI capable and do I want to enable it. Naturally, I choose yes. The driver dialog box is brought up and I can check the SLI checkbox. Doing so brings up a reboot dialog so I let it reboot my system. Once the system comes back up I am in standard VGA mode with no nVidia drivers loaded. I know this because the task bar try icon isn't there and going into advanced display settings shows that there is no nVidia menu.

    I've done quite a few things to try to fix this. Initially, I was forced to update the bios because the SLI tab only had the EZ Connector warning on it. Rebooting forced me to remove one card because the new bios was defaulted to forced single board mode. After setting SLI to Auto and SLI Aperture to Auto, I reinstalled the second card, flipped the selector card, put the connector on the two cards and powered up the system.

    I installed the nVidia drivers that came with the video card and then windows blue screened. I lost my USB keyboard and was forced to connect a normal keyboard to the motherboard. I then downloaded the latest nVidia drivers from Asus' site and installed those in safe mode. This allowed windows to boot and gave me back my USB keyboard. Then I started having the problem I'm having now. Enabling SLI in windows and rebooting causes nVidia drivers to disappear.

    I've uninstalled and reinstalled in every possible configuration. Using both nVidia drivers from nVidia's website and Asus' website. I've installed latest and greatest nForce4 chipset drivers. I've pulled out the video cards and tested both in single board mode.

    I was on the phone with Asus' level2 support guy for about an hour. He was completely stumped and left me with the standard RMA the motherboard line. I really would rather not do that since I have a feeling the motherboard doesn't have a problem.

    And so I turn to the gurus here in the hope that one amongst you has had a similar issue and knows how to fix it. Listed below are my system components.

    Power Supply
    Mother Board
    Hard Drive
    Video Cards (x2)
  2. Finchy

    Finchy TS Rookie Posts: 353

    There are three things you must make sure you do when you get SLI.
    1: You must buy precisely the same card, down to make and model number.
    2:The SLI controller on the motherboard must be set to SLI mode.
    3: The bracket that comes with the motherboard must must be attached to the the tops of the cards.

    If you've done all those i'm stumped, unless there an update for Windows to enable it properly.
  3. ChrisN

    ChrisN TS Rookie Topic Starter

    Thanks for your reply! Yes, I've done all of that. The video cards are identical as far as a I can tell. When I ordered them from newegg, I simply put 2 in the quantity. I even ordered Asus brand N6800 Ultras thinking that I would avoid any compatibility issues that way.

    The system detects SLI, but then when I try to enable it in Windows the system goes back to standard VGA after the restart.
  4. Merc14

    Merc14 TS Rookie Posts: 171

    Are you sure that you are not in SLI? If you are getting all those indications then you should be in SLI. Right click on the desktop and see if there is "Nvidia Display" in the box that pops up (the Nvidia utility doesn't show up in the toolbar sometimes, don't ask me why and I never really cared as I always use the right click on desktop). Select it and you should be in the Nvidia utility. On the SLI enabled page select "show load balancing" and run a Direct X game to see if you are getting SLI. Also Chris, make sure you are running BIOS 1008, 1011 has given me and others problems, and that you enable "dual card" in SLI.

    If the above didn't help then it is time for an overhaul. Copy the Nvidia drivers to a CD then, assuming you are already running 1008 and there was no change, download Drivercleaner Pro (free utility, google it) and install it. Next, using windows "add/remove software", remove all your Nvidia drivers except the SATA and RAID drivers. Read driver cleaners instructions and run it to clean out all the detritus leftover from previous installs. Reboot and load the NForce drivers except for the NVfirewall. Reboot and load the latest Nview driver (71.89 I believe) and reboot. After the reboot the SLI dialog should pop up. Proceed as above.

    BTW- That is one helluva system! Should be a screamer when you get it squared away.
  5. ChrisN

    ChrisN TS Rookie Topic Starter

    Thanks for your reply, Merc. Yes, I'm sure I'm not in SLI mode at that point because the display drivers do not load. In the advanced settings in the display there is no nVidia menu, let alone an SLI menu. The menu exists prior to clicking the "Enable SLI" check box.

    I did upgrade the bios to 1011 at first because no SLI options existed in the bios with the version shipped on the mobo. I will try downgrading the bios to see what happens.

    I just installed the latest nVidia drivers and they behaved the same way.

    If this last thing fails I will assume I have a hardware problem and RMA the mobo. The tech support guy at Asus was completely stumped and that's what he suggested.

    I ran the system in single card mode for a day playing World of Warcraft with friends, and even with only one video card it is extremely quick. I can't wait to see how it performs with dual video cards working. :D
  6. Merc14

    Merc14 TS Rookie Posts: 171

    That sucks but at least try the 1008 BIOS. 1011 gave me loads of trouble. Hope it works but if not drop me a PM and let me know if the new board fixes your problems. I'm really interested in what a system like that can do.
  7. ChrisN

    ChrisN TS Rookie Topic Starter

    Merc, you're my hero! Downgrading to the 1008 bios solved the problem. I almsot cried when that little dialog popped up informing me that SLI was enabled. If you ever make it to San Diego, the beer is on me!
  8. Merc14

    Merc14 TS Rookie Posts: 171

    That's great Chris! I'm glad I could help. I can only imagine the relief you felt at getting that little pop-up message. LOL.

    Watch the VCore voltage for a few hours too make sure it is stabilized. 1011 stuck mine at 1.5 and when Asus Probe tried to raise it the system crashed. Switched, in Asus Probe, from Auto to Standard and back to Auto and that unlocked the VCore and all was well. The problem was a leftover from 1011 (my VCore in Asus probe usually hovers around 1.6-1.65 and is very stable there).

    Have fun with that system and let us know what it can do.
  9. JeffT88

    JeffT88 TS Rookie

    Hi Merc,
    I hope that you could help shed some light on the problems that I'm encountering with my new Gigabyte GA-8N-SLI Royal. My config as follows:
    Gigabyte GA-8N-SLI Royal mobo with DPS installed
    (a) 4 x Geil DDR2-533 512MB PC2-4300 CL 4-4-4-12 (comes in 2x512mb kit)-I'd ensured that each pair sits in correct slots
    (b) Pentium 4 3.4GHz 800MHz FSB, 1MB L2 cache with Gigabyte G-Power BL Cooler
    (c) XFX GeForce 6600GT w/256MB DDR3 Dual DVI card (ver B.0) - claimed to be manufacturer clocked to 1000MHz
    (d) CoolerMaster Centurion Casing with Antec 480W True Power 2.0 PSU
    I'm running the mobo bios on Fail-safe settings with the latest nVidia drvs for both the mobo & graphics card (downloaded fm nVidia website.)
    Whole PC & Samsung 930B LCD monitor connected to a Belkin SurgeMaster Gold series (F9G726SH3-GRY).

    On 1-2 occassions, I could get the rig up & running with no probs for 2-4 hrs but provided I remove the 2nd pair of RAM. more often than not just like last nite, it reaches the winxp pro logo with the running bar at the bottom & just stays there for the next 5-10 mins. after rebooting, its still the same.

    Any help/advice would be much appreciate as the local gigabyte support only say that the mobo is quite high end that requires tweaking but offers no advice there.
  10. Merc14

    Merc14 TS Rookie Posts: 171

    Have you updated the mobo's BIOS? Also, what is "DPS installed"

    PS: That is the lousiest advice I've ever heard. LMAO. Gigabyte should be ashamed of themselves.
  11. JeffT88

    JeffT88 TS Rookie

    yup, done that too last night but the system still didn't want to boot up- suspect that it could be a corrupted windows file or driver. anyway, did a reformat of the HDD & partitioned the 200GB maxtor sata drive into 2 drives: <C>=30GB & the rest goes into <D> drive. will be reinstalling the OS & the nVidia drivers, just need to be careful of the default gigabyte drivers to be installed from the disk that came with the mobo-I suspect that the nVidia System drivers could be one of the cause. spoke to some pc dealers & they believe either gigabyte should be coming out with a bios upgrade or nVidia should come out with a patch for SLI mobos, since they themselves have also encounter similar problems with the SLI boards that they are fixing. seems that problems starts when all 4 ram slots are populated. BTW DPS = Dual power Supply: it's a gigabyte technology where the add-in board provides a 8 phase psu ( Royal.htm)
  12. Merc14

    Merc14 TS Rookie Posts: 171

    I would break it down to 1 stick of RAM, 1 video card and the CPU, reset the CMOS/BIOS and get her to POST. Add a second stick of RAM and see if it will POST. If it does add the other two sticks and see what happens. If it dies then just run w/ 1GB until a new BIOS comes out.

    With a stable POST, start adding things like one hard drive, the floppy, CDROM etc. and if all is well then load up windows. Just take it slow and add things until the system fals and then you'll know where your problem lies.
  13. JeffT88

    JeffT88 TS Rookie

    Hi Merc,
    followed yr advice. Went w/2 sticks of RAM at 1 go,only had 1 vga card, CPU, flash the BIOS-POST was OK but stil didn't boot. so tried the 2nd time & went to the BIOS & adjusted some settings-somehow,inside the BIOS,when I hit CTRL-F1, I get access into some more advance settings.disabled the SLI Broadcast Aperture & the CPU Spread Spectrum options. changed the PCIE Spread Spectrum & SATA Spread Spectrum options to Down Spread & Change the LDT Spread Spectrum option to Centre Spread (got these info from a nVidia forum), rebooted & it works but only with 1GB RAM, didn't work with 2GB (4 x 512MB)-I think either Gigabyte or nVidia screwed up somewhere.

    Just to be safe,I reformatted the entire HDD,split it into <C> 40GB & <D> 160GB & reloaded my win xp pro. 1st try-loaded all drivers from the gigabyte cd-wrong choice. 2nd try-reformat & reloaded all drivers except for a package that says nVidia SYstem Drivers (whatever that means). It works. found out from some forum postings that the nVidia ActiveArmor hardware firewall that is built into the mobo is quite screwy,so maybe its part of the 'Systems Driver package'. Anyway, ended up using Zone Alarm & Norton Anti Virus.

    so far Pc running A-OK for 2 days now, only 2 issues this time:
    1) System sure generate lots of eat-so had to remove the side panel & put a small table fan to blow directly into the casing - maybe that helps abit in the stability.
    2) In my Control Panel - System Properties - Hardware settings, I do notice a item with a question mark: Other Devices - Other PCI Devices, don't know what item this is since the PC is running ok, could be something that is part of 'nVidia System Drivers' package that I didn't load, anyway, Pc running ok more important that tracking down this item.

    Thanks Merc. Really appreciate the assistance that you've rendered.
    Now, just hoping that gigabyte could come out with a fix for using all 4 slots of the RAM.
  14. Merc14

    Merc14 TS Rookie Posts: 171

    No problem Jeff. I noticed you didn't saythat you had reste the CMOS/BIOS by removing the battery and moving the jumpers. Did you do that or not?
  15. JeffT88

    JeffT88 TS Rookie

    nope, in my haste to get the rig woking & finally getiing it to work, I don't think I reset the CMOS or the BIOS but I did re-install the bios from the BIOS file that I've downloaded from Gigabyte website. Will it make any difference - I mean resetting the CMOS? I read from another nVidia website that some SLI mobos are not able to work with 1T timings for 4 sticks of DDR2 RAM even though they comes in pairs. Recommendation to use only 1 pair of RAM & running it @ 2T timings; check the max voltage that the RAM can handle & increase it slightly to maybe 0.1 V for a start & check on the stability.
  16. Merc14

    Merc14 TS Rookie Posts: 171

    It never hurts to reset the CMOS/BIOS after major changes to hardware and drivers etc. Just have to adjust your BIOS settings afterward. As far as the DDR2 you may be right on the 2T timings. I ahven't used it and from what I understand there are a lot of latency issues hence AMD's decision to stay away from it for now (next gen CPU's will use it though). I'd play with the setings and try to use the full 2GB's if I were in your shoes. hell, if you have to run at 2T then at least have all the RAM in there.
  17. Secondgunman

    Secondgunman TS Rookie Posts: 91

    I didnot think that SLI loaded...

    I didn't think that SLI loaded in widows, till a game or app requiring massive GPU power was loaded. That is how mine works when in a game the system kicks into SLI when in windows you only run off one card the way to tell is to click the "show load bars" or what ever they are called you will know you got the right setting when green lines apear on your screen when playing a game.
  18. JeffT88

    JeffT88 TS Rookie

    Hi Merc14,
    I've managed to get my rig working with the full 2GB RAM however not in full dual channel mode.since Gigabyte Ssingapore wasn't able to assist,I wrote to the Taiwan HQ & after some emails to & fro, they sent me a test document on ALL DDR2 RAM that were tested & worked with this particular board (they SHOULD HAVE posted this on their website). I went back to my dealer & he replaced it with 2 x 1GB DDR2 Kingston RAM (but didn't come in kit form). the ram worked well for the last 1 week & even for a full 5 hrs that I was running Battlefield 2 so quite happy with it. Probably need to save up to get a recommended & tested DDR2 ram down the road. Thanks

  19. Merc14

    Merc14 TS Rookie Posts: 171

    What timings are you using?
  20. JeffT88

    JeffT88 TS Rookie

    I've reverted to the Gigabyte default timings just to play safe & so far its working ok.
  21. Merc14

    Merc14 TS Rookie Posts: 171

    Hey Jeff-
    Forgot about this thread but glad everything is working. Just so you know, the Gigabyte board has no RAM default settings, it simply goes to the RAM chip itself and reads what the RAM's manufacturer suggests is a safe setting, for the majority of mobos, off what is called the "SPD chip" (small ROM chip on the RAM with all the sticks info). It then sets itself automatically from that SPD chip download. The SPD is usually very conservative and I would bet you could start tweaking those timings down. Most important is 1T or 2T (1T much better) and and the operating frequency. The rest of the settings are not as apparent to the user.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...