Spread the love! TechSpot Tech Gift Shortlist 2017

Problem loading Medieval 2 Total War

By cranwo · 35 replies
Nov 14, 2006
  1. Hello if there is someone that can help I would be grateful, my problem is I bought Medieval 2 recently, my PC has specs more than capable of running this game but that is not my problem. On trying to load the game it is not seen on the drive, so did all the good things like restarted the PC tried to install and nothing the disc is turning but is not being seen by the drive. On removing hte disc my desktop froze. So I sent the game back, asking for a replacement thinking this was a bad Disc. I then loaded Rome Total War WITH NO PROBLEMS AT ALL. recieved the replacement Game but still have the same problem as before.
    ANY IDEAS. or should I just forget it, return the game and ask for a refund as all my other games load and run with no problems at all.

    Looking forward in reading any suggestions you may have

  2. berr0um

    berr0um TS Rookie

    I have the same problem but only with disk 2, does anyone know a solution?
  3. TimeParadoX

    TimeParadoX TS Rookie Posts: 2,273

    Hmm I think this would work, When you put the disk inside the DVD drive go to My Computer and Double Click the DVD drive so a folder will pop up. When you are there go to Control Panel > Add / Remove Programs > Add Programs then put the setup.exe into the browse thing ( after finding the folder to the game )

    Hope I helped :)
  4. berr0um

    berr0um TS Rookie

    Thanks i tried that, but my problem is DISK 1 works and starts installing and then when i have to put in DISK 2 nothing happens. When i got to My computer then the drive it freezes.
  5. cranwo

    cranwo TS Rookie Topic Starter Posts: 18

    Problem with Medieval 2

    That is what happens to me my PC Freezes but with Disc 1, I returned the Game thinking it miht be a bad disc, and I recieved a replacement but exactly the same thing has happened. my PC still freezes and I have tried everything I know but to no avail.
  6. berr0um

    berr0um TS Rookie

    cranwo, you have to make sure you've got a DVD drive to read DVD 's and the drive has to be 8x speed or more but ive got both of them and disk 1 works with mine its disk 2 that dodgy.
  7. cranwo

    cranwo TS Rookie Topic Starter Posts: 18

    Many Thanks for that I do have a DVD RW Drive which is very fast but still no joy
    mind boggling or what, as every other game I have purchased including Alexander works a treat
  8. berr0um

    berr0um TS Rookie

    ive had no luck with my problem im just sending off for a new one, but cranwo you could try burning it into an ISO file and trying it from there?

    install it on a another PC maybe and transfer the files?
  9. RobMeade

    RobMeade TS Rookie

    I experienced the same problems with this game also - here's my story..

    1. Ordered the game from Play.Com - it arrived swiftly, to the tune of £29.99

    2. Tried to install the game on my "gaming" PC - nothing happened when putting disc one, or disc two into my DVD-Rom drive. I tried via "My Computer" and again nothing, the label of the disc didn't even appear.

    3. I tried the discs on my PC at work, the game installed fine with none of the above issues.

    4. I tried the discs on my laptop, the first disc was recognised, auto-played and starting installing, when the prompt for the second disc appeared and disc two was placed in the drive, nothing happened, it just timed out and gave the "Not responding" message, I was subsequently unable to "End Task" this program, which seems to appear as "_ISnn.exe" where nn is a random number generated by the installer. It wasn't using any system resources.

    5. I then tried exploring disc two, I could see it in "My Computer", I created a folder on my desktop called "MED2" and copied all of the files from disc two into the folder - this worked. I then rebooted the laptop, placed disc one back in and choose "Install", this progressed exceptionally quickly because it hadn't removed any of the files from the first attempt (they actually go into the install directory rather than a "Temp" directory, although the "Installer" files do go into a "Temp" directory. At the prompt for disc two I clicked on "Browse" and selected the folder "MED2" on my desktop and clicked ok. The installation continued and I am able to play the game.

    This is a *very* frustrating issue, I think in my case at least I have proven that my discs are "ok", as I've been able to install it at work problem free (Philips dvd-writer), and able to explore it at home on the laptop (Sony VAIO AR21S). What is frustrating is that I cant really return this to Play.Com for it to be exchanged, they test all returned software, so apart from the period of time it'll take, they might have a setup which it works on problem free (like mine at work), alternatively, they might not, in which case they'd send out another copy, which again, might have exactly the same problems.

    It seems as if the installer might well have problems - being that it just crashes, perhaps we should all investigate in this direction instead of faulty discs?

    Anyway, I post this only to share in your pain and also offer a solution which I dont think had been posted yet, I hope it helps some of you play this incredibly "pretty" game...

    As we are all aware the game only mentions that the DVD-Rom drive must have a 1200Kb sustainable transfer rate, being that most drives these days report their transfer speeds in MB I dont believe this (in my case) to be the issue..

    If anyone does get to the bottom of this I would be interested to hear back, in addition if I discover anything I'll post back.

    Happy hunting!
  10. Landscaper

    Landscaper TS Rookie

    Medieval 2 Total War

    Looks like only a few of us are having a problem. Both Disk 1 and 2 both will let me load the program on my PC.But when I click on the icon to start it. It will say put the correct disk in but it will not see the disk in the drive. It will just keep on giving the same message over and over each time you click the icon. So I removed it and reinstalled it. That did not work got the same message again. So I removed it again. I then took it back to Best Buy exchanged it got another copy came home reinstalled it. I am know better off now then I was before I still have the same problem !!!!!!! I all so need any help you can give.
  11. RobMeade

    RobMeade TS Rookie

    I haven't tried it myself - as I can obviously run the game at least...but you could try a visit to www.gamecopyworld.com

    Most likely you'd be able to find a "fixed image" of the game, you'll need to download and install something like Daemon Tools which will allow you to "mount" an image...it'll basically think that the big fat ISO image of the game is in a drive, not sure that'll it solve your problem - but it might...

    You'd still need your CD key for online gaming...
  12. lvl3nerd

    lvl3nerd TS Rookie

    okay guys i have the answer to your problems
    this game is a really advanced game that only good DVD-Drive can read
    CD-RW Drives cannot read this disk after reading the posts written by you guys i thought if would be a good idea to go out and buy a DVD Drive i went out and got a LG drive from best buy and the game worked perfectly
    so if its not working im pretty sure its either because you have a CD-RW Drive or a out of date DVD-RW Drive
    and ya this game is sickk
  13. RobMeade

    RobMeade TS Rookie

    I would agree to a degree....

    With my gaming PC, I did exactly that, went out and bought a new DVD Rom drive from PC World to the tune of about £30 - effectively making the cost of the game £65 for me :(

    I took out my Plextor drive which had never experienced any of these problems in the past, and was able to both install and play the game with no problems.

    However, where I'd disagree would be on two points...

    1. I have just received a Sony VAIO laptop (AR21S) - retailing at £1999.99 - I experienced problems with this game on this also - now, in my mind, I should not have to go and buy "another" dvd rom drive (because now I'd most likely want to get an external that I could plug into the laptop) to go with the spanky new laptop.

    2. You really shouldn't have to upgrade cdrom/dvdrom drives for games to play - the only mention of spec for this game with the dvd rom drive was the continously transfer rate of 1200Kb per second - all of my drives can/could achieve this yet I still had the problem.

    I have also had this problem since with Caesar IV and Stronghold 2 (the latter not being a particularly 'new' game).

    Two of these games used "InstallShield" to install, and for me, this is where it goes wrong, ie, the dialogue box asking for disc 2, although on the gaming PC, it wouldn't see either of the discs...

    It seems a very difficult problem to actually track down - I'd much rather have to update some client files for "InstallShield" than replace all of my hardware to play a game! Had it been possible to return the game I probably would have, if enough people were to do this, or not buy it, then maybe what ever they are doing to make these games incompatible with all of our existing hardware they might stop it!
  14. irgy709

    irgy709 TS Rookie

    I'm having the same installation issue, and it's happened a few times before with other games (I don't remember which ones...just being intensely frustrated and reinstalling about 50 times and popping disc-2's in and out a lot...I think Black and White 2 might have been one of the games). it's a really obnoxious problem - I'll try copying all the files to my hard drive and see if that helps.
  15. soccermom4x

    soccermom4x TS Rookie

    Anyone get the following error ...
    can't locate D3X9_30.DLL
  16. JIMMY

    JIMMY TS Rookie

    Installing The Game Is Okay, But When It Loads I Could See The First Page But When It Clicks Over To The Second Page, Nothing Comes Up. The Task Manager Tells Me That The Program Is Not Responding....please Help
  17. missp

    missp TS Rookie

    Hi All,

    I too have the problem where my drive won't even read the disks - not even the label. How can I tell if my drive is compatible or not? I have a
    and it can read everything else I have..

    Can anyone help?

    Kind regards
  18. TongPoJones

    TongPoJones TS Rookie

    Disable DLA

    Had the same problem where Disks 1 and 2 weren't recognized. After several hours of trying, I restarted the system, went to "my computer", right clicked on the DVD drive, clicked on the DLA tab, and disabled DLA. After that put back disk 1 and installed. Maybe this will work for you.
  19. Zap123

    Zap123 TS Rookie

    I had no problems installing the game and i got to play it for 2 days but when i went to open the game again it said it says "please insert the correct CD-ROM, select OK and restart application", but i can still explore the CD. I tried cleaning the disk and everything i even went and got the game exchanged at best buy and the new copy does the same thing when i try to open it plz help i really like this game.
  20. thesutton24

    thesutton24 TS Rookie

    i had the same exact problem as Zap123. please help us both.
  21. mikaelgamer

    mikaelgamer TS Rookie

    i have the same problem as Zap123 and thesutton24.
    Please help all of us
  22. foxyknoxy

    foxyknoxy TS Rookie

    Hi, I bought Medieval 2 a few months ago, and initially it ran fine. However, now whenever I click "Play Medieval 2: Total War" the loading screen comes up for about a second and then I get an error message saying "Medieval 2: Total War encountered an unspecified error and will now exit." Anybody know what might be the problem?
  23. Bambsti

    Bambsti TS Rookie

    My Friend had this very same problem after he bought the game. What we did was create a disk image of the disk and save them on his hard drive. To do this we used a program like magic iso to create the image. Then a program like Daemon tools to mount the images and install. This worked for us I hope that it might help some of you. Also don;t do anything illegal with the images Creative Assembly worked very hard on this game and deserves to be compensated for all their great work.

    p.s. Also if it is asking for the dvd to be in the drive. You can get a cracked exe file. Just google it. Again do not do this unless you actually bought the game.
  24. Low Fat Milk

    Low Fat Milk TS Rookie

    Mouse problem

    all my disks work perfectly atm. Graphics & sound r fine. works exactly the same as my rome did, wich was with nothing wrong EXEPT the mouse.

    Whenever it is still the cursor is completely invisiblem occasionaly flickering into sight. When i move it it flicks fast like its there then it isnt. And there is a block of black surrounding the mouse. This makes it incredibly hard to see if archers r in range or not, get unit info and see wether or not units can move anywere or attack.

    My mouse is a
    M/N M-BZ105A
    P/N 831760-0000
    PID L2705AJ
    Rating 5V___
    - - - 100mA
  25. problems123

    problems123 TS Rookie

    same thing


    I also have the same problem as Zap123 and thesutton24 PLEASE help us. I love that game.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...