Problem networking XP with Win2K

By josbd ยท 21 replies
Nov 26, 2005
  1. We have a desktop running XP Pro and a laptop on Win2K. We have had them running a network quite happily in the past, until a reinstall was necessary on the desktop. Since then, we have been unable to get them to talk to each other.

    The network is wired and runs on an ntl cable modem and a Netgear router.

    We can share the internet connection happily, but XP will not see Win2K, tho Win2K sees XP.

    When trying to view workgroup computers from the pc, I get the message: Workgroup is not accessible. You might not have permission to access etc etc... and: The network path was not found.

    I should explain that we are both logged in as Administrator, with the same password on each system. I have run the network wizard many times, and even installed NETBEUI, just in case this helps.

    Out of interest, we installed XP on the laptop (the owner hates xp...) and we had exactly the same problem.

    XP's *coughs* firewall is disabled. We both run Sygate Pro, and that is not asking permission to send a packet or anything similar.

    Any help would really be appreciated, since I am about to go bald through pulling out my hair!

  2. milky

    milky TS Enthusiast Posts: 85

    Im not sure if this will help you, but try opening Windows Explorer or My Computer
    click <Tools>, <Folder Options>, <View>
    scroll all the way to bottom
    try toggling 'Use simple file sharing'
  3. josbd

    josbd TS Booster Topic Starter Posts: 202

    Thanks for that, but it is already ticked.
  4. milky

    milky TS Enthusiast Posts: 85

    try unticking
  5. IronDuke

    IronDuke TS Rookie Posts: 856

    Have you actually created any shares?
  6. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    A few questions for you..

    • Are you attempting to access the computer by browsing the workgroup with Windows explorer?
    • Does the error message mention anything about, "not enough storage space"?
    There's so many variables with network shares, its hard to troubleshoot without actually being there. You're being denied workgroup access and there's a computer with Windows 2000, which I think might be a good hint as what is going on. So here's my suggestion... You can try it and if it works, great. If not, then we'll keep hitting it.

    First one - Disable your firewall or any applications you think may limit connecting to your computer.

    Second suggestion - Enable NetBIOS
    • Right click My Network Places and choose Properties
    • Right click your network connection and choose Properties again
    • Click on Internet Protocol (TCP/IP) and click Properties once more
    • Click on Advanced and then click WINS
    • I'm assuming you're using DHCP, so you'll want to select "Use NetBIOS setting from the DHCP server."
    • Click "OK" as many times as necessary to get out of all that crap :)

    Check this on both computers, but I'm particularly interested in your checking this on your Windows 2000 computer. Reboot all computers on the network afterwards. Once they all reboot, try to browse your network again.

    Remember: Don't forget to disable your firewall or any applications you think may limit connecting to your computer once you reboot. This applies to all computers you are trying to connect to/from.
  7. josbd

    josbd TS Booster Topic Starter Posts: 202

    A lot to be going on with!

    Yes, plenty of shares.

    Yes, I am trying to access via Explorer. There is no message about not enough storage space.

    OK, shall try all recommendations, and report back tomorrow.

    Thanks so much for everyone's input. I appreciate it.
  8. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    netbios,NetBEUI enabled ??
  9. josbd

    josbd TS Booster Topic Starter Posts: 202

    OK: Yes, NETBIOS and NETBEUI enabled

    Tried everything Rick posted, and the situation is now this:

    Simple file sharing disabled

    I (pc) can now see the pc and the laptop (win2k) for the first time, but am still unable to access the laptop and am getting the same error messages as I was originally. The laptop can see itself, but not the pc.

    So: some progress!

    Any further thoughts, much appreciated, and thanks for all your help so far :D
  10. IronDuke

    IronDuke TS Rookie Posts: 856

    Check in the Sygate traffic log to confirm nothing is being blocked.
  11. toffeapple

    toffeapple TS Rookie Posts: 152

    are you using a domain or just a workgroup?
  12. josbd

    josbd TS Booster Topic Starter Posts: 202

    Nothing being blocked by Sygate.

    And we are using Workgroup.
  13. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    Your laptop canot see the PC still... Which is complicated. :(

    Ask yourself the following questions:

    1.) Workgroup or domain - Are they the same?
    2.) Subnet Mask - Is it the same for both PCs? (DHCP should be correct).
    3.) Client for Microsoft Networks - Is it installed and enabled?
    4.) NetBIOS and possibly NetBEUI - Are they installed & enabled?
    5.) Firewall software - Is it disabled or set to allow network connections?

    If the answer is yes to all of the questions, it should really work for you. If isn't working, then you probably have an issue that is not due to configuration or hardware, but a bug of some sort.

    Some things you may want to try to verify the above are:

    1.) Look in System Properties --> Computer Name
    2.) Look in Network Properties --> TCP/IP
    3.) Look in Network Properties
    4.) Look in Network Properties
    5.) From the computer that can see both itself and the other, Start -> Run -> Type cmd . Then type ping name_of_other_pc in the prompt window. (name_of_pc will be the name of your other PC, obviously. You may also use the IP address) If you get a reply, we know it is not a firewall/connectivity issue. If you recieve time outs or other errors, then we know where to look.
  14. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    in your nic properties make sure the wins panel at bottom reads checked
    enable LMHosts lookup

    enable netbios over tcp/ip
    do not use default setting
    in the pc that can not access other machine
    in security setting add network add permissions for network

    in sygate add the router ip as a trusted network
  15. milky

    milky TS Enthusiast Posts: 85

    Did you try uninstalling and reinstalling the NICs and protocols?
  16. josbd

    josbd TS Booster Topic Starter Posts: 202


    Just about to check out all of the above!

    Shall report back. And thanks ;)
  17. josbd

    josbd TS Booster Topic Starter Posts: 202

    Right: well I don't know which particular form of action worked, but all is now well! Network up and running, and happily sharing!

    A massive thank you to all of you for helping!

    Cheers chaps! And if ever any of you are in the UK, I owe you a beer or several!
  18. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    I accept money orders, certified checks and C.O.D. Please, no personal or third party checks. Thanks!

  19. IronDuke

    IronDuke TS Rookie Posts: 856

    Hey Rick checks are different over here. He'll send you the winner's flag. :haha:
  20. josbd

    josbd TS Booster Topic Starter Posts: 202

    Damn.......... got a pile of slightly dubious 3rd party cheques sitting here, heheh!!

    Many thanks to all :D
  21. equinox137

    equinox137 TS Rookie

    Can you ping between the two machines?
  22. josbd

    josbd TS Booster Topic Starter Posts: 202

    Yep, and all is now fine, thanks mate :D
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...