Problem Running Defrag in Win2K

By larswebb ยท 23 replies
Jul 24, 2004
  1. Hi,

    When I try to run disk defragmenter I get an error message
    "mmc.exe has generated errors and will be closed by Windows. You will need to restart the program"

    Restarting gets the same result.

    Any Ideas?


  2. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Is it just disk defragmenter snap-in, or is it whenever you go into the management console at all?

    Try this...

    start, run, type "mmc" (no quotes), return

    Console1 window appears.

    file--->add remove snap-in---> In Standalone tab, hit ADD --> Select Disk Defragmenter---> ADD ---> CLOSE --> OK.

    Try using that instead. You may, of course, get the same thing...

    Did you install anything that plugs into the mmc? If so, uninstall it. Uninstall any program that added its own disk defragmenter.

    Its possible you have an unregistered dll as well, which you would have to register. Or its corrupted. But finding that dll is like finding a needle in a haystack.

    Try a windows restore if all else fails.
  3. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    As far as I can tell it's just the defragmenter. I followed your instructions and got the same error message. I don't know if I installed anything that plugs there. I have not tried to run defrag for quite a while so I don't know when this problem started.

    Does Win2k have a restore?

  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    No restore for W2K, but I can heartily recommend you buy Drive Image, it's a life-saver.

    Before you run defrag, do a checkdisk first: select Start/Run and type chkdsk and hit enter. Having errors on your disk in most cases prevents defrag from running.

    The native defragger is a clipped version of Diskeeper (I think V6.0).
    Surf over to
    to get a more up-to-date version, well worth its money.
  5. Phantasm66

    Phantasm66 TS Rookie Posts: 5,734   +8

    Sorry, I missed that you had W2K and not WinXP.

    What service pack are you using? Maybe you should upgrade to the latest, or if you have the latest, reinstall that.
  6. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    I ran chkdsk first had the same problem. I'm using SP4 so I tried to reinstall it. That didn't work so well, I had to use a bootdisk to get up again and ran GoBack so I'm back where I started.
    I have another issue going on right now that may be related. In add and remove programs many of my program icons and all windows hot fixes changed to (computer graphic) . See attached screenshot



    Attached Files:

  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

  8. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    Unfortunately My icon problem is the least of my worries. And I installed Disk Keeper 8 demo and that looks real good.

    When I tried to turn on my computer yesterday morning all I got was a black screen. The CD drives will operate and it sounded like my hard drive started and then stopped. There is no boot screen or anything just black. My monitor is not turning on. I'm using my backup PC with the same monitor and it works fine.

    Please Help

  9. Mr-CFB_95

    Mr-CFB_95 TS Rookie

    Your monitor was all black? Did you try turning it on? For me, sometimes my "turn on monitor" button gets stuck so I have to take a pin to pull the button out and then press it fully back in so the button can hit the circuit to send the information to turn on the monitor, or if its not that, maybe your cable is not plugged into the monitor.
    Or you could've accidently turned the brightness all the way down or it could be a problem with your monitor settings. But I am using Windows 95 so I don't know anything about Win2000

    Sorry if this may sound like stupid advice but it is all I know and I could at least try to help others since I am getting help from my PC problems.

    P.S: Get windows 95, it rocks! The system is so simple that it makes it easier to solve problems, if you have a complex OS like 2000 then it will obviously be more complicated.
  10. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    Yes my monitor is black. The little orange lite is on and its suppose to wake up and turn green. All I did was shut down for the night. I have had problems with power button not working but flipping the switch on the power supply off then on again always got it working again.
  11. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Try reseating your graphics card, and check any other cards too while you are at it. Also reseat memory and check all cables between mobo, drives and PSU.
  12. Shiney

    Shiney TS Booster Posts: 160

    You may also want to try a boot cd, and if that fails reset your bios.
  13. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    How about a bad hard disk?

    Bad sectors might causes defragmenters to locked up, crash etc... And it may also cause your computer to behave oddly and even not boot depending on where data may be missing or corrupted.

    I recommend running a disk diagnostic just to be on the safe side.
  14. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Is it just me or do Windows defragmenters have a tendency to break something?
  15. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    I have it up and running again. While then drive lights were still blinking I repeatedly tapped F10 and got to the settings. I exited and it booted up! I tried it again and it started OK. I tried it again and it booted up but the mouse and keyboard wouldn't work. I tried again and it worked ok. I don't know what to fix. Every other boot up works inbetween the mouse and keyboard don't work.
    I think I might have to bite the bullet and take it somewhere.
    It's less than 2yrs old and most of the parts are under warranty.
    Unfortunatly I built my self.

  16. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    It could be that (one or both) PS/2 port(s) is/are faulty.
    Borrow another keyboard and mouse with PS/2 connectors to eliminate that problem.
    If they also fail, try a USB mouse and keyboard. If they work, then your problem is (most likely) solved.

    Open your PC anyway and check/reseat every card/memory/drive/mobo connectors etc.

    Check your mobo's website, to see if they have a newer BIOS that refers to your problem. If the new(er) BIOS does not mention any of your problems, DON'T flash your BIOS.
  17. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    PS/2 ports use IRQ12, maybe the computer suddenly decided to share it with hard disk controller?
  18. Goalie

    Goalie TS Booster Posts: 616

    Have you tried replacing the bios/cmos battery?

    Bad batteries which lose settings can cause no end of frustrations.... Relatively cheap attempt at fixing (usually less than $15USD)
  19. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    I reseated Everthing.
    I tried another Keyboard and mouse and got the same result.
    There is a newer bios available but it doesn't address my issues but I don't think I would mess with that anyway.
    So I took it in to get repaired. I will let everyone know what it turned out to be. I hope it wasn't the battery!
  20. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    Right now the problem has been narrowed down to the motherboad (Asus P4S8X). I have recieved a RMA# from Asus so it will be a couple more weeks before I get it back. According to the technician working on it there is a problem with the north or south bridge, failure to post to the monitor.
  21. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    Well after a little more than 2 months CompUSA finally got me up and running again. After replacing the mother board and still having the same problem they decided it was the video card (Gainward Geforce 4 650 Golden Sample). Now it seems to be working OK. When I first got it back I was still having issues with the keyboard and mouse so I updated the drivers and so far so good. I also still had a problem with disk defrag and crazy icons in add remove programs so I uninstalled all the freeware stuff I never used anyway and now everythings working OK. Time will tell.
  22. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Maybe you should consider a reformat and reinstall I know it`s probably not what you want to do but sometimes it`s the only way to sort out a problem. If you do this and still experience problems then it`s probably a hardwear problem. Regards Howard:grinthumb
  23. larswebb

    larswebb TS Rookie Topic Starter Posts: 32

    Hey Howard,

    My problems with the keyboard & mouse have returned and sometimes when I shut down for the night the next day the power button won't work. Then I turn off the PS switch for a few seconds, turn it back on then the power buttons works Again.
    You may be right about the reformat and reinstall. Does Win2K have a repair windows option like Win98? Could the power button problem be software related? This computer now has a brand new motherboard and videocard.


    Will I always be a newcomer in training?
  24. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Not sure about w2k as I`ve never used it but I`m sure someone will let you know. Once you reach 50 posts you will no longer be a newcomer in training. Regards Howard:grinthumb
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...