Problem with dvd burner Sony DVD RW DW-U18A

Not open for further replies.
My dvd burner (Sony DVD RW DW-U18A), 18 months old, stopped working today.

When I insert a blank cd-r or dvd, it will not recognize the medium
no matter which software, Roxio/DVD XCopy/1 Click DVD/DVD Shrink,
I use.

Could somebody please let me know how I should proceed?
Thanks, TomiR :dead:
so it plays dvds and cds, it just doesnt prompt you to burn empty disks? (if so)seems to me like these disks you think are empty are either scratched, warped, defective or are not really empty.
First... do you have auto insert working.??
2nd... can you play a cd or DVD that you know is recorded.??
3rd... several 3rd party programs can kill your player.
4th... when you insert a CD or DVD can you explore it?
example is Dr. Divx - known to skew with CD's and DVD players.
fix for Dr. Divx and other 3d party skewup's
You may perform the following steps to isolate it:

1. Run Regedt32.exe.

2. Locate the 'UpperFilters' value under the following key in the registry,
and delete it:


3. Locate the 'LowerFilters' value under the same key, and delete it:


4. Close the registry editor and restart the computer.

you can also try: control panel -> system -> remove your player... reboot and let your OS find an reinstall...
I had the same problem

You should back up and do a system recovery, what happens over time is that from installing different apps you get file conflicts which affect drivers in a very disruptive manner. A system recovery should eliminate that. My drive would not see discs the same way you describe, I had a warranty on the computer so I had a tech out who installed a brand new drive and it would not see the discs either so he told me to do a system recovery and that did the trick!

Frank Smith said:
You may perform the following steps to isolate it:

1. Run Regedt32.exe.

2. Locate the 'UpperFilters' value under the following key in the registry,
and delete it:


3. Locate the 'LowerFilters' value under the same key, and delete it:


4. Close the registry editor and restart the computer.
I'm having the same problem... my drive wont recognize CD-R (blank or with data) but will recognize everything else (DVD, DVD+R, and Store bought CDs).

Is this the only registry key where you should delete these references? If I search the registry, I see "UpperFilters" and "LowerFilters" in many other places too. I've tried deleting just the two particular ones you listed and the problem is still happening... should I be looking at the other references as well? I don't want to delete anything that I shouldn't, but I'd really like to solve this problem.

Also, I'm not a registry expert... I noticed that every time I see "UpperFilters" and "LowerFilters" in the registry, under the "Type" column it says "REG_MULTI_SZ" but most other entries throughout just say "REG_SZ." Does that mean anything?

I wish I could remember what I was doing right before this problem started happening..... I don't really remember installing any new programs recently.

Thanks for the continued help; you guys are great!
copy and paste this with notepad or word..... then saveas CDGONE.reg then doubleclick... and say yes you want to add this to the registery...







Hope this helps
Frank, thank you for the information. I did this update and the filter references were removed from that registry key successfully, however, the problem still persists.

I ran a program that detects which filters each drive is using ("Filter Driver Load Order" via and it reports that the CD drive is using redbook Upper Device Filters and imapi Lower Device Filters. (Unfortunately, it didn't provide much more information beyond that.) I looked around the registry and found references to "UpperFilters redbook" in relation to the CD drive in the following locations:

  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\IDE\CdRomIDE-CD_R/RW_4x4x24______________________C12a____\3237323830344833495755534e332020_0_0_0_0
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\SCSI\CdRom&Ven_IDE-CD&Prod_R/RW_4x4x24&Rev_C12a\5&3ae52175&0&000
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\SCSI\CdRom&Ven_TSSTcorp&Prod_CD/DVDW_TS-H552B&Rev_TS05\5&3ae52175&0&000
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\SCSI\CdRom&Ven_TSSTcorp&Prod_CD/DVDW_TS-H552B&Rev_TS10\5&3ae52175&0&000
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\SCSI\CdRom&Ven_TSSTcorp&Prod_CD/DVDW_TS-H552B&Rev_TS11\5&3ae52175&0&000
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\IDE\CdRomIDE-CD_R/RW_4x4x24______________________C12a____\3237323830344833495755534e332020_0_0_0_0
  • HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Enum\SCSI\CdRom&Ven_IDE-CD&Prod_R/RW_4x4x24&Rev_C12a\5&3ae52175&0&000
  • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\IDE\CdRomIDE-CD_R/RW_4x4x24______________________C12a____\3237323830344833495755534e332020_0_0_0_0
  • etc.
Would any of these raise suspicion?

I'm beginning to hope that the drive is just "broken" and I can simply replace it with a new one! But that leads me to another question: if this problem is indeed software/registry related, will I be able to install a new CD/DVD drive to overcome the problem, or will the problem still happen with a new one?

Thanks again for the help! I wish I knew what other information to provide; please let me know if you have any further ideas or any thoughts about getting a new drive.

Next it be to know all the different cd/dvd programs you use and there versions?... sample: Dr. Divx, Easy VCD, Roxio, Nero.... etc etc ... If I remember correctly you have to reinstall Roxio after you install Nero.. and Dr. Divx was a nasty program which several versions conflicted with XP...and created many different problems.... !
what are the different names of the CD and DVD players you have
have you upgraded there firmware? to the latest...
are they rated compatible with XP ??
can you play a store bought CD?
can you play a store bought DVD?

many questions but only a few at a time....
For the past year I've been very consistent with the CD/DVD programs on this computer. I've been using Nero Express 6 as my CD-R/DVD burning software, and for DVD viewing, I've been using interVideo's WinDVD Platinum 6. I've never used Roxio or Dr. Divx on this computer. I also use WinAmp 5 to listen to audio CDs. I've been happy with these three programs so I never really had a reason to try anything else. The problem seems strange to me because I haven't installed any new programs recently. I tried re-installing Nero, but I didn't notice any changes; it still acts like there is no CD-R disc in the drive. Maybe I will try to remove Nero completely.

I don't know if this means anything, but the last CD-R disc that I had any success with in the drive was severely scratched. The drive recognized the scratched disc, but it was not able to get all the data off that scratched disc. I'm pretty sure that was the last time it recognized a CD-R, but I never thought a scratched disc would be able cause a drive to fail... is that actually possible?

Edit: complete removal of Nero did not help...still same symptoms: after inserting a CD-R (with data and without) the light just blinks and the motor moves around a bit, but Windows does not respond. It does read store bought CDs, and it even reads data from a DVD+R that I made a few months ago. I honestly don't mind buying a new drive if it will work...
OK, if you want to remove NERO make sure you use the clean program from Nero...
first... try this... I have seen this happen several times...
shut down the computer.... remove the DVD/CD player by simply unplugging it(totally unplug pwr and cable) .. after 3 or 4 mins... shut down again...
then reset all cables.... restart the computer... is if that will clear the problem.
second place a bootable CD or DVD into unit... make sure the BIOS is set to
1st boot CD... use control panel to check CD/DVD and populate it or both units.... IT MUST BE A BOOTABLE CD/DVD....
Scratched disc? That rings a bell. Check this link and see if it helps. Click here.

The part about "Uninstall the secondary IDE port" might apply.
I havnt used any extra program apart from InterVideo WinDvd.
and I havnt touched the computer. cuz Im afraid Im gonna touch somethin and break it :p so uhm...cuz im not qualified to do somethin like uhm...I tried evrything you said...and nothing...any more suggestions?
Seems like your player is intermittent, I'd suggest replacing it with a new model. Make sure you read on the BOX what all items the NEW PLAY supports. Some times "firmware" for some reasons seems to fail on what it can read correctly, (this I have found also indicates) Failure of the Device.

If you were "minded" you could open the old unit and look for bad solder joints, or simply "lint" which could be shorting some points depending on the humidity level & temp inside your unit...

I have at time removed devices, opened the cases (voids the warranty) and use "a small air compressor" 25 to 30 lbs max and blew them clean...replaced the covers, reinstalled and "VIOLA" all worked OK. Lint is caused by (moms, girlfriend's, wife's who vacuum to much, and carpets or cats.) guys that leave there computers running when the aforementioned do house work.
Not open for further replies.