1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Problem with Gigabyte GA-K8VM800M and memory

By slippyjim20
Jul 5, 2006
  1. Hiya,

    I’m in a right mess I offered to help my mate with his PC and it has just been a disaster!!!
    Current config is a Sempron 64bit 2600+, Kingston Value RAM 512MB DDR400 (64MB for gfx), Gigabyte GA-K8VM800M, 80GB Seagate SATA HDD, LG DVDRAM

    It started going wrong soon after he got it (its useless trying to take it back to the shop as we live in Tenerife and they don’t believe in refunds over here!). I thought I had sorted it a while back when I discovered that he had been sold a dodgy hard drive, it was officially an 80GB disk but had been deliberately limited to 60GB and had a load of bad sectors on it. So I got a new hard drive and reinstalled everything for him. It seemed to be alright until today.

    Now whenever you try and start up it comes up with the black screen with white writing asking if you want to start windows normally or go into safe mode. If you start normally it gets to the XP logo with the moving bars and just stays there, if I go for safe mode it displays all the files its loading and gets down to gagpx30.dll (or something like that) and then after a few seconds displays a BSOD with STOP 0x50.

    So before repairing windows I decided to have a look at the memory using memtest, and this is where it gets stranger. With the RAM in slot 1 of the motherboard after a few minutes there are no errors, but with the RAM in slot 2 there are about 40000 errors after a few minutes, all at either 0.6MB, 4.6MB or 5.6MB. If I leave the RAM in slot 2 and try and boot up it just restarts a few seconds after detecting the SATA HDD. So then I thought it must be the motherboard so I tried 2 other sticks of unbranded 256MB DDR266, one at a time in slot 1 and then slot 2 and after a few mins there are no errors with either RAM in either slot. I know I need to let memtest run for a lot longer but even so that doesn’t explain the odd results with the 512MB in slot 2.

    Ok, an update……
    Does memtest v3.2 support 64 bit CPUs?
    All these results are with memtest v3.2
    Dodgy (?) memory in broken PC slot 1 – OK after 33 passes (approx 7 hours)
    Dodgy (?) memory in broken PC slot 2 – 40000 errors after 2 mins at 0.6MB, 4.6MB & 5.6MB

    Working memory in broken PC slot 1 – OK after 70 passes (approx 16 hours)
    Working memory in broken PC slot 2 – still running but OK after approx 1 hour
    Working memory in broken PC slots 1 & 2 – not tried yet

    Dodgy (?) memory in working PC slot 1, 2 & 3 – 130000 errors after 4 minutes but this time at 442.6MB, 212.6MB, 273.6MB and some other values

    Any ideas?
    I can’t seem to see any logic to these results, it looks like the dodgy memory is broken but why is it ok in slot 1 of the broken PC?

  2. pcaceit

    pcaceit TS Rookie Posts: 315

    Hi, as the stick showed errors on working pc, then there must be a problem with the stick and you should just replace it, if the two 256mb work ok, and the system boots ok and works ok then it is just a dodgy 512mb stick. faulty ram does not necessarily have the fault/s at specific memory addresses only, and i suspect that memtest probably does not check the memory addresses in a rigid sequence (123etc..) so this might explain the varying amounts of bytes checked before it comes across the faulty addresses. Sounds like a dodgy shop to me with dodgy techs, as for the memory seemingly working ok in slot 1 of the broken pc! this is also probably down to which memory addresses are read first by the controller and maybe the error only accur when the addresses are read or written to in a particular sequence.

    Initially the problems looks like one where there is hdd corruption or corrupt system driver and sometimes filesystem or partition table errors but if the memory fails memtest in working pc then that is the problem.
    hope this was of some help.
  3. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

  4. slippyjim20

    slippyjim20 TS Rookie Topic Starter

    Put a new stick of memory in and it has behaved itself so far, 4.5 days and counting.....

    Thanks for the help,
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...