Problem with Router (possibly due to DHCP?)

By acidosmosis ยท 4 replies
Nov 15, 2003
  1. I am using a Westell Wirespeed 2100 DSL modem, and a D-Link DI-604 Ethernet Broadband Router. The Westell is set as "bridged ethernet", and the D-Link is set for PPOE. The reason for this is I need to connect multiple computers to this DSL connection so I am using my D-Link Router for that purpose. The D-Link is actually making the connection with PPOE.

    Two computers are connect to the D-Link.. a Windows XP machine and a Windows 2000 machine, each are set to automatically receive an IP. When these PC's receieve an IP it is indeed in the range that I specified on the D-Link's DHCP settings (.101 and .102).

    The Westell modem is connected by CAT5 from its WAN port to the WAN port of the D-Link. The Windows XP machine and Windows 2K machines are connected to ports 1 and 2 on the D-Link (note: I have tried others such as 3 and 4.)

    The problem is this. If the Windows 2K machine is connected to the D-Link, the D-Link's lights would go off and I would see "network cable unplugged" then the lights would come back on, almost as if the D-Link was restarting itself. Then I would lose Internet connection on both machines for about 15 seconds until the D-Link started back up. This only occurs with TWO pc's connected to the D-Link at once, but not one.

    I updated the firmware after trying multiple things to fix the problem and then the problem started occuring about every minute instead of every 20 minutes or so.

    Note: For a few months I used the D-LINK DI-604 basically as a switch to connect two machines. (The machines were connected to ports 1 and 2, and I was able to successfully network those two PC's with no problem whatsoever so it seems to me that this specifically occurs when the WAN port is in use with TWO computers connected to the ports).

    Note: Firmware on the D-Link DI-604 and the Westell Wirespeed 2100 have been updated.
  2. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Make life easier on yourself:
    In your router-setup (WAN - ISP or the like) change the protocol to something like: "Fixed IP"
    Under LAN disable the DHCP-server

    On both your PCs under Network settings, change the Local Area Connection/Properties, ONLY the Internet Protocol(TCP/IP) Properties to read as follows:

    Use the following IP-address: ( or 102, etc.)
    Subnet mask:
    Default gateway: the IP-address of you D-link router

    Use the following DNS...
    Preferred DNS: same IP-address of D-link router as default gateway
    Alternate DNS: leave blank or put in the first of your IP's DNS-servers

    PS: I use a Billion BIPAC 640AE Firewall/Router so my setup might be different from yours
  3. Rick

    Rick TechSpot Staff Posts: 4,572   +65

    To make things even easier on yourself, just replace your router. :)

    I don't think there's any set of circumanstaces in which the router should turn itself off for 15 seconds, regardless of settings or what's connected it. It's clearly not working properly, which makes me believe replacing it would be the best solution.

    It's always fun to troubleshoot things, but save yourself the headache, man! :)
  4. acidosmosis

    acidosmosis TechSpot Chancellor Topic Starter Posts: 1,350

    That's what I'm thinking Rick. It doesn't many ANY sense to me that it would restart itself for any reason like that.
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...