1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Problem with secondary HDD, error loading operating system

By NV30 ยท 20 replies
Feb 22, 2003
  1. Hi,

    Finally got back to here, my 40GB drive failed and Maxtor was kind enough to RMA an 80GB back to me! It's very quiet and fast so I'm happy. Basically I have a backup drive set as the slave which has all my backed up files from before the crash. I'd naturally want to hook it up to my PC. I have it set as a slave, power, IDE cables all attached. My BIOS recognizes it, but then during boot I get error loading operating system. So I go and run XP Recovery console, and I see that it's examining the drives, but they're both on Disk 0. Not sure if they should be. The newer one is Id0, older backup is Id1. Not sure what has gone wrong.

    Booting with just the 80GB works fine.

    If you need my specs, they're in my profile.
  2. Nic

    Nic TechSpot Paladin Posts: 1,519

    I suggest you disconnect the slave, install your OS to the new drive, then re-attach the slave and see what happens.

    If that doesn't work, then you need to check the jumper settings on each drive (maybe do this step first just in case). You are probably best to set both drives to 'cable select' (CS) setting and make sure that the boot drive is attached to the furthest away connector. Then there will never be any confusion between drives.:grinthumb

    PS: I am assuming that you autodetected each drive in your bios!
  3. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    Yeah, they were both auto-detected. What advantage would cable select have? Also, what pin setting would that be?
  4. Nic

    Nic TechSpot Paladin Posts: 1,519

    If you set all drives on a cable to 'Cable Select' then the drive furthest along the cable always becomes IDE0 (for primary controller - IDE3 if on secondary controller) and the drive on the middle connector becomes IDE1 (for primary controller - IDE4 if on secondary controller).

    The jumper settings for your drives depend on your particular drive make/model and should be shown on the drive label.

    The advantage of the CS setting is that you never have to worry about jumper settings afterwards, even if you move drives around (the cable select setting is a convienience feature). It would eliminate having the jumpers on your drive set wrong by accident.;)
    Just a thought.

    You don't provide enough detail about what you did to fully understand your problem, so I provide some 'general' solutions for you to try.

    How did you install XP if your drive is not recognised properly?
  5. Rick

    Rick TechSpot Staff Posts: 4,512   +65

    I recommend cable select if you are having problems like this.

    NEwer UDMA drives have two master jumper positions usually. The first is for a single master without a slave, and the other for a master with a slave. They don't always work the same, so try each.
  6. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    I have the D740X from Maxtor. Couldn't find anything on two master positions. A friend of mine suggested swapping IDE cables, ie HDD & DVD on one, HDD and CDRW on another, versus DVD+CDRW and HDD+HDD2 as it is now.
  7. Nic

    Nic TechSpot Paladin Posts: 1,519

    Here's a checklist ...

    1. Is your new drive set up as 'master' on your primary ide channel (it should then be ide0)?

    2. Is your backup set up as 'slave' on the same cable (it should then be ide1)?

    3. Is your bios set up to boot to ide0?

    4. If you then installed your OS to the c:\ drive (ide0) then everything should be fine.

    PS: I am assuming that you must have partitioned and formatted your new drive (and made the partition an active primary partition - windows xp would do this for you if you install to a new drive) as you appear to indicate that you did install an OS but it will not boot.

    Failing all this, maybe you should try reseating all cable connections as you may have a bad connection.:cool:

    You could also try moving your backup drive to the secondary ide channel with your cdrom.

    If you are still having problems then please indicate exactly what devices you have attached and where!
  8. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    Thanks. I'll try moving the drives around on the cables, as I think I completed everything on the checklist. I also heard that Maxtor drives might "fight" with other ones on the same connection.
  9. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    Another thing, what is the jumper setting for the Maxtor D740X to be master when there's another drive as slave? Sounds like there are two master settings. This is an OEM drive, so I have no manual to tell me, nor is Maxtor's site any good.
  10. Nic

    Nic TechSpot Paladin Posts: 1,519

    All Hard Drives show jumper settings on the label on the top of the drive. If you don't want to look there you can use the following document (pdf) available on maxtor's website ...

    Maxtor Hard Drive - Jumper Settings
  11. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    Thanks. Actually, Maxtor doesn't have the settings on most of their drives, including this one. I tried putting the drives on different IDE cables, but they can't streach far enough to connect my backup drive. You can't move the connector on the cable, can you?
  12. Nic

    Nic TechSpot Paladin Posts: 1,519

    If you take a look at the doc (see link in above post) I think you'll find the settings for your drive on page 9 (style c).
  13. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    Yeah I got it. There's only one master selection though. Another thing, how do you remove your expansion cover? I'm going to move a few drives around so this can work. Is there a popup button on the back? Sorry for this stupid question. :)
  14. Nic

    Nic TechSpot Paladin Posts: 1,519

    I don't know what an 'expansion cover' is - please explain.

    If you are talking about the front bezel, then most common way is to remove case side panels (I am assuming that you have a tower style case) and the look for any screws that go through and attach to the front. There is a lot of variation between different cases however, so you need to describe your case better.
  15. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    I meant the panels that cover your 5 1/4 inch drives. I got them out ok, and installed the drives the way they should be. They're both still at Disk0, even after assigning one to be on a separate IDE cable. I'm thinking I should just copy all the info off my backup onto a friends drive, format the backup and copy back all the files to my master drive. Not sure if Windows thinks they're both "boot drives" as it must be looking for Windows on both as they're both Disk0.
  16. Nic

    Nic TechSpot Paladin Posts: 1,519

    Did you have win2k or xp installed on the backup drive?
  17. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    It did have XP, but I'm pretty sure I formatted that partition. I sure hope I don't have to format the drive to make it work.
  18. Nic

    Nic TechSpot Paladin Posts: 1,519

    Something you can try ...

    Leave both drives connected how you want them, then reinstall windows over your existing installation. If that doesn't work you may have to try deleting the master boot record on the backup drive (or both drives), but start with that first as its easiest.

    I have more suggestions, but they're not so easy to carryout on XP as can't use a boot disk and edit files easily.

    The problem may be as you say, and windows is getting confused and trying to boot to the drive without the OS.
  19. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    All that I can say is it worked!! I can access the drive, although I think they might still both be on Disk0. Guess Maxtor doesn't like other drives on it's IDE cable.
  20. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,049   +11

    Relax, that disk(0) in NT boot loader configuration has nothing to do with the physical configuration. In IDE configuration, it's always 0.
  21. NV30

    NV30 TS Rookie Topic Starter Posts: 242

    OK, well anyways, even if it didn't matter, having them on different IDE cable works well.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...