Problems after installing Sevice Pack 2...

By Need_a_Dell ยท 13 replies
Dec 30, 2005
  1. My mom finally got high speed internet. Her computer was purchased just a few years ago. With only dial-up, microsoft updates would take ages. So when the new high speed came along, there were a lot of things to install. I installed about a million different updates from the windows update site which all went smoothly, but now I am unable to right-click on anything. When I do this the window that is open will become unresponsive, and the right-click menu will not show up. After this happened I performed a system restore and I got my computer back to the way it was supposed to be. I figured that there was just a problem with the way the updates installed. That was two weeks ago. I decided today that I would try to update the computer for a second time. Again things went smoothly, but low and behold, I can no longer right-click. I can however right click on the desktop. But when I right-click on an item, the system locks up. I thought that maybe there was a piece of software that I had installed that wasn't compatable with SP2, so I unstalled the programs that would normally show up on a right click on a file. I uninstalled WinZip and WinRar. (These were not the newest versions out there.) This seemed to sort of work. I can now right-click on folders, and the menu will pop up with the system freezing, but I still cannot right-click on files. I have no idea what else to do. Is there something else that I should look at? Any suggestions would be greatly appreciated! :eek:
  2. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    Try either reinstalling your mouse driver or better yet get the latest one from the manufacturer's site. Your old mouse driver may not be compatible with one of the new updates. Was Windows XP Service Pack 2 one of them?
  3. SultanGris

    SultanGris TS Booster Posts: 158

    i had multiple problems with service pack 2 also, it would be fine for about a week or two after format/reinstall, and then would act up again. i reverted to service pack 1 and dont have the problems i did before.
  4. Need_a_Dell

    Need_a_Dell TS Rookie Topic Starter Posts: 44

    Still having problems...

    I tried updating the mouse driver, but it didn't work. Just to clarify, I can right-click on folders, but not on files. It doesn't make sense for a computer to stop functioning properly because of an updated OS. I set restore points after every update I put on today. I tried to restore the comp to just after SP2, but when it booted back up, it said that it failed to restore. I haven't tried restoring to before SP2 yet, but I would rather just get the damn computer to work with the updates instead. If anyone out there has any more suggestions, that would be great.:)
  5. mailpup

    mailpup TS Special Forces Posts: 7,188   +470

    What mouse do you have?

    Just in case you want to, I believe you can uninstall SP2 in the Add/Remove Programs. Service Pack 2 is not an ordinary update. It has broken a lot of programs. Don't get me wrong. I think it would be better to keep it if possible. You just have to update some other things because of it.

    You might want to check in your Device Manager to see if any other devices were negatively affected. Look for any that have yellow exclamation marks next to them.
  6. r_chowdhury

    r_chowdhury TS Rookie

    If you cannot right-click on only files, then may be you have got something bad on the context menu. Scan your computer with a good antivirus program and an antispyware to be sure.
  7. SultanGris

    SultanGris TS Booster Posts: 158

    encountered many problems when updating to sp2 after already using windows for a while, problems were fewer when reformated, reinstalled, and did all updates before installing any other programs.
  8. Need_a_Dell

    Need_a_Dell TS Rookie Topic Starter Posts: 44

    I have a logitech mouse. When I went to the Logitech site, my mouse wasn't even listed. I downloaded a universal driver for their optical mice. (MouseWare I believe it was called.) The driver works nicely and is compatable with my mouse, but it didn't help my situation.:(
    I checked the device manager and everything is working properly. I tried to do a system restore but it doesn't seem to want to let me. (Everytime it boots back up, it tells me that it was unable to perform the restore.) The computer works perfectly, except for the right click thing and the system restore. Unless someone has any other ideas, I'm going to uninstall SP2. Uninstalling everything and then reinstalling them is too tedious for me. Ultimately, this update it just WAY too much trouble. Thanks to everyone that chipped in. I appreciated your input. It's too bad this hunk of machine doesn't want to work. I'm still open to suggestions though. So if anyone comes up with something new, I'd still love you for it!

    I have up-to-date norton system works and internet security 2006. I'll do a scan, but I doubt it'll come up with anything. Thanks for the suggestions though!
  9. ender

    ender TS Rookie Posts: 94

    This may sound silly but nobody's suggested it yet. Have you tried to use a different mouse and see if it works? If it doesn't then it's probably not the mouse's (driver's) fault and something else is causing the problem.

    Hope this helps.
  10. Need_a_Dell

    Need_a_Dell TS Rookie Topic Starter Posts: 44

    My right-click works. It works in games and applications flawlessly. The only time it acts up is when I try to right-click on a file. (Folders seem to be fine.:S) I wanted to send Microsoft an email, but they wanted to charge me $45 for it. (I don't think so!) I'm going to try uninstaling the programs that would normally pop up on the right-click menu to see if that helps. (ie. Adobe Photoshop CS)
  11. gooderguy

    gooderguy TS Enthusiast Posts: 68

    It is NOT a mouse issue

    I've seen this problem with some customer's systems before. This is very likely to be a problem with one or more context menu handlers. Everytime you right-click on something, you get options and those options will vary depending on what you click on. For example when you right-click a file you get from Winrar, Winzip, Scan with..., stuff like that.

    There's a variety of things you can try on this website

    You can also just try uninstalling some applications that have ontext menu handlers like file compression (Winrar, Winzip), Antivirus, some burning software and try right-clicking files in in between to see if it works.

    Good luck.
  12. Need_a_Dell

    Need_a_Dell TS Rookie Topic Starter Posts: 44

    Thank you for this suggestion. This is what I was thinking may be the problem. The link you sent me was very helpful. I'm going to try it out and see if it helps. (As I already mentioned in an earlier post, I uninstalled Winrar and Winzip and after I was able to right-click on folders. I don't know how many more menu-handles I have, but I do know that Photoshop is on there, so that's going to go.) Any more suggestions are always welcome!;)
  13. Need_a_Dell

    Need_a_Dell TS Rookie Topic Starter Posts: 44


    HOLY CRAP!!!

    I don't know what happened, but my right-click seems to be working now! I hadn't tried anything since last night, but now it seems to be better!:D fingers crossed things stay alright! Thanks to everyone that helped out in my ordeal, I really appreciated it!
  14. Need_a_Dell

    Need_a_Dell TS Rookie Topic Starter Posts: 44

    Update #2

    I did a reboot and now my right-click isn't working again. I'm beginning to think that there's something wrong with my system's boot order or something. This is an extremely weird problem. I'm still looking for sources for the problem if anyone still wants to help!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...