Problems booting Fedora Core 4

By djwillia007 ยท 4 replies
Aug 23, 2005
  1. I am trying to help a freind fix his computer. The error appears "hard disk read failure- no bootable devices- strike F1 to retry, F2 for setup utility" when trying to boot up the linux partition FC 4. Previously there were 5 partitions 4 linux, 1 xp (xp was corrupt and would not boot). On the 2 FC partition there was windows VM of 2000.

    The bios is set up correctly and it recognizes the HDD but will not boot as if the partition is not there any more.

    I booted from the FC cd to run linux restore and I get the following error; "there are no linux partitions to be mounted."

    At this point I am trying to recover any lost data, save it on my network, then reghost the HDD with a new FC-XP image. But I need to retain his lost data. If anyone has any idease please help.
  2. zephead

    zephead TechSpot Paladin Posts: 1,569

    set the boot drive in the bios to the drive with a working linux boot loader in its mbr. if you didn't install a boot loader or the drive itself has failed, you'll need to boot to a removable medium and work from there. what boot laoder do you have?

    there's a reasonable chance that your hard drive is shot, so don't eliminate that as a potential problem.
  3. djwillia007

    djwillia007 TS Rookie Topic Starter

    The BIOS is already set. Initially the MBR was grub. Now that it won't recognize any of the partition load files, it won't boot.

    I tried using KNOPPIX yesterday and that helped me mount the partitions. (I kept on trying to mount and remount and it froze up saying no more RAMDISK space, I rebooted and low and behold the partitions showed up, DON'T KNOW HOW!) After proceeding to remount the MBR and booting into LINUX, the files, and directory are corrupt. I have tried cp -r, tar, and anything else just in the SAMBA server for KNOPPIX to recover but as of right now no luck.

    I have been able to reach the root login. I have to wait for my friend to come back over since I do not have a login on this laptop.

    Is there a simple way to recover, and repair the files and directory system without su root login?
  4. tdeg

    tdeg TS Rookie Posts: 119

    1 word.


    Boot from it and recover your data. It has full network support and also has support for burning.
  5. PanicX

    PanicX TechSpot Ambassador Posts: 669

    You're getting to a root login? So GRUB loads and you selected an installation from there? If so, you may want to check out how to use GRUB to boot into single user mode.

    In a worse case scenario, you can always get a 2.5" disk external hard drive and plug the laptop drive into there to recover the files on a different system.
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...