Problems on bootup - no video display

By troypar54 ยท 6 replies
Jul 31, 2005
  1. Hey guys, new to forum and would appreciate any thoughts on my current situation...

    My problem is that when I turn on my pc, I get no display at all. This started yesterday without any warning. I had the pc on for a few hours in the morning, powered down & later on I tried to power-up and got no display at all. I tried a different monitor, different v-card, mouse (non-wireless), keyboard (all are known to be ok) - no luck! When I power-up, all of my fans (case, processor, power supply and v-card) start, my harddrives run, my optical drives have power (can open & shut the doors) but I just don't get any display at all. I also don't get any sort of post beeping. I pulled out my RAM (RDRAM 4x256) just to see if I'd get any error beeping, but I don't get anything. I removed the battery and reset the cmos, I even bought a brand new battery and installed it. I re-seated the proc, but that didn't help. One curious thing is I don't get any lights on my keyboard, nor do I get a light on my wireless mouse receiver. I'm thinking something has gone wrong with my motherboard - I can't swap it out with my parts on hand. I was thinking the PS was bad, but I get power to everything in the case, and I can't swap it out right now either. The PS is a Chieftec 420w. This is kinda frustating - it's my son's PC and I am known as the one who can usually fix anything PC related, LOL! Any help would be greatly appreciated. Listed below are the pertinent PC specs:

    OS: WinXP Home
    MB: Asus P4T533-C
    PROC: Intel P4 2.8 ghz
    MEM: RDRAM (4 x 256mb)
    V-CARD: Nvidia 6800GT 256mb
    HDs: Maxtor 80gig EIDE x2
    OPTICALs: Liteon 52x CDRW, Pioneer DVD-R 4x
    PS: Chieftec 420w
    SOUND: Soundblaster Live 5.1

    Once again, thanks in advance!!
  2. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    You seem to done all of the obvious - the Mb swap. Very curious!
    I would definitely change to a PS 2 mouse and try another Keyboard ,
    Also try a new monitor cable ,I know , but I have seen this here more than once. And, I don't know that Vid crd , but if it has Digital & Analogue connection use the analogue.
    It may be that you have deleloped bad a Mb or short ( do a visual check on mount points, Clean card/Ram terminals with an eraser.Blow out dust etc.
    Let us know if you have any luck.
    BTW, Welcome to Techspot.
  3. troypar54

    troypar54 TS Rookie Topic Starter

    I have swapped out the monitor (different cable), keyboard and mouse (PS2) and neither worked - they are known good components because I'm using them right now to type this in MY computer. I pulled all 4 of the RDRAM sticks, swapped them around, used 2 instead of 4 (you have to use matched pairs with RDRAM). I've cleaned the contacts, used a whole can of air cleaning the connectors on the MB. At one point or another this past 24hrs, I've had every card & drive either disconnected or connected in the computer (except for the MB & PSU) with the same results - nothing. Thanks for the welcome to the forum, lots of good info here...
  4. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    Just checking , but I am sure you know Rdram slots all must be populated if you you use 2 sticks you must insert the two dummy sticks(for lack of the correct term) in the other slots.
    I guess a new Mb is the next logical move , but I don't see where you have actually tested the Ram, you may want to try 2 new sticks if you can.
    Let us know how things work out.
  5. troypar54

    troypar54 TS Rookie Topic Starter

    Yeah, when I pull the RDRAMs out and re-arranged them, I made sure to use the CRIMMs where needed. Another update... I tried a different PSU and got no change during boot-up, so I think I can rule that out. Guess I'm down to Proc & MB. If I pull the proc and power-up, shouldn't I get some sort of error beeping on POST? Going to try that here is a bit (at work now). Thanks for your help...
  6. Liquidlen

    Liquidlen TechSpot Paladin Posts: 1,094

    I would think beep code with no proc would look like non recognition type error?
    I believe new Mb, but I would be curious as to the real state of your existing Ram.
    Let us know
  7. troypar54

    troypar54 TS Rookie Topic Starter

    I just got an RMA from Asus for my MB, so hopefully in a couple of weeks, I can rule that out. Thanks for all of your help!
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...