1. TechSpot is dedicated to computer enthusiasts and power users. Ask a question and give support. Join the community here.
    TechSpot is dedicated to computer enthusiasts and power users.
    Ask a question and give support.
    Join the community here, it only takes a minute.
    Dismiss Notice

Problems with Sapphire Atlantis Radeon 9500

By kensa ยท 16 replies
Jun 27, 2003
  1. Hi..

    I've been having problems with my 128meg Sapphire Atlantis 9500 since i installed it, and was wondering if anyone could help...

    the problem's with the AGP settings....my bios tells me that AGP is set to '4x', as does SmartGart, but various diagnostics software (eg 3dmark) tell me it's set to '0x'. I also get very poor performance, considering the specs of my machine - p4 2.4, 768megs of 2700 crucial RAM, the 9500, and two 7200rpm drives - a 3dmark of around 2100, and poor fps in games - even old games, such as Counterstrike. I recently 'discovered' the advanced bit of smartgart, by doing start/run/smartgart, and both 'AGP Write' and 'AGP Read' are set to 'off'. If i try to turn them on, and then restart, smartgart tells me that they're still 'off'.
    I'm using Catalyst 3.2 drivers.

    Are there any settings or basic adjustments I should make to get a better performance from this system? And how do I solve this AGP problem? The motherboard, btw, is an ASUS P4PE.

    I'd greatly appreciate any help you could offer....I'm heavily into gaming, counterstrike in particular, yet know very little about tweaking the system :(

    Oh, and it's self-built, not a ready-made pc. Is there anything I could have done wrong during the building process?
  2. iss

    iss TechSpot Chancellor Posts: 1,994

    Did you install the motherboard drivers? specifically have you installed intel's application accelerator?
  3. kensa

    kensa TS Rookie Topic Starter

    i did install the motherboard drivers, but i can't find any updates for them...only an updated BIOS, and as I don't have an A: that's fairly useless for me.

    and no, i haven't installed the intel application accelerator. should i have done?
  4. iss

    iss TechSpot Chancellor Posts: 1,994

  5. kensa

    kensa TS Rookie Topic Starter


    well, i installed it, and tried to run 'counter strike'....and my pc rebooted. upon windows loading i got a message telling me that 'windows has just recovered from a serious system crash' and i was then directed, after selecting 'send error report', to 'Online Crash Analysis', which tells me that:

    so..erm...i think i'll be uninstalling that application accelerator now thanks :p
  6. iss

    iss TechSpot Chancellor Posts: 1,994

    Your problem was more than likely not caused DIRECTLY by the intel application accelerator. but installing it may have enabled your mobo and card to function at the performance level it is supposed to and in doing so caused the crash because of a another faulty device driver.

    in device manager are there any devices with question marks or yellow triangles with exclamation points in them?

    and have you tried uninstalling the catalyst drivers Completely and uninstalling the card then rebooting and reinstalling the cat? you might also want to try the latest cats.

    to make sure that you uninstall the drivers completely use a probram like Driver cleaner 1.7

  7. kjl

    kjl TS Rookie Posts: 17

    Did you ever get this fixed?

    I'm having exactly this problem, with with an ATI Radeon 9800 Pro - same thing. I also have an ASUS motherboard (P4P800 Deluxe).

    I can go into Smartgart (from start->run), hit the "retest all" button and it will automatically toggle "AGP Read" and "AGP Write" to "on", so at this point everything seems happy. Upon reboot, it takes about 10 seconds longer to log in and the first thing that comes up is Smartgart again, with both of these things switched back to "off."

    I've got the latest BIOS (p4p81009) and the latest catalyst drivers (uh, 3.5 I think).

    Anybody else have this problem and get it fixed?


  8. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Can't these AGP settings be adjusted from BIOS?
  9. kjl

    kjl TS Rookie Posts: 17

    BIOS AGP settings

    The AGP settings in my BIOS are very limited - there are only 2 options:

    Aperture size: set to 64 I think
    And priority (PCI/AGP or AGP/PCI) - currently set to the second one, but I tried both of course, just to be thorough...

  10. kjl

    kjl TS Rookie Posts: 17

    Ah, it's working now.

    Got it working, thanks to a friend at work...



    The Intel(R) Chipset Software Installation Utility installs
    to the target system the Windows* INF files that outline to
    the operating system how the Intel(R) chipset components will
    be configured. This is needed for the proper functioning of
    the following features:

    - Core PCI and ISAPNP Services
    - AGP Support
    - IDE/ATA33/ATA66/ATA100 Storage Support
    - USB Support
    - Identification of Intel(R) chipset components in
    the Device Manager

    Installing this thing made AGP stop sucking.

    You learn something new every day... especially if you're an ***** like me...

  11. ---agissi---

    ---agissi--- TechSpot Paladin Posts: 1,977   +15

    kensa, if all else has failed, why dont you try installing the latest Catalyst drivers, v3.6.
  12. PreservedSwine

    PreservedSwine TS Rookie Posts: 325

    Re: Ah, it's working now.

    Installing chipset drivers was the first reply in this thread. That's what your motherboard drivers are.

    Glad to hear you've got it working, though. Just goes to show that problems that have the same symptoms don't neccesarily have the same cause:)
  13. kjl

    kjl TS Rookie Posts: 17

    Re: Re: Ah, it's working now.

    Yeah, ISS did mention the motherboard drivers right off the bat :) . I think, though, with people like me (and maybe Kensa?), even with something as straghtforward as "install the motherboard drivers", it might not even be clear enough... I'm just a guy who likes games, not putting the machine together, and I'm not very smart anyways. I mean, I know I've got an Asus motherboard, so I went to the Asus site and went to the drivers download page, which just has a RAID driver, some sound drivers, and other unrelated stuff. So I updated the BIOS instead, just so I could feel like I was doing something vaguely useful. I didn't know I had to troll around on the Intel site (actually, it's linked through the "utilities" section of the Asus download page) to get a separate chipset driver... Heh, I don't even know what a chipset is.

    Looking for a FAQ now (what is chipset? what does a chipset driver do? is the chipset driver I need dependent on the maker of the processor or all the other little black rectangles glued to my motherboard? etc. etc.)

  14. schacker99

    schacker99 TS Rookie Posts: 20

    helped me out


    I have to say...thanks a bunch. I am having the same problems when I play Dungeno Siege, meaning my computer would just freeze or restart for no reason at all (that I could think of at least). I updated all of my video card drivers, got the SP1 for XP, I even bought a new power supply because it was mentioned that I might not be getting enough power (since the video card plugs right into the ps). I was running out of ideas and then I come into work this morning and I see your post...which outlined my problems and had the answer. I have been waiting since 8:00 this morning to get home to try it out. Have you had any problems since??? Would any of your other games work? Anyways thanks again

  15. kjl

    kjl TS Rookie Posts: 17

    Hey Schacker. I'm the one who got my machine working - dunno if Kensa has had a chance to try it out yet. I have not had any problems since - I pretty much was just playing Star Wars Galaxies (haha okay you guys can stop laughing now) and instead of crashes every 15 minutes I didn't crash once in a 6 hour marathon gaming session, plus I was finally able to turn on all the fancy graphics options (vertex shading, bump mapping, etc.) with a significant framerate improvement to boot.

    This might not fix your problem, though - I noticed in your other post that you had problems running Rise of Nations, which I had been running just fine for me before I did this fix... but you never know...

  16. schacker99

    schacker99 TS Rookie Posts: 20


    Sorry about the mixup. So far it has worked great!!! I didn't have any problems with Age but only with Dungeon Siege and Black and White...but I installed the chipset software utility and it works...damn is that a relief...so I can now return the $99.00 power supply. Did you download the accelerator too?
  17. kjl

    kjl TS Rookie Posts: 17

    No - I didn't download the accelerator; I'm of the technophobic school of keeping my computer as unspooky as possible.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...