probs with CMD

By Yakob ยท 7 replies
Feb 27, 2007
  1. right, this isn't down to a virus as i've scanned it recently. But my CMD or COMMAND.COM will not accept commands like Ping or net etc. i'v eattached a pic to show that. i was wondering if it could be something has gone haywire in my registry. it's actually quite anoying because my friend makes batch files that cause flashy screen :) but anyway back-on-track, if anybody knows how to sort out my cmd then plz let me know. i will be going to school in about 20 mins so i cannot speak for too long.

    Attached Files:

    • cmd.JPG
      File size:
      41 KB
  2. LNCPapa

    LNCPapa TS Special Forces Posts: 4,276   +461

    Actually - it just looks like your path environment variable might be lost. Sometimes it's as easy as re-entering it or even just a reboot. I would open up the variable - paste it into notepad - save it empty - then open it back up and paste it back in.
  3. Yakob

    Yakob TS Rookie Topic Starter Posts: 55

    will try that but it seems to stay like that no matter how many times i've reboot the pc. and it seems to have happened once i ran a batch file to remove a virus. all it did was removed a file using the simple DEL command. but since then it's not worked
  4. teradost

    teradost TS Rookie Posts: 32

    I had a similar problem, but it was with the "cd.." command. I was using the JVM for my Java class, and we compiled everything using the command line. I couldn't change directories, so I worked around the problem temporarily by moving all the project to the default folder.

    Anyways, I don't know how I fixed it, but it seems to have been corrected somehow. It might involve downloading Windows updates, using a registry cleaner, or repairing the OS.

    I can't help you much, but don't trash the computer because the problem CAN be FIXED.:cool:
  5. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    In command prompt, run "set" and post the output here.
  6. Yakob

    Yakob TS Rookie Topic Starter Posts: 55

    here you go.

    Attached Files:

  7. Nodsu

    Nodsu TS Rookie Posts: 5,837   +6

    Your PATH variable is screwed up.
    Take a close look at your screenshot - in the middle of the fouth line you see that the GTK and QuickTime entries have been merged.
    Put a semicolon (;) between \bin and C: (You can edit the system variables in System Properties->Advanced->Environment Variables)
  8. Yakob

    Yakob TS Rookie Topic Starter Posts: 55

    yay! thanks Nodsu, you have saved my life! ty :)
Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...