Promise RAID 1 Recovery Problem

By Wildwood
Jul 19, 2007
  1. Been happily running XP off a pair of WD Raptor disks configured as RAID 1 under the control of the on-board PROMISE 378 controller on my MSI 875P Neo-FISR (PCB 1.0).

    Last week the Promise controller Bios reported that the raid 1 array had gone" critical". I could still boot XP from the surviving drive. By trial and errr I identified which disk had failed and attempted to rebuild the array (option 5) which copies from the survivor to the failed drive.

    Rebuild appeared to be working, but at 8% complete the array again went "critical". I figured the target drive was stuffed.

    Next steps
    - ran ChkDsk across the survivor. No errors found.
    - replaced the target drive with a brand new WD Raptor
    - reran the rebuild process

    same error .... goes to 8% copying and the array goes "critical".

    Anybody got ideas as to what might be wrong and how recover? Various combinations of deleting/re-allocationg the array have been tried, but the rebuild fails at the 8% mark.

    System still runs on surviving drive, but I want my RAID 1 back!

Topic Status:
Not open for further replies.

Similar Topics

Add your comment to this article

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...